Helpful Links

External SD card

Contributor

External SD card

I'm using the Galaxy Note 2 and it's saying that my external sd card is not mounted but it is in the device. Does anyone know what to do in a case like this?
3,105 Views
Message 1 of 3
Highlighted
Professor

Re: External SD card

Have you tried rebooting the phone?  Try another card if you have access to one.  Also you can try to format the card on your computer (connected via a card reader) to FAT32.

 

If it still doesn't work after a reformat or with another card, its possible the card tray is damaged or defective.

Tags (1)
Message 2 of 3
Contributor

Re: External SD card

I did try rebooting it still didn't fix the problem. I've come to the conclusion that my sd card might be corrupt. I checked it on a computer it still didn't work. When I did put in a different card to my sd slot it worked.

Thank you for your tips. I didn't know what to do.
Message 3 of 3
Share this topic
Announcements

Find out how to track your iPhone's delivery!

Have questions about International Plans? Get the answers on Wed. 10/25 at Hello World: International Plans, from 1-4pm ET / 10am-1pm PT!

Let us help you upgrade and activate your device!

Additional Support