• Favorite forums
  • My latest badges
My latest badges
Subject Forum Replies New Author Views Last Post
This is a topic with new unread messages

0 0 0 0
Blog Idea Exchange There are no unread messages in this message board Q&A This is a topic with new unread messages This is a popular topic with no new messages This is a topic that you have replied to with new unread messages This is a popular topic that you have replied to with new unread messages This is a popular topic that you have replied to with new unread messages There are no new messages in this topic Solved! Message contains an attachment Message contains no text Message contains a video Message contains an image
View profile
Created: May 16, 2011
cellphonereviews4u Created: May. 16, 2011
Ive been getting around 6mbps so far.I've only had like 3-4 bars coverage so far.what speeds are you all experiencing so far?
Wireless Forum  •
476476 views
View profile
Created: Mar 1, 2011
cellphonereviews4u Created: Mar. 1, 2011
i got 4.11 mbps a few tmes on download speed, and upload about .43 mbps
Wireless Forum  •
1,0971097 views
0
View profile
Created: Mar 1, 2011
cellphonereviews4u Created: Mar. 1, 2011
ok so i was taking the sim card cover on the bottom of the phone off to just look inside for no good reason, and i pulled the cover off by the two sides and when it came off it cracked down the middle. what do i do? like can i take it back to the att store, i bought it off contract for 400 bucks, and i havent had it for thirty days, please help!
Wireless Forum  •
6,5866586 views
View profile
Created: Feb 17, 2011
cellphonereviews4u Created: Feb. 17, 2011
The H+ icon up in top right is a flaw, its only 3g, hspa+ isnt officially turned on until march 1st.
Wireless Forum  •
2,1712171 views
0
cellphonereviews4u has no accepted solutions.
cellphonereviews4u has no activity.
Activity Feed for cellphonereviews4u

Uploaded Images for cellphonereviews4u

No images available.