Sierra wireless Elevate drains battery when OFF as though it is on and in operating mode

Contributor

Sierra wireless Elevate drains battery when OFF as though it is on and in operating mode

Does anyone else have a Sierra Wireless Elevate mobile hotspot that drains the battery from full charge in the off mode in less than 12 hours as though it is on.  I have recently replaced the battery bought 1 from 2 different suppliers.  when each battery is fully charged if i unplug from charger when fully charged and off if i wait 12 hours the battery is dead, but i am sure it is off since we can no longer use and charge at the same time.

878 Views
Message 1 of 2
Community Manager

Re: Sierra wireless Elevate drains battery when OFF as though it is on and in operating mode

How is your device? If it's under a year, you should contact the warranty department. Are you shutting it off by holding the power button for few seconds?

 

Thanks,

Dmitriy


Rethink Possible


Did a post have a solution that worked for you? Help other people find solutions faster by marking posts that helped you as an "Accepted Solution". Learn about accepted solutions: Learn More.

Employee Contributor*
*I am an AT&T employee and the postings on this site are my own and don't necessarily represent AT&T's position, strategies or opinions.
Message 2 of 2
You must type a description before you click preview or reply.
Share this topic
Announcements

Are you looking to upgrade and activate your device?

Let us help make Ordering, Upgrading and Activating easy!

Additional Support