Ask a question
Search in Wireless Forums

Wireless Forum

Reply
Posted Dec 17, 2013
10:00:06 AM
MyATT app version 2.6.1 no longer works on iOS 5.1.1 iPhone 4S
Edited by Rats and Gods on Dec 17, 2013 at 11:19:21 AM

Hi all.

 

So here is my issue.

 

I have an iPhone 4S running 5.1.1 on AT&T. Due to my dislike of updating anyway and not really liking the newer firmwares, I don't want to update my iOS to the new iOS7. There are too many issues with this firmware that I would rather not deal with.

 

I have the MyATT app on my phone that I use to monitor and pay my AT&T and my U-Verse accounts. I updated it to version 2.6.1 as it was a bug fix. After this update, when I click on the "bill & pay" in the U-Verse account, I receive the below error:

 

 

So I click on the "report a problem" at the bottom of the page and get this:

 

 

 

This only happens on the U-Verse account. My AT&T mobile account, I am able to utilize the app just fine with no problems.

 

What I've tried to troubleshoot:

 

1. Deleting the app and reinstalling (via iTunes and via App Store on the iPhone itself)

2. Deleting current version and installing older versions of the app via iTunes

3. Deleting the app and downloading a fresh version of the app from the App Store

4. Deleting the U-Verse account in the app and reinputting the account info

5. Contacting AT&T and being told just to update the app/iOS (which if version 2.6.1 is still available for my iOS, this shouldn't be the only fix out there)

6. Resetting the Network Settings

 

Any other suggestions would be very helpful. I've searched all over the web and haven't found anything useful. Anyway, thanx for all the assistance in the past, present, and future.

 

Also moderators, if this is in the wrong place, please feel free to move it to the correct section of the forum. Thank you.

Hi all.

 

So here is my issue.

 

I have an iPhone 4S running 5.1.1 on AT&T. Due to my dislike of updating anyway and not really liking the newer firmwares, I don't want to update my iOS to the new iOS7. There are too many issues with this firmware that I would rather not deal with.

 

I have the MyATT app on my phone that I use to monitor and pay my AT&T and my U-Verse accounts. I updated it to version 2.6.1 as it was a bug fix. After this update, when I click on the "bill & pay" in the U-Verse account, I receive the below error:

 

 

So I click on the "report a problem" at the bottom of the page and get this:

 

 

 

This only happens on the U-Verse account. My AT&T mobile account, I am able to utilize the app just fine with no problems.

 

What I've tried to troubleshoot:

 

1. Deleting the app and reinstalling (via iTunes and via App Store on the iPhone itself)

2. Deleting current version and installing older versions of the app via iTunes

3. Deleting the app and downloading a fresh version of the app from the App Store

4. Deleting the U-Verse account in the app and reinputting the account info

5. Contacting AT&T and being told just to update the app/iOS (which if version 2.6.1 is still available for my iOS, this shouldn't be the only fix out there)

6. Resetting the Network Settings

 

Any other suggestions would be very helpful. I've searched all over the web and haven't found anything useful. Anyway, thanx for all the assistance in the past, present, and future.

 

Also moderators, if this is in the wrong place, please feel free to move it to the correct section of the forum. Thank you.

MyATT app version 2.6.1 no longer works on iOS 5.1.1 iPhone 4S

[ Edited ]
1,209 views
10 replies
(0) Me too
(0) Me too
Reply
View all replies
(10)
0
(0)
  • Rate this reply
View profile
Dec 17, 2013 2:50:48 PM
0
(0)
Tutor

Just chatted on the phone with an AT&T rep and they stated very rudely "you just need to upgrade that thing to the new iPhone". Wow! I would love to go ahead and upgrade if this was an option. Jeez. I just wanted help with an app that is supposed to work. Ironically all I'm trying to do is view/pay my U-Verse bill. You would think of all the things that they would make sure work in the app, it would be the "bill and pay" link.

Just chatted on the phone with an AT&T rep and they stated very rudely "you just need to upgrade that thing to the new iPhone". Wow! I would love to go ahead and upgrade if this was an option. Jeez. I just wanted help with an app that is supposed to work. Ironically all I'm trying to do is view/pay my U-Verse bill. You would think of all the things that they would make sure work in the app, it would be the "bill and pay" link.

Re: MyATT app version 2.6.1 no longer works on iOS 5.1.1 iPhone 4S

2 of 11 (1,154 Views)
0
(0)
  • Rate this reply
View profile
Dec 17, 2013 3:16:14 PM
0
(0)
Employee
Edited by loganic on Dec 17, 2013 at 3:18:00 PM

Hey Rats_and_Gods,

 

Yeah, from what little I know about programming, it takes a lot of resources to keep a program or app both backward and forward compatible.

 

On Itunes, the app is listed as required IOS 6.0 or higher.

https://itunes.apple.com/us/app/myat-t/id309172177

 

 

I don't know any legitimate way of getting an old version of the app, but I imagine, it might be easier to maybe get ios 6.0 without ios 7.0

You may either need to find a compatible version of the app, or get a the right version of ios that meets the minimum requirements for this one.

 

-Alex

Hey Rats_and_Gods,

 

Yeah, from what little I know about programming, it takes a lot of resources to keep a program or app both backward and forward compatible.

 

On Itunes, the app is listed as required IOS 6.0 or higher.

https://itunes.apple.com/us/app/myat-t/id309172177

 

 

I don't know any legitimate way of getting an old version of the app, but I imagine, it might be easier to maybe get ios 6.0 without ios 7.0

You may either need to find a compatible version of the app, or get a the right version of ios that meets the minimum requirements for this one.

 

-Alex

*I am an AT&T employee and the postings on this site are my own and don’t necessarily represent AT&T’s position, strategies or opinions.
*I am an AT&T employee and the postings on this site are my own and don’t necessarily represent AT&T’s position, strategies or opinions.

Re: MyATT app version 2.6.1 no longer works on iOS 5.1.1 iPhone 4S

[ Edited ]
3 of 11 (1,148 Views)
0
(0)
  • Rate this reply
View profile
Dec 17, 2013 3:36:48 PM
0
(0)
Tutor
Edited by Rats and Gods on Dec 17, 2013 at 3:41:00 PM

Hi Alex, being on iOS 5.1.1, when you install it from the App Store, it says the current version (3.0.3) is available for iOS6 and higher and gives you the option to install the last compatible version (2.6.1) to the iDevice.

As far as old versions, I still had an older version (2.4.1) on iTunes and installed it via that way. The 2.4.1 version would install ok but wouldn't open at all. Just flashes and then closes back to the home screen.

Hi Alex, being on iOS 5.1.1, when you install it from the App Store, it says the current version (3.0.3) is available for iOS6 and higher and gives you the option to install the last compatible version (2.6.1) to the iDevice.

As far as old versions, I still had an older version (2.4.1) on iTunes and installed it via that way. The 2.4.1 version would install ok but wouldn't open at all. Just flashes and then closes back to the home screen.

Re: MyATT app version 2.6.1 no longer works on iOS 5.1.1 iPhone 4S

[ Edited ]
4 of 11 (1,142 Views)
0
(0)
  • Rate this reply
View profile
Dec 17, 2013 4:33:17 PM
0
(0)
Employee
This is basically same issue those with ipad 1 have but they cannot upgrade to IOS7 stuck on 5, no longer works...response buy newer ipad need ver 2 or higher.

http://forums.att.com/t5/Applications/Need-iPad-app-won-t-work-on-older-iPad/td-p/3783675

Your option upgrade or not, if not cannot use app, your choice.
This is basically same issue those with ipad 1 have but they cannot upgrade to IOS7 stuck on 5, no longer works...response buy newer ipad need ver 2 or higher.

http://forums.att.com/t5/Applications/Need-iPad-app-won-t-work-on-older-iPad/td-p/3783675

Your option upgrade or not, if not cannot use app, your choice.
*I am an AT&T employee and the postings on this site are my own and don’t necessarily represent AT&T’s position, strategies or opinions.

Re: MyATT app version 2.6.1 no longer works on iOS 5.1.1 iPhone 4S

5 of 11 (1,116 Views)
0
(0)
  • Rate this reply
View profile
Dec 17, 2013 4:44:32 PM
0
(0)
Tutor
This is a pretty sad response though as you're basically saying your iDevice is obsolete in that case and the customer is now forced to either buy a new one (spend more money) or not use the resources out there (apps) because they no longer work on the device because it's been updated.

Keep in mind that there is a version of this app (2.6.1) available to anyone on iOS5 in the App Store that is stated to be compatible with the specific firmware I'm on yet when using it to attempt to pay my U-Verse bill, it says I can't connect to AT&T. So it's almost like AT&T did something to not allow the app version (2.6.1) to work any longer. It doesn't seem to be an issue with the app itself as it works perfectly for my AT&T mobile account. Can this be confirmed?
This is a pretty sad response though as you're basically saying your iDevice is obsolete in that case and the customer is now forced to either buy a new one (spend more money) or not use the resources out there (apps) because they no longer work on the device because it's been updated.

Keep in mind that there is a version of this app (2.6.1) available to anyone on iOS5 in the App Store that is stated to be compatible with the specific firmware I'm on yet when using it to attempt to pay my U-Verse bill, it says I can't connect to AT&T. So it's almost like AT&T did something to not allow the app version (2.6.1) to work any longer. It doesn't seem to be an issue with the app itself as it works perfectly for my AT&T mobile account. Can this be confirmed?

Re: MyATT app version 2.6.1 no longer works on iOS 5.1.1 iPhone 4S

6 of 11 (1,113 Views)
0
(0)
  • Rate this reply
View profile
Dec 17, 2013 6:06:22 PM
0
(0)
ACE - Master

If you have recently installed the update via iTunes, then you should still have the old version in your recycle bin.  If you do, then you can replace the newer version (which doens't work with your iOS version) with the older release (that does work with your iOS version).  I have had to do that many times with other apps that had compatibility issues.  It is not uncommon for developers to drop support for iOS versions older than the most recent one or two releases.  I know one developer who is dropping support for iOS 5 and 6 in the next release of their app.

 

Once you find the IPA file for the older version of the app, just open your iTunes and drag/drop the top left corner of your iTunes window and it should ask you if you want to replace the newer version with the older one.  Tell it you do, and it should do so.  You may need to manually delete the newer version of the app from your device in order to get iTunes to load the older one onto your device.  

 

As a side note, you will probably want to make sure that you keep a backup copy of the older version safely stored someplace on your computer incase you ever accidentally upgrade the app in iTunes.


Jerry B.
"GeekBoy"

--

For additional help, please send a PM to ATTCustomerCare.

If you have recently installed the update via iTunes, then you should still have the old version in your recycle bin.  If you do, then you can replace the newer version (which doens't work with your iOS version) with the older release (that does work with your iOS version).  I have had to do that many times with other apps that had compatibility issues.  It is not uncommon for developers to drop support for iOS versions older than the most recent one or two releases.  I know one developer who is dropping support for iOS 5 and 6 in the next release of their app.

 

Once you find the IPA file for the older version of the app, just open your iTunes and drag/drop the top left corner of your iTunes window and it should ask you if you want to replace the newer version with the older one.  Tell it you do, and it should do so.  You may need to manually delete the newer version of the app from your device in order to get iTunes to load the older one onto your device.  

 

As a side note, you will probably want to make sure that you keep a backup copy of the older version safely stored someplace on your computer incase you ever accidentally upgrade the app in iTunes.


Jerry B.
"GeekBoy"

--

For additional help, please send a PM to ATTCustomerCare.

Jerry B.
"GeekBoy"

--

For additional help, please send a PM to ATTCustomerCare.
*The views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.

Re: MyATT app version 2.6.1 no longer works on iOS 5.1.1 iPhone 4S

7 of 11 (1,085 Views)
0
(0)
  • Rate this reply
View profile
Dec 18, 2013 6:45:03 AM
0
(0)
Tutor

That's the thing. I didn't update to 3.0.3 as it won't allow it. I had version 2.6.1 when the update came out. It installed and worked perfectly fine for my mobile account and my U-Verse account. Then about two months ago, it quit allowing me to see my bill and pay feature on the U-Verse side. So I don't think it's the App.

 

I have tried the installing an older version (2.4.1) of the app and it will install fine just won't open on my phone. I don't remember if version 2.4.1 was compatible with iOS5 though so that could be it. If I could find a version of 2.6 that would be great but the App Store doesn't let you choose which version to download and install unfortunately.

That's the thing. I didn't update to 3.0.3 as it won't allow it. I had version 2.6.1 when the update came out. It installed and worked perfectly fine for my mobile account and my U-Verse account. Then about two months ago, it quit allowing me to see my bill and pay feature on the U-Verse side. So I don't think it's the App.

 

I have tried the installing an older version (2.4.1) of the app and it will install fine just won't open on my phone. I don't remember if version 2.4.1 was compatible with iOS5 though so that could be it. If I could find a version of 2.6 that would be great but the App Store doesn't let you choose which version to download and install unfortunately.

Re: MyATT app version 2.6.1 no longer works on iOS 5.1.1 iPhone 4S

8 of 11 (1,054 Views)
0
(0)
  • Rate this reply
View profile
Dec 19, 2013 8:14:22 AM
0
(0)
Scholar
Edited by jane697 on Dec 19, 2013 at 8:17:25 AM

So if I'm interpreting OP's last reply (above) correctly, he's saying that 2.6.1 was working perfectly/correctly in allowing him to check both his mobile and U-Verse accounts...then about two months ago for whatever reason he is no longer able to use the bill and pay feature on his U-Verse account using 2.6.1.  Assuming the iOS level on his iPhone has not changed at all during the entire time, then I can only speculate the following:

 

1) AT&T has changed the manner in which access to the the U-Verse account is authenticated sometime since the last time OP was able to access his U-Verse account successfully, to the point that it is no longer possible to access U-Verse using 2.6.1

 

2) Some other application(s) on OP's iPhone installed since the last time he was able to access his U-Verse account successfully using 2.6.1 is causing a conflict that is preventing him from accessing it

 

To OP--are you no longer able to view anything at all on your U-Verse account...or is the issue limited to only the bill and pay feature in U-Verse?  Sorry if the question sounds a bit obtuse--I don't have U-Verse so I don't know what info about U-Verse is available in the myATT app.

So if I'm interpreting OP's last reply (above) correctly, he's saying that 2.6.1 was working perfectly/correctly in allowing him to check both his mobile and U-Verse accounts...then about two months ago for whatever reason he is no longer able to use the bill and pay feature on his U-Verse account using 2.6.1.  Assuming the iOS level on his iPhone has not changed at all during the entire time, then I can only speculate the following:

 

1) AT&T has changed the manner in which access to the the U-Verse account is authenticated sometime since the last time OP was able to access his U-Verse account successfully, to the point that it is no longer possible to access U-Verse using 2.6.1

 

2) Some other application(s) on OP's iPhone installed since the last time he was able to access his U-Verse account successfully using 2.6.1 is causing a conflict that is preventing him from accessing it

 

To OP--are you no longer able to view anything at all on your U-Verse account...or is the issue limited to only the bill and pay feature in U-Verse?  Sorry if the question sounds a bit obtuse--I don't have U-Verse so I don't know what info about U-Verse is available in the myATT app.

Re: MyATT app version 2.6.1 no longer works on iOS 5.1.1 iPhone 4S

[ Edited ]
9 of 11 (946 Views)
0
(0)
  • Rate this reply
View profile
Dec 19, 2013 8:34:37 AM
0
(0)
Master

In following this thread, I think there are a couple of things here.  I do not think the ATT rep meant you need to change to a newer iPhone.  Your iPhone 4S is just fine!  I think he meant that you need to upgrade to iOS7.  I would strongly agree here!!

 

Apple does offer at times older versions of programs for iPhones that cannot support the lastest iOS release however in this case your iPhone 4S does support the latest iOS version and hence Apple assumes you will be using it. BTW it runs it very nicely based on what I see on my wifes iPhone.

 

I also think that ATT has changed some things behind the scenes and the old version of the program cannot access the data based on the old API's.  Again upgrading to iOS 7 will solve your problem.  This is not uncomon for developers.  Just look at Twitter and their requirement that the 1.0 API can no longer be used by programs.  Older programs that are not updated by the developer were cut off.  I do not think this is unreasonable for a developer to keep moving forward to enhance their programs to make them even better but sometimes that means elimianating old ways of doing things.

 

I think you are trying to find a solution that does not fit within the Apple ecosystem.  Your iPhone will run iOS 7 just fine but you do not want to upgrade.  That is your choice but it is not necessarily ATT's or developers fault or problem that thier old programs no longer work.  I would also suggest that in the new iOS versions are important security fixes that you are missing out on.

 

If you choose to stay on your current iOS version, this problem may become more prevelant with other developers and systems.  It is your choice to use your iPhone 4s as you see fit but there are implications for upgrading or not.

 

Good Luck!

_____________________

For service or support questions including existing order status, call:
Customer Support: 1-800-331-0500

Information on iPhone unlocking can be found here by copying this link into your browser:
https://www.att.com/deviceunlock/client/en_US/

In following this thread, I think there are a couple of things here.  I do not think the ATT rep meant you need to change to a newer iPhone.  Your iPhone 4S is just fine!  I think he meant that you need to upgrade to iOS7.  I would strongly agree here!!

 

Apple does offer at times older versions of programs for iPhones that cannot support the lastest iOS release however in this case your iPhone 4S does support the latest iOS version and hence Apple assumes you will be using it. BTW it runs it very nicely based on what I see on my wifes iPhone.

 

I also think that ATT has changed some things behind the scenes and the old version of the program cannot access the data based on the old API's.  Again upgrading to iOS 7 will solve your problem.  This is not uncomon for developers.  Just look at Twitter and their requirement that the 1.0 API can no longer be used by programs.  Older programs that are not updated by the developer were cut off.  I do not think this is unreasonable for a developer to keep moving forward to enhance their programs to make them even better but sometimes that means elimianating old ways of doing things.

 

I think you are trying to find a solution that does not fit within the Apple ecosystem.  Your iPhone will run iOS 7 just fine but you do not want to upgrade.  That is your choice but it is not necessarily ATT's or developers fault or problem that thier old programs no longer work.  I would also suggest that in the new iOS versions are important security fixes that you are missing out on.

 

If you choose to stay on your current iOS version, this problem may become more prevelant with other developers and systems.  It is your choice to use your iPhone 4s as you see fit but there are implications for upgrading or not.

 

Good Luck!

_____________________

For service or support questions including existing order status, call:
Customer Support: 1-800-331-0500

Information on iPhone unlocking can be found here by copying this link into your browser:
https://www.att.com/deviceunlock/client/en_US/
Posted from my iPhone _____________________________ For service or support questions including existing order status, call: Customer Support: 1-800-331-0500 Information on iPhone unlocking can be found here by copying this link into your browser: https://www.att.com/deviceunlock/client/en_US/

Re: MyATT app version 2.6.1 no longer works on iOS 5.1.1 iPhone 4S

10 of 11 (941 Views)
Highlighted
0
(0)
  • Rate this reply
View profile
Dec 19, 2013 10:05:58 AM
0
(0)
Tutor
You have hit the nail right on the head. I think speculation #1 is probably what is going on as I've pretty much had the same stuff installed on my iPhone 4s since I've had it. I don't really use it for much other than to talk, text, and bills. Even web searching and such isn't really priority.

I can login to my U-Verse account but the second I go to anything within it, it gives me that error.

I can still pay my mobile bill and access the web to pay U-Verse via the website. Just was much easier to have the app to do it in.
You have hit the nail right on the head. I think speculation #1 is probably what is going on as I've pretty much had the same stuff installed on my iPhone 4s since I've had it. I don't really use it for much other than to talk, text, and bills. Even web searching and such isn't really priority.

I can login to my U-Verse account but the second I go to anything within it, it gives me that error.

I can still pay my mobile bill and access the web to pay U-Verse via the website. Just was much easier to have the app to do it in.

Re: MyATT app version 2.6.1 no longer works on iOS 5.1.1 iPhone 4S

11 of 11 (933 Views)
Advanced
You must be signed in to add attachments
Share this post
Share this post