Email-to-SMS with iPhone 5

Contributor

Email-to-SMS with iPhone 5

[ Edited ]

This isn't so much a question as a report of the problem I'm having. Maybe it will help someone else.

 

I have a new phone, new number, new account.  Just signed up, just activated.  It's an iphone5.

Runs ios6, latest version.

 

I understood that any email client (like hotmail, yahoo, gmail, any corporate email) could send an SMS to any AT&T subscriber's wireless device by using the address XXXXXXXXXX@txt.att.net, where the X's are replaced by the 10-digit AT&T wireless subscriber's wireless telephone number.

 

I have another AT&T wireless number, and this works flawlessly.  I also use this to send SMS to my friends and colleagues, who use AT&T Wireless. So I know this "works" normally.


For some reason this does not work for my new phone.  When I send an email to the address corresponding to my own wireless number, I get an error report email from the email system. The error email I get from my outgoing email server (I am using hotmail) says:

Delivery to the following recipients failed.
 
       9876543210@txt.att.net
 
 

 ..where 9876543210 is replaced by my own subscriber number.

 

There is an attachment to the error email. In the attachment is a text file containing this message from AT&T's system:

Reporting-MTA: dns;blu0-omc2-s27.blu0.hotmail.com
Received-From-MTA: dns;BLU159-W27
Arrival-Date: Mon, 19 Nov 2012 11:39:59 -0800

Final-Recipient: rfc822;9876543210@txt.att.net
Action: failed
Status: 5.5.0
Diagnostic-Code: smtp;550 Invalid recipient: <9876543210@txt.att.net>

 

If I try the same thing but send to 9876543210@mms.att.net, which is the address for MMS messages (for binary attachments including pictures), then I get a similar message:

Reporting-MTA: dns; schemailmta07.cingularme.com
Arrival-Date: Mon, 19 Nov 2012 13:43:27 -0600
Received-From-MTA: dns; schemailedgegx01.cingularme.com (172.16.130.170)

Final-Recipient: RFC822; <9876543210@mms.att.net>
Action: failed
Status: 5.1.1
Remote-MTA: dns; localhost.localdomain (127.0.0.1)
Diagnostic-Code: smtp; 550 Invalid recipient: <9876543210@cingularme.com>

 

... and I also  get this:

This Message was undeliverable due to the following reason:

Each of the following recipients was rejected by a remote mail server.
The reasons given by the server are included to help you determine why
each recipient was rejected.

    Recipient: <9876543210@mms.att.net>
    Reason:    Invalid recipient: <9876543210@cingularme.com>


Please reply to <Postmaster@cingularme.com>
if you feel this message to be in error.

 

When I login to myAT&T and send a text message to my phone through the web interface, it works just fine.  Also I can send/receive SMS to/from other SMS systems, just fine. 

 

I have contacted AT&T Support by dialing 611.  They've reproduced the problem and confirmed that this is an unexpected result. I have a ticket number, and they'll get back to me.

 

The problem I'm seeing is very similar to problems that have been reported here sporadically by other AT&T wireless users over the years. I found similar reports dating back to 2007. (try googling:  "Invalid recipient" txt.att.net ) I never saw much real information as to the resolution to those problems. In two cases I saw responses like: I contacted AT&T support and they provisioned this feature in my wireless account.   I don't know what that means and neither did the AT&T Support person I spoke with (who was very sympathetic and professional, by the way).

 

So I'm not expecting the community to help out on this.  I'm just reporting this here so that I can post the solution, when I get it, and help someone else out in the future.

 

 

Message 1 of 11 (6,417 Views)
ACE - Master

Re: Email-to-SMS with iPhone 5

When you say new number, how new? Was it just activated today? Just guessing here but I expect this is just a temporary issue because your new number has not yet populated to the server that handles incoming emails. In essence the receiving email server does not recognize the email address:

 

Diagnostic-Code: smtp;550 Invalid recipient: <9876543210@txt.att.net>

You get the same response when you send to any invalid email address. I don't know how long it takes for new numbers to populate to the email server bu I'd give it at least 24 hours.

*The views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.
Message 2 of 11 (6,388 Views)
Contributor

Re: Email-to-SMS with iPhone 5

[ Edited ]

AT&T has disabled the Email-to-SMS gateway as of today, citing spam reduction. The gateway now only works for business and enterprise customers.

 

Some have mentioned success using mms.att.net, but I imagine that may be disabled soon as well...

Message 3 of 11 (6,309 Views)
Highlighted
Guru

Re: Email-to-SMS with iPhone 5

It is still working for me sending it to @txt.att.net
Message 4 of 11 (6,233 Views)
Expert

Re: Email-to-SMS with iPhone 5

Do you have a link to the online article stating this information?.
Message 5 of 11 (6,226 Views)

Re: Email-to-SMS with iPhone 5

I stopped receiving SMS texts from the gateway as of November 12, 2012. What is really absurd is that AT&T Unified Messaging (I have it on my business lines) notifications of received voicemails are also not being received and appear to use the same email to SMS gateway. I was told by 3rd level Mobility tech support yesterday afternoon that they were aware of a "widespread" problem, and promised it would be fixed in "24 hours". I'm still waiting......

Message 6 of 11 (6,193 Views)
Scholar

Re: Email-to-SMS with iPhone 5

I can still send texts to my phones using the @txt.att.net address.
Message 7 of 11 (6,065 Views)
Guru

Re: Email-to-SMS with iPhone 5


gphipps wrote:
I can still send texts to my phones using the @txt.att.net address.
I just tried and I still can send them too!
Message 8 of 11 (6,017 Views)
Scholar

Re: Email-to-SMS with iPhone 5

I hope they don't disable that option. I use it quite a bit to send messages to my kids from work.
Message 9 of 11 (5,993 Views)
Teacher

Re: Email-to-SMS with iPhone 5

Considering the mms.txt.net instructions and address are still on the AT&T website, I don't understand this claim that it's been disabled to prevent spam.  Let people block spam if they want.

 

The more likely explanation is ... money.  AT&T wants you to buy more data and stop using mms.txt.net.

Message 10 of 11 (2,762 Views)
Scholar

Re: Email-to-SMS with iPhone 5

Every user can decide for himself/herself whether they want to block e-mail to SMS. The instructions are right here.

 

https://www.att.com/esupport/article.jsp?sid=KB92125#fbid=abBl9Tta5Pt

 

Personally, I think it is very important to offer a block because otherwise anyone can e-mail your SMS number and you get dinged for the cost of the message.

Message 11 of 11 (2,739 Views)
Share this topic
Announcements

Welcome to the AT&T Community Forums!!! Stop by the Community How-To section for tips on how to get started.