Can't send or receive picture/group messages on my Pantech Ease (P2020)

Contributor

Can't send or receive picture/group messages on my Pantech Ease (P2020)

Since getting my new phone, I have had an annoying problem where I'm unable to read group messages sent to me by others. I also can't send or receive picture messages (they both show up the same on my phone). I don't know how to create a group message, so I'm not sure if I can send them (but I suspect the answer is no).

 

When I try to view a picture or group message, I get a metadata screen giving the subject, priority, date, sender, and size, and options to delete, retrieve, or reply. When I hit "Retrieve", the phone tries to download for a while, makes no progress, then gives me the error message "Downloading has been Failed [sic]". Sending a picture message gives a similar problem; it just says "Sending failed".

 

I haven't changed any of my messaging settings since getting the phone so I don't see why this keeps failing. My old flip phone could receive group messages and send/receive picture messages just fine. What could the problem be?

Message 1 of 4 (3,144 Views)

Re: Can't send or receive picture/group messages on my Pantech Ease (P2020)

Hello dpitch,

Do you have a Data Plan active on your line?
Message 2 of 4 (3,105 Views)
ACE - Master

Re: Can't send or receive picture/group messages on my Pantech Ease (P2020)


julywashere wrote:
Hello dpitch,

Do you have a Data Plan active on your line?

The Pantech Ease is not a smart phone so a data plan is not required, however a working data connection is needed for picture messages to work. OP needs to ensure cellular data is enabled and no data block is in place.

*The views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.
Message 3 of 4 (3,094 Views)
Contributor

Re: Can't send or receive picture/group messages on my Pantech Ease (P2020)

I had to create a new MMS profile with a different (preprogrammed) connection type and look up some proxy information online to enter. This allowed multimedia messages to work. I don't get why my phone couldn't have come with this setting as the default if it's the correct one.

Message 4 of 4 (3,038 Views)
Share this topic
Announcements

Welcome to the AT&T Community Forums!!! Stop by the Community How-To section for tips on how to get started.