Helpful Links

Activating Microcell w/ Comcast home internet


Activating Microcell w/ Comcast home internet

We recently moved to a condo that is pre-wired for Comcast home internet service (I believe it is the xFinity service). In trying to set-up our Microcell, we have been unable to activate. We have it connected to the Comcast modem via ethernet. We get three solid green lights and a blinking green light at bottom. 


I did a bit of searching these forums and elsewhere online and don't see anything that specifies that Comcast would be blocking the traffic from an MCell.


Am I doing something wrong? I'd like to avoid having both parties pointing the finger at the other and not get anywhere.


Any advice?



Message 1 of 17

Re: Activating Microcell w/ Comcast home internet

For the benefit of others...


I spent a lot of time trying to get my microcell working and couldn't get any help whatsoever (tried Comcast, AT&T, Cisco and the vendors of the actual Gateways I was dealing with). So I'm hoping this saves someone else time.


Some background: I had the "priority connection" working for months home. This is not so great because if you want to have other devices (such as a camera) accessible from outside your network, you can't. But the real reason I had to move away from this was Comcast itself... I got a new Comcast gateway (Technicolor TC8305C) when I upgraded my account; the gateway is a modem/wireless router combo. I first had Comcast "downgrade" my Gateway into only a modem (called running in Bridged Mode). Then I setup priority connection again and things were fine for ... about a week. The mCell then couldn't connect any longer to the Internet. I called and Comcast couldn't get it to work (a computer connected directly to the modem would connect fine to the Internet though...). I already wanted (for other reasons) to not have the MCell in Priority Connection, so I decided to take on Comcast!


I went to the Comcast store and picked up all three of their Gateways. I was first successfully getting  the Arris TG862 working, but that Gateway is buggy and once I added two static IP's, I could no longer go to the "connected devices" page, which is where one adds more static IPs. Given that I have quite a few other access points in my house, this was useless. I then reverted to the Technicolor and tried the same there... and it worked. Here's what I know:


1. Start fresh (revert your Gateway to "factory settings")


2. Boot up the router, connect to it and DO NOT CHANGE ANYTHING (such as intranet IP address range, etc.)


3. From the bottom of the MCell, get the MAC address.


4. Give your router a range for static IP's (i.e. configure it so that DHCP starts at, say,


5. Create a static IP for the MCell using the MAC address from (3)


6. Put the static IP of the MCell in the DMZ


7. This is speculative, but just in case, turn the Firewall off. You can turn it back on (to highest setting) after all steps.


8. Connect the Gateway and plug the power cord (i.e. turn it on)


9. The MCell should connect briefly.


10. Now, and only now, plug into the Gateway another other ethernet devices you might have (i.e. a main switch)


I've also noticed that when I cycle the Gateway or disconnect the cable from the Gateway and reconnect it, I have to power cycle the MCell.


Hope this helps. If nothing else, at least know that it is possible to connect an MCell to a Technicolor or Arris gateway provided by Comcast w/o using Priority Connection.


Message 16 of 17
ACE - Master

Re: Activating Microcell w/ Comcast home internet

Glad you got it working. A lot of this is covered in the Guide (link in my sig). It doesn't specificially mention the types of modems/gateways but port forwarding is, as well as using a static ip address based on the MicroCell's MAC address. The mandatory basic router configurations are also covered.


My gateway is set to Bridged Mode and I let my router (Apple Extreme Base Station) handle all of the traffic. I have it set to port forward the required ports to a static-assigned ip address for the MicroCell. Priority connection is a great way to troubleshoot if your gateway is set to Bridged Mode because it rules out the router which narrows down considerably the possible problems. However, there is nothing wrong with leaving it in Priority Connection if that works best for you.


Usually if your connection is fine and there haven't been any changes on your end and there's a sudden loss of connectivity it's more than likely something your ISP has done. In situations like this I always recommend folks to check the obvious things first like loose cables, the cat chewed on a cable, the ac adapter is getting hot to the touch, things like that.


MicroCell Technical Guide by Otto Pylot

"Quick Tips: My Microcell Doesn't Work"

I am not an AT&T employee. For additional help, please send a PM to ATTMobilityCare

*The views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.
Message 17 of 17
Share this topic

Is the iPhone X worth it? Find out why it totally is!

Find out how to track your iPhone's delivery!

Let us help you Give the Gift of AT&T Wireless this holiday season!

Additional Support