evergreen a-667 takes forever to become functional

Highlighted
Tutor

evergreen a-667 takes forever to become functional

When I turn off my phone, then turn it back on, it takes hours - literally I have been waiting since noon (and it is 2:33 pm right now) before the address book and my inbox/outbox become accessible again.

 

Does anyone know any steps I need to take to make this happen sooner?

 

187 Views
Message 1 of 2
Tutor

Re: evergreen a-667 takes forever to become functional

Well, it took 18 hours, but the phone finally started working yesterday morning. Then, a few hours later, I pulled the phone out of my pocket and it was "dark". No amount of pushing buttons, including the power on, seemed to help. I took it home, plugged it in, and the battery charging animation came on, but indicating a nearly charged battery. I pressed the power on button and it booted up. I let it charge all the way, unplugged it, read a few texts, and sat it down. Next time I picked it up, a few hours later, it was dark again. Again, pushing the power button didn't help, but plugging it in again launched into charging mode - showing a nearly full battery. Anyone ever see this kind of problem before?
Message 2 of 2
You must type a description before you click preview or reply.
Share this topic
Announcements

Find the Unlimited Plan that works best for you at our Knowledge Sharing Session: Whole Lotta' Data Going On on Wed. 6/28 from 1-4pm ET / noon-3pm CT / 10am-1pm PT!

Find out the very latest about the new iPad Pros!

Are you looking to upgrade and activate your device?

Let us help make Ordering, Upgrading and Activating easy!

Additional Support