Helpful Links




I finally received my iPhone 4 today and it automactially recognized my wireless DSL at home. I typed in the password and all.


However, it doesn't show the wifi emblem beside the ATT emblem in the top left corner. It instead is using 3G...


How can I make it use Wifi..

Message 1 of 2

Re: WiFi...

Double check the settings, open and try forgetting the network and reconnecting. If that doesnt work then you might want to try a network reset. Settings, General, Reset, Reset Network Settings.

Enter the info again, if its still no-go then I would call AppleCare and see if they can walk you through some troubleshooting. 1-800-MY-IPHON(E).

The issue could be:

  • Wrong encryption type selected
  • Router configuration issue
  • Network settings (reset should fix)
  • The iPhone cannot get DNS or DHCP from the router

If those sounded like another language, I would call AppleCare first to walk to you through the troubleshooting.

Hope this helps!

Message 2 of 2
You must type a description before you click preview or reply.
Share this topic

Are you looking to upgrade and activate your device?
Let us help make Ordering, Upgrading and Activating easy!

AT&T Locker is being discontinued on August 3rd. Find out what you need to do.

Additional Support