Helpful Links

Why won't my iPhone connect to my wireless router, and now I cant get sound. What's the deal?!

Voyager

Why won't my iPhone connect to my wireless router, and now I cant get sound. What's the deal?!

My iphone will no longer connect to my wireless network, and I've done all the things I can do such as:

 

  • Restore to factory settings
  • Reset my Wi-Fi setting
  • Manually put in my router that I want to connect to

Still nothing, and then a few days ago my sound srop working for all my Apps even my ring for my phone doesnt work. The only volume on my phone is either when I'm on youtube, or have my headphones plugged in. So can i get some help, please?


Edit: I'm a goof it was on vibrate the whole time Smiley Very Happy

But wireless is on and still not working.

Message Edited by hexedfairy on 02-13-2010 03:40:08 PM
Message Edited by hexedfairy on 02-13-2010 03:40:42 PM
11,630 Views
Message 1 of 4
Professor

Re: Why won't my iPhone connect to my wireless router, and now I cant get sound. What's the deal?!

What do you mean by "doesn't connect"? Is the iPhone not actually detecting the router's SSID? Is it connecting, but no internet access? Are any other devices being affected?

 

Make and model of your router? 

Message 2 of 4
Former Employee

Re: Why won't my iPhone connect to my wireless router, and now I cant get sound. What's the deal?!

Try to reset your router. As with your sound issue, I know this will sound dumb, but check the switch on the left side, right above the volume, make sure it's not in the bottom position and you don't see a red dot (Silent mode).
Message 3 of 4
Voyager

Re: Why won't my iPhone connect to my wireless router, and now I cant get sound. What's the deal?!

I have had the same problem too since upgrading to 3.1.3  My WiFi will only connect to my Home wireless network.  If I'm out and about it no longer looks for networks such as when your at McDonalds or somewhere.  You have to go to settings and connect.  The phone says its connected; but, the data stays on the cellular data when you are using.  I live in an Edge area so it is very annoying.  Have also done all the resets but no luck.
Message 4 of 4
Share this topic
Announcements
Additional Support