Touch screen is locked and nothing works

Contributor

Touch screen is locked and nothing works

I have a Mythic modle, and the touch screen is locked and nothing works, even holding down the area to unlock it doesn't work!

 

The option to reset the phone assumes that the menu works but it doesn't work since it is a button on the screen!  

Message 1 of 2 (318 Views)
Master

Re: Touch screen is locked and nothing works

I hate to tell you this, but I think your Mythic is doomed. The same exact thing happened to me earlier this year, and I didn't think much of it until I got past the unlock screen, only to find out that the touch screen was completely unresponsive, rendering the phone completely unusable. You can actually unlock the phone from the lock screen by holding the lock button located on the upper high right side of the phone if you didn't already know. That will unlock it - the problem is, does your entire touch screen work, now?

If it does not, try turning the phone off and back on. If it still is unresponsive, pull the battery out while the phone is on. Turn the phone back on and see what happens. If the touch screen is still not responding, take out both the battery and SIM card and leave them out for a couple of hours. Place them back in later and see what happens.

Believe me, I tried EVERYTHING to save my Mythic. Unfortunately, it's completely shot. I had to replace it with a Captivate as I needed a phone. I really do miss my Mythic, and I hope your's works all right once you get past the unlock screen.

Good luck.

Cat Happy Remember that Wild Banchi... 1993-2010 Cat Happy



Message 2 of 2 (301 Views)
Share this topic
Announcements

Welcome to the AT&T Community Forums!!! Stop by the Community How-To section for tips on how to get started.