Strange email push latency problem

Highlighted
Mentor

Strange email push latency problem

I have many email addresses defined to my BB 9700.

Recently, my BB has been having issues with my main work email address. 

I did many tests to measure the latency.  Yesterday, at 12:09p, I sent a single email to 3 accounts hosted at goDaddy and to my account at att.blackberry.net (as a control):

 

  1. Account at att.blackberry.net received it within seconds
  2. goDaddy Account #1 received it within seconds
  3. goDaddy Account #2 received it within seconds
  4. goDaddy Account #3 received it @ 3:25a.  This is my main work email account.  More than 15 hours is clearly unacceptable.  Sometimes emails are delayed 3 hours, sometimes 4h, sometimes 9h, this case 15h and sometimes they never arrive.  Remember, this account too used to work within seconds.

I checked the definitions at goDaddy, on the BB and via the old BIS website and all 4 seems to be defined exactly the same.  Any ideas?

Message 1 of 6 (476 Views)
RCA
Mentor

Re: Strange email push latency problem

[ Edited ]

Are email accounts 1,2 and 3 all hosted with GoDaddy (EDIT: nevermind, i see you said they are hosted with GoDaddy)? Or do you have your record(s) pointed to another email host?

 

With email account #3, my only suggestion is to delete it from the phone, pull the battery (reset phone), and then re-enter the email account. You might also try resending the service books as well.

Message 2 of 6 (468 Views)
Mentor

Re: Strange email push latency problem

@RCA Thanks for the suggestions, but I tried both of those before I posted.

Message 3 of 6 (452 Views)
Mentor

Re: Strange email push latency problem

I checked with GoDaddy and for account#3, they report that the email hit the webmail server within seconds, so they believe it's a carrier (AT&T) problem...

Message 4 of 6 (437 Views)
Mentor

Re: Strange email push latency problem

So I spent the whole morning with goDaddy then AT&T then RIM (BlackBerry).  We tried everything: deleting Service Books and resending; deleting the email account and re-adding (once thru the BIS website and a second time from the BB); and many other things BB tried in the background.  Mike @ RIM was fantastic and tried everything.  When all else failed, Mike read the the fora and found a similar case and suggested I:

  1. Delete the account from the BB
  2. Pull the Battery
  3. Delete the account from GoDaddy
  4. Wait a bit
  5. Re-add the account at GoDaddy
  6. Put the battery back in
  7. Re-add the account on the BB

Well, what do you know that worked!!!Smiley Very Happy

Message 5 of 6 (430 Views)
RCA
Mentor

Re: Strange email push latency problem

Thanks for posting the results.
Message 6 of 6 (411 Views)
Share this topic
Announcements

Welcome to the AT&T Community Forums!!! Stop by the Community How-To section for tips on how to get started.