Samsung Galaxy S2 will not connect to 3G Microcell

Contributor

Samsung Galaxy S2 will not connect to 3G Microcell

We get 2 - 3 bars of service in our home and are frequently dropping or missing calls.  AT&T told us that we should get a microcell.  I successfully activated the microcell and all of the lights on the front are solid green but our phones have never connected to it.  I have tried 2 different microcells and spends several hours on the phone with tech support and nothing has worked to get our phones to connect. Support has no clue what to do about it, they say that everything is setup correctly and our phones should be working.  Our galaxy s2 phones have the latest update (Android 2.3.6) installed. Has anyone had success connecting their Galaxy s2 phone to a microcell? Any ideas?

2,662 Views
Message 1 of 3
Tutor

Re: Samsung Galaxy S2 will not connect to 3G Microcell

My GS2 Skyrocket connects to my MicroCell fine.  Do you have old SIM cards?

Message 2 of 3
Explorer

Re: Samsung Galaxy S2 will not connect to 3G Microcell

On a trip to Las Vegas last weekend I found my old Moto Razr 9x unable to hold a charge so I bought the Galaxy S2 Skyrocket there. I was also told it worked with the Microcell and that if I was unsatisfied I could return it for a modest restocking fee within 30 days.

 

When I returned home on the 17th of January (yesterday)  and tested it with my microcell it didn't work. My wife's iPhone was working but not my new Galaxy. I was reading this very thread when I noticed my Galaxy FINALLY responding to the Microcell. It took over ten minutes to do whatever handshaking it needed to do.

 

My Galaxy now makes the Microcell connection just like my old Razr and our iPhone when we are within its range and properly shows the Microcell 3G identification on the Galaxy's display screen instead of the usual AT&T cell connection. The signal strength doesn't immediately show 5 bars but does within a few seconds (I think that is Android's calculating it slowly) but the phone clarity still behaves like it's 5 bars.

 

You might want to turn off your phone, go to the Manage your Microcell within your AT&T account and delete and re-add your Galaxy phone number. Wait 5 minutes, then turn on your Galaxy again and wait another couple minutes and see what happens. 

Message 3 of 3
You must type a description before you click preview or reply.
Share this topic
Announcements

Find the Unlimited Plan that works best for you at our Knowledge Sharing Session: Whole Lotta' Data Going On on Wed. 6/28 from 1-4pm ET / noon-3pm CT / 10am-1pm PT!

Find out the very latest about the new iPad Pros!

Are you looking to upgrade and activate your device?

Let us help make Ordering, Upgrading and Activating easy!

Additional Support