Replaced old phone now can't activate

Contributor

Replaced old phone now can't activate

I recently lost my iPhone3 and made an insurance claim and received a new iPhone 4s (thanks AT&T!). However for some reason I can't get it to activate. I tried to hard shutoff and still get "no service" and when i followed the prompts when I first turned the phone on it seemed to have no problem but It says "no service". I read somewhere I might need to update my sim card so I tried to do that online and it said I didn't need to. I'd like to be able to do this online somehow because this is the only phone I have...and it's not working...so I can't make any calls unless I go to a friends house. Please help!
Tags (1)
824 Views
Message 1 of 2
Highlighted
ACE - Professor

Re: Replaced old phone now can't activate

http://www.att.com/econtactus/

 

Perhaps that would lead to success? Or you could always call via a google voice account Smiley Happy

*The views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.
Message 2 of 2
You must type a description before you click preview or reply.
Share this topic
Announcements

Are you looking to upgrade and activate your device?

Let us help make Ordering, Upgrading and Activating easy!

Additional Support