No Service!?!?! (iPhone 4)

Scholar

No Service!?!?! (iPhone 4)

[ Edited ]

So I'm on an iPhone 4 right now and I cannot make any outgoing calls. Is this happening to anyone else? The phone says I have signal, 4 bars actually, but there is no EDGE data nor is there 3G availible. I try to send a message and all a sudden it changes to No Service.

 

I'm not sure what the problem is honestly. This happening to anyone else right now?

Message 1 of 8 (20,342 Views)
Professor

Re: No Service!?!?! (iPhone 4)

Have you tried the basics of reset, restart/reboot, or restore?

 

Are others in your area having problems?

Message 2 of 8 (20,276 Views)
Scholar

Re: No Service!?!?! (iPhone 4)

Yeah I restored the phone. Reset it. Turned it off and on. Toggled airplan mode back and forth. Usually when I do that, it will search after coming off. But from airplan mode back to off it automatically gets 5 bars and AT&T, but no EDGE or 3G.

 

I'm thinking it's a hardware issue but what is weird is that when I left my city to another one last night, I noticed it was working just fine. Could it be AT&T tower's for my area? Because as soon as I got back around my neighborhood it stopped working again.

 

But I checked my brother's phone who is also on AT&T and his phone works just fine. Although he's not on a iPhone.

 

I'm going to Apple later today to do a swap if possible. If the problem still exists it has to be AT&T.

Message 3 of 8 (20,207 Views)
ACE - Professor

Re: No Service!?!?! (iPhone 4)

Could be an issue with the SIM card, too. Either way a visit to Apple or AT&T seems in order.

*The views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.
Message 4 of 8 (20,184 Views)
Scholar

Re: No Service!?!?! (iPhone 4)

So visited an apple store earlier, genius appointment. The guy ran trough everything and could not see any problems.

What's worse is that when I got there, the phone was perfectly fine. In fact, any time I leave my city, the phone works perfectly. When i literally enter my city, it's dead network wise.

So I'm guessing it's an AT&T/tower issue. Maybe it is the sim so switching it just because wouldnt hurt.

Att stores are completely pointless though. Biggest brainless reps I've ever met. But I'll try them again to switch sims.

If that doesn't solve the prob then I have to call AT&T and tell them it's their problem that they need to fix.
Message 5 of 8 (20,137 Views)
Scholar

Re: No Service!?!?! (iPhone 4)

Forgive any typos and spelling errors, on the iPhone now...which is workin perfectly only 7 miles from my city -_-
Message 6 of 8 (20,135 Views)
Tutor

Re: No Service!?!?! (iPhone 4)

I have been having the very same issue with my iphone 4!  It's quite frustrating.  My phone simply displays "searching", no bars of service, no edge, no 3g.  Cannot make or receive a call or text message.  When I am at home I CAN connect to the internet

via my WiFi.  Repeated attempts to restore do not work.  This has been happening to me at least once a week since I got the phone about a month ago.  My daugter got identical phone at the same time and we live together and she has never had her phone not work like mine.  She does see the phone switch back and forth between ATT, 3G, Searching, etc. but it never rendered her device useless.  Yesterday I was without service the entire day.  It was only after being home for a few hours on WiFi that I noticed the screen displayed full bars and ATT.  Oh yeah, that was after the umpteenth time I restored the phone.

 

The closest ATT stores to me have useless employees and I don't have the time to travel to the Apple store in Manhattan to have someone look at it.

 

FYI - I am in the NYC Metro area.

Message 7 of 8 (17,702 Views)
Highlighted
Professor

Re: No Service!?!?! (iPhone 4)

Are you near one of the NY area airports?  Does the problem get better if you get farther away from the airport?  I've seen this problem mentioned in other forums, and the cause was "pilot pollution".  There was an update from Apple that resolved problems for some people on VZW.

Message 8 of 8 (17,673 Views)
Share this topic
Announcements

Welcome to the AT&T Community Forums!!! Stop by the Community How-To section for tips on how to get started.