Ask a question
Search in Wireless Forums

Wireless Forum

Reply
Posted May 16, 2012
11:26:42 PM
View profile
Nitro HD says 4G but it isn't working...

Just got my new Nitro HD....

 

It works fine on wifi, and I turn wifi off and it says 4G... but wont load any web pages...

 

What should I do? It just says "4G" on it. It doesn't have anything next to it, and I've never had an android before so can't tell how to turn 4G on and off

Just got my new Nitro HD....

 

It works fine on wifi, and I turn wifi off and it says 4G... but wont load any web pages...

 

What should I do? It just says "4G" on it. It doesn't have anything next to it, and I've never had an android before so can't tell how to turn 4G on and off

Nitro HD says 4G but it isn't working...

1,375 views
6 replies
(0) Me too
(0) Me too
Reply
View all replies
(6)
0
(0)
  • Rate this reply
View profile
May 17, 2012 2:00:31 AM
0
(0)
Contributor

Just got my new Nitro HD....

 

It works fine on wifi, and I turn wifi off and it says 4G... but wont load any web pages...

 

 

Just got my new Nitro HD....

 

It works fine on wifi, and I turn wifi off and it says 4G... but wont load any web pages...

 

 

Nitro HD says 4G but it isn't working...

2 of 7 (1,377 Views)
0
(0)
  • Rate this reply
View profile
May 17, 2012 8:30:35 AM
0
(0)
ACE - Professor
Hi there!

Do you have a signal on the device? How many bars do see (1 - 5 bars)?

Posted from my iPhone 4S on AT&T, the nation's fastest 4G network.
~Sunshine Smiley Happy
Hi there!

Do you have a signal on the device? How many bars do see (1 - 5 bars)?

Posted from my iPhone 4S on AT&T, the nation's fastest 4G network.
~Sunshine :)
- Sunshine :)
*The views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.

Re: Nitro HD says 4G but it isn't working...

3 of 7 (1,352 Views)
0
(0)
  • Rate this reply
View profile
May 17, 2012 10:07:53 AM
0
(0)
ACE - Professor

4G icon doesn't neccesarily mean you are connected to the network, it just means the phone knows a network is there to connect to.  Take it to an AT&T store, and they will get you sorted out.  Something might be provisioned wrong on your account, something wrong with the SIM card, or something else.

 

On that note, the phone has a SIM card in it, and you called AT&T to activate (or they activated it in-store)?

4G icon doesn't neccesarily mean you are connected to the network, it just means the phone knows a network is there to connect to.  Take it to an AT&T store, and they will get you sorted out.  Something might be provisioned wrong on your account, something wrong with the SIM card, or something else.

 

On that note, the phone has a SIM card in it, and you called AT&T to activate (or they activated it in-store)?

*The views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.

Re: Nitro HD says 4G but it isn't working...

4 of 7 (1,347 Views)
0
(0)
  • Rate this reply
View profile
Jun 13, 2012 6:40:47 PM
0
(0)
Contributor

My husband and I are having this exact same issue with our Nitro HD phones.  I really LOVE this phone, but if it won't connect to 4G then there is no point keeping it.  The weird thing is that I live in a rural area that doesn't have 4G and my internet works great; however, once I cross the line from 2G (Edge) to 4G I get an error message that states "network not available.  I think that there is a setting somewhere in my account that is causing this issue.  I have called the support line several times but nothing seems to work.  I can get 4G to work for a few minutes after hanging up with support and then it stops working.  I have removed the Simm card and battery, and also done a factory reset.  So far, nothing has worked.  I have only had AT&T for a few weeks now.  I switched from Verizon and am beginning to wish I hadn't.  If there is anyone out there that can help me fix this problem, I WILL BE GREATLY APPRECIATIVE!  I don't want to give up this phone, but again, I'm not paying $30 a month to not be able to connect to 4G data.  HELP!

My husband and I are having this exact same issue with our Nitro HD phones.  I really LOVE this phone, but if it won't connect to 4G then there is no point keeping it.  The weird thing is that I live in a rural area that doesn't have 4G and my internet works great; however, once I cross the line from 2G (Edge) to 4G I get an error message that states "network not available.  I think that there is a setting somewhere in my account that is causing this issue.  I have called the support line several times but nothing seems to work.  I can get 4G to work for a few minutes after hanging up with support and then it stops working.  I have removed the Simm card and battery, and also done a factory reset.  So far, nothing has worked.  I have only had AT&T for a few weeks now.  I switched from Verizon and am beginning to wish I hadn't.  If there is anyone out there that can help me fix this problem, I WILL BE GREATLY APPRECIATIVE!  I don't want to give up this phone, but again, I'm not paying $30 a month to not be able to connect to 4G data.  HELP!

Re: Nitro HD says 4G but it isn't working...

5 of 7 (1,269 Views)
0
(0)
  • Rate this reply
View profile
Jun 14, 2012 7:44:41 AM
0
(0)
ACE - Professor

If you can get to an AT&T store, bring the phone in.  Have them check the APN, check your account is properly provisioned, and ask them for a new SIM.  Any of those things can cause connectivity issues.  If none of that works (and as you already said, you tried factory reset) go for a warranty replacement, as it may be a hardware defect.  If your phone is less than 30 days old, they can give you a brand new phone in store.  Over 30 days, you will need to send your phone in for replacement or repair. 

If you can get to an AT&T store, bring the phone in.  Have them check the APN, check your account is properly provisioned, and ask them for a new SIM.  Any of those things can cause connectivity issues.  If none of that works (and as you already said, you tried factory reset) go for a warranty replacement, as it may be a hardware defect.  If your phone is less than 30 days old, they can give you a brand new phone in store.  Over 30 days, you will need to send your phone in for replacement or repair. 

*The views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.

Re: Nitro HD says 4G but it isn't working...

6 of 7 (1,259 Views)
0
(0)
  • Rate this reply
View profile
Jun 14, 2012 2:59:26 PM
0
(0)
Contributor
Edited by ShaunMN on Jun 14, 2012 at 3:05:15 PM

AT&T was finally able to figure out what the problem was on our phones.  The tech person said that our phone was initially set up wrong on their end.  Once the changes were made, my phone's 4G internet worked.  My husband's works too.  The person that was able to help me was Terri {personal content removed for safety}

 

Incidentally, my husband and I ordered our phones online.  Just curious as to how many of you that are still having issues did the same thing...

AT&T was finally able to figure out what the problem was on our phones.  The tech person said that our phone was initially set up wrong on their end.  Once the changes were made, my phone's 4G internet worked.  My husband's works too.  The person that was able to help me was Terri {personal content removed for safety}

 

Incidentally, my husband and I ordered our phones online.  Just curious as to how many of you that are still having issues did the same thing...

Re: Nitro HD says 4G but it isn't working...

[ Edited ]
7 of 7 (1,251 Views)
Share this post
Share this post