Ask a question
Search in Wireless Forums

Wireless Forum

Reply
Posted Oct 9, 2011
8:42:36 AM
View profile
How to use AT&T blackberry curve with T-Mobile

I am having so much trouble with getting my phone to work, so if anyone could help that would be great. I unlocked my AT&T bberry curve 3300 (i think) and it now works with tmobile. But I can't send MMS and internet/wifi doesn't work. When I try and send a MMS it says "No MMS service record." And the blackberry Enterprise Server says not connected. How do I fix this??

I am having so much trouble with getting my phone to work, so if anyone could help that would be great. I unlocked my AT&T bberry curve 3300 (i think) and it now works with tmobile. But I can't send MMS and internet/wifi doesn't work. When I try and send a MMS it says "No MMS service record." And the blackberry Enterprise Server says not connected. How do I fix this??

How to use AT&T blackberry curve with T-Mobile

1,261 views
1 reply
(0) Me too
(0) Me too
Reply
View all replies
(1)
Highlighted
0
(0)
  • Rate this reply
View profile
Oct 9, 2011 11:26:57 AM
0
(0)
Master

cubbies1357 wrote:

I am having so much trouble with getting my phone to work, so if anyone could help that would be great. I unlocked my AT&T bberry curve 3300 (i think) and it now works with tmobile. But I can't send MMS and internet/wifi doesn't work. When I try and send a MMS it says "No MMS service record." And the blackberry Enterprise Server says not connected. How do I fix this??


I think one of T-Mobile's GSM bands for data services is not the same as AT&T's. When you got the phone unlocked to use with T-Mobile, that frequency was lost. Try contacting T-Mobile's customer service and ask them if they can help you enable data, if possible.

Cat Happy Remember that Wild Banchi... 1993-2010 Cat Happy




cubbies1357 wrote:

I am having so much trouble with getting my phone to work, so if anyone could help that would be great. I unlocked my AT&T bberry curve 3300 (i think) and it now works with tmobile. But I can't send MMS and internet/wifi doesn't work. When I try and send a MMS it says "No MMS service record." And the blackberry Enterprise Server says not connected. How do I fix this??


I think one of T-Mobile's GSM bands for data services is not the same as AT&T's. When you got the phone unlocked to use with T-Mobile, that frequency was lost. Try contacting T-Mobile's customer service and ask them if they can help you enable data, if possible.

:cathappy: Remember that Wild Banchi... 1993-2010 :cathappy:



Remember that Wild Banchi... 1993-2010

Re: How to use AT&T blackberry curve with T-Mobile

2 of 2 (1,255 Views)
Share this post
Share this post