Ask a question

    Reply
    Posted Jul 19, 2010
    5:23:32 AM
    View profile
    How to turn off 3G on the Captivate

    I've been searching and can't find a way to toggle 3G off on the Captivate.

     

    Not only does 3G drain the battery where I am, I've found that the Edge network is more reliable for calls and text messages. I always kept 3G off on my iphone unless I needed to transfer some data where a wi-fi connection wasn't.

     

    Thanks!

     

     

    How to turn off 3G on the Captivate

    27,602 views
    56 replies
    (0) Me too
    (0) Me too
    Post reply
    View all replies
    (56)
    0
    (0)
    • Rate this reply
    View profile
    Jul 20, 2010 6:51:37 AM
    0
    (0)
    ACE - Tutor

    I'm in the same boat. I work in a building where the signal is minimal and leaving 3G on kills my battery. I have a computer (who doesn't), so I rarely use data on my phone during the day.

     

    This is enough of an issue for me to consider taking it back, paying the restocking fee and ETF, and moving to T-Mobile or Sprint since I can get pretty much the same phone with either provider.

    Re: How to turn off 3G on the Captivate

    2 of 57 (27,463 Views)
    0
    (0)
    • Rate this reply
    View profile
    Jul 20, 2010 6:55:57 AM
    0
    (0)
    ACE - Teacher

    If I take it back, I'm going to argue against the re-stocking fee.

     

    Another reason it's an issue is that I've actually been unable to make 3G calls before - usually in a crowded place or a sporting event - but was able to switch to the Edge network and make a call with no issues.

    Re: How to turn off 3G on the Captivate

    3 of 57 (27,459 Views)
    0
    (0)
    • Rate this reply
    View profile
    Jul 20, 2010 7:26:02 AM
    0
    (0)
    ACE - Mentor

    Search web for "turn off 3g on samsung galaxy".  Have not gotten my phone yet but it looks like it might be somewhere around Settings->Wireless and network->Mobile networks.

     

    Let us know if you find it.

    Re: How to turn off 3G on the Captivate

    4 of 57 (27,442 Views)
    0
    (0)
    • Rate this reply
    View profile
    Jul 20, 2010 7:50:28 AM
    0
    (0)
    ACE - Tutor
    Edited by GLU on Jul 20, 2010 at 7:54:10 AM

    AT&T had Samsung remove the option to force 2G from the Android settings. I won't speculate why.

     

    It's available on T-Mobile's Vibrant as well as Euro/Asian Galaxy S devices.

     

     

    Re: How to turn off 3G on the Captivate

    [ Edited ]
    5 of 57 (27,435 Views)
    0
    (0)
    • Rate this reply
    View profile
    Jul 20, 2010 8:07:31 AM
    0
    (0)
    ACE - Teacher

     


    Voltaire wrote:

    Search web for "turn off 3g on samsung galaxy".  Have not gotten my phone yet but it looks like it might be somewhere around Settings->Wireless and network->Mobile networks.

     

    Let us know if you find it.


    It's not on there. Believe me. I've tried about a dozen different ways and solutions. If it's possible, it's likely going to come through some hack or creative app, but the ones I've tried  can't force something that's not there.

     

    Re: How to turn off 3G on the Captivate

    6 of 57 (27,426 Views)
    0
    (0)
    • Rate this reply
    View profile
    Jul 20, 2010 10:08:27 AM
    0
    (0)
    ACE - Tutor

    Have you tried a widget? Slight chance it may work...

     

    Search for: "Switch Network Type 2G / 3G" in the market or appbrain

    Re: How to turn off 3G on the Captivate

    7 of 57 (27,382 Views)
    0
    (0)
    • Rate this reply
    View profile
    Jul 20, 2010 10:11:20 AM
    0
    (0)
    ACE - Teacher

    Do you have any suggestions of one that I could try?

     

    The one thing I did do that I thought might work was to create a shortcut using Anycut that went into the phone settings. The only problem is the choice - GSM Only - wasn't available on this phone.

    Re: How to turn off 3G on the Captivate

    8 of 57 (27,386 Views)
    0
    (0)
    • Rate this reply
    View profile
    Jul 20, 2010 10:14:28 AM
    0
    (0)
    ACE - Tutor

    Switch Network Type 2G / 3G is the name of the widget.  Here's a link to it in appbrain.com

    Re: How to turn off 3G on the Captivate

    9 of 57 (27,381 Views)
    0
    (0)
    • Rate this reply
    View profile
    Jul 20, 2010 10:16:10 AM
    0
    (0)
    ACE - Teacher

    Yep - Tried that one. It doesn't work on this phone.

    Re: How to turn off 3G on the Captivate

    10 of 57 (27,377 Views)
    0
    (0)
    • Rate this reply
    View profile
    Jul 20, 2010 11:06:59 AM
    0
    (0)
    ACE - Mentor

    Found the following information on this:

     

    1. One site stated you could set this in two ways (one we know was removed by AT&T):

    Go to the phone and press * # * # INFO # * # * or * # * # 4636 #*#*, after it entered into the Phone information and set preferred network type to GSM Only.

     

    And this posting for the Aria which seems to not have the 2G only option either:

    Thanks, because of your information I able to summarize what the setting should be to "turn off 3G "/ EDGE network only. 

    I found the answer:
    - Go to : Setting->Wireless & Mobile Network -> Mobile Networks (set option for roaming networks...) -> Enable always-on mobile (Uses more power on some ...) -> make sure "Check"/enable this one
    - Go to : Phone -> type *#*#4636#*#* -> phone information -> change to GSM only. 

     

    And this posting about doing this on the Aria:

    Remember, the only problem with selecting GSM only is that on AT&T you can not accept calls while you are D/L data over EDGE.  So this will give you great battery life and conserve data, but you have a lot more calls heading to VM if you don't keep data off until you need to use it.

     

     

     

    2. APNdroid (http://www.androlib.com/android.application.com-google-code-apndroid-jxt.aspx) allows you to stop all data access.  Apparently this will be an option in Froyo and so this app will not be useful after that.

     

    Re: How to turn off 3G on the Captivate

    11 of 57 (14,039 Views)
    0
    (0)
    • Rate this reply
    View profile
    Jul 20, 2010 11:15:27 AM
    0
    (0)
    ACE - Teacher
    Edited by know1 on Jul 20, 2010 at 11:19:15 AM

    Yep - that's exactly where I was before and GSM Only is not an option for preferred network. It's just not there.

     

    It has

    WCDMA only

    GSM auto (PRL)

    CDMA auto (PRL)

    CDMA only

    EvDo only

    GSM/CDMA auto (PRL) - this is what was selected

    Unknown

     

    I've tried them all and it stays on the 3G network in the display.

     

    I do appreciate your help, but I really think it is not possible to force the phone onto 2G.

    Re: How to turn off 3G on the Captivate

    [ Edited ]
    12 of 57 (14,035 Views)
    0
    (0)
    • Rate this reply
    View profile
    Jul 20, 2010 11:36:29 AM
    0
    (0)
    Guru
    The second option is GSM only. Right under WCDMA only.

    Re: How to turn off 3G on the Captivate

    13 of 57 (14,024 Views)
    0
    (0)
    • Rate this reply
    View profile
    Jul 20, 2010 11:38:39 AM
    0
    (0)
    ACE - Teacher
    Edited by know1 on Jul 20, 2010 at 11:40:42 AM

     


    davidusr wrote:
    The second option is GSM only. Right under WCDMA only.

    OK - but when I choose that, the icon at the top of the phone says still says 3G. I let it sit on that one for quite awhile and it never wavered from 3G. Maybe I need to make a call or try pulling some data, but I know that "E" can be displayed at the top because I've seen it when I was in an area where 3G was spotty.

     

    I just tried making a call and pulling some data with that setting and my phone still indicates it's on 3G the entire time.

     

    Re: How to turn off 3G on the Captivate

    [ Edited ]
    14 of 57 (14,019 Views)
    0
    (0)
    • Rate this reply
    View profile
    Jul 20, 2010 11:39:41 AM
    0
    (0)
    ACE - Mentor

    You have to scroll the option window up.  However, I can select GSM only, but it does not save.

    Re: How to turn off 3G on the Captivate

    15 of 57 (14,018 Views)
    0
    (0)
    • Rate this reply
    View profile
    Jul 20, 2010 11:43:39 AM
    0
    (0)
    ACE - Teacher
    Edited by know1 on Jul 20, 2010 at 11:46:27 AM

     


    blackviper71 wrote:

    You have to scroll the option window up.  However, I can select GSM only, but it does not save.


    I didn't realize I could scroll up, but there it is. I've chosen it, but my phone still says it's on 3G.

     

    Note - I went back and it wasn't selected anymore.

     

    Re: How to turn off 3G on the Captivate

    [ Edited ]
    16 of 57 (14,012 Views)
    0
    (0)
    • Rate this reply
    View profile
    Jul 20, 2010 3:50:11 PM
    0
    (0)
    Contributor

    Hey Guys,

     

    I just found another way to turn off 3G. After getting into Phone Setting (*#*#4636#*#*) i clicked the 'menu' option and then 'more'. it had something like 'disable data connection'. Once i did this I dont get the 3G icon anymore on the top menu bar.

    Re: How to turn off 3G on the Captivate

    17 of 57 (13,914 Views)
    Highlighted
    0
    (0)
    • Rate this reply
    View profile
    Jul 20, 2010 6:15:17 PM
    0
    (0)
    ACE - Mentor

    That is good and I found this which is pretty comprehensive:

     

    http://www.mydigitallife.info/2010/04/30/how-to-turn-off-and-disable-mobile-data-connection-2ggprsedge3g-on-android-phone/

     

    Of course, what we really want is to be able to use 2g for data thus extending battery life; not turning off wireless data download completely.

    Re: How to turn off 3G on the Captivate

    18 of 57 (13,889 Views)
    0
    (0)
    • Rate this reply
    View profile
    Jul 21, 2010 4:49:56 AM
    0
    (0)
    ACE - Teacher

     


    bravisha wrote:

    Hey Guys,

     

    I just found another way to turn off 3G. After getting into Phone Setting (*#*#4636#*#*) i clicked the 'menu' option and then 'more'. it had something like 'disable data connection'. Once i did this I dont get the 3G icon anymore on the top menu bar.


    I don't see a "menu" option after typing in that code.

     

    Re: How to turn off 3G on the Captivate

    19 of 57 (13,828 Views)
    0
    (0)
    • Rate this reply
    View profile
    Jul 21, 2010 6:32:05 AM
    0
    (0)
    ACE - Tutor

    He means hit the menu button on the far left.

     

    And while this is a step in the right direction, it is somewhat cumbersome and turns off data completely rather than forcing the phone to EDGE, which is what I was looking to do.

     

    Thanks for that though. I might use it.

    Re: How to turn off 3G on the Captivate

    20 of 57 (13,813 Views)
    0
    (0)
    • Rate this reply
    View profile
    Jul 22, 2010 9:55:26 AM
    0
    (0)
    Contributor
    Edited by gadgetguy681 on Jul 22, 2010 at 10:00:08 AM

    Note that when you turn off the data connection, it only stops the sending and receiving of data. With the connection turned off, the phone is still using the HSDPA (3G) network for reception and calls. Look at where it says Network Type and you'll see HSDPA there instead of EDGE (GSM).

     

    We need a way to force it to GSM only.

     

    Like someone else posted here, I have the iphone as my previous phone and left the 3G off unless I needed to use the data connection for browsing or email. I called AT&T and they had no help. They referred me to Samsung. I'll call them and post if they say anything useful.

     

    In my area, they are just upgrading to 3G and I get one to two bars less signal with the 3G. This causes way to many missed and dropped calls.

     

    I'd bet it'll be changed in the Android 2.2 update.

     

    I hope AT&T is reading this because if this is not fixed within my inital 30 days, the phone will be returned and I'll be looking into the Droid X on Verizon.

    Re: How to turn off 3G on the Captivate

    [ Edited ]
    21 of 57 (10,507 Views)
    0
    (0)
    • Rate this reply
    View profile
    Jul 23, 2010 6:38:26 AM
    0
    (0)
    Contributor
    Edited by gadgetguy681 on Jul 23, 2010 at 6:45:16 AM

    Well, it's off for now. I was able to switch it to GSM only in the phone settings. Scroll the list to the top and you'll see GSM only. I selected it and the first time it reverted back to GSM/CDMA. After I selected it the second time, I scrolled down the screen to where it shows SMSC: (not sure what it's for). I selected refresh, then update, and ever since, it's stayed in GSM only mode.

     

    Maybe it'll revert back to the original settings at some point in time but for now, it's staying in GSM Only.

     

    The entire procedure is:

     

    1. Go to the phone keypad

    2. enter *#*#4636#*#*  The phone enters a testing mode.

    3. Select Phone information. You'll see information regarding the network being used and different settings.

    4. Scroll down the screen to Set Preferred Network Type. Touch the down arrow and scroll the list up to GSM Only and select that.

    5. Scroll down to SMSC: and select refresh and then update.

    6. Press the home button. DO NOT PRESS THE BACK BUTTON AS THIS SEEMS TO MAKE THE SETTINGS REVERT BACK TO ORIGINAL

     

    So far it's working. We'll see if it will stay though. I have my doubts.

    Re: How to turn off 3G on the Captivate

    [ Edited ]
    22 of 57 (10,385 Views)
    0
    (0)
    • Rate this reply
    View profile
    Jul 23, 2010 7:05:49 AM
    0
    (0)
    ACE - Mentor

    So, the 3G symbol at the top of your phone changed to show the EDGE symbol?

    Re: How to turn off 3G on the Captivate

    23 of 57 (10,373 Views)
    0
    (0)
    • Rate this reply
    View profile
    Jul 23, 2010 7:11:31 AM
    0
    (0)
    ACE - Teacher

    Still says 3G at the top of the screen for me.

    Re: How to turn off 3G on the Captivate

    24 of 57 (10,371 Views)
    0
    (0)
    • Rate this reply
    View profile
    Jul 23, 2010 10:08:59 AM
    0
    (0)
    ACE - Tutor

    Tried that method and several others. Even though it stays as "GSM only" the 3G indicator is still present and 3G speeds are as well, so it's a no go for me. I've found the menu via a different code that controls band selection but it says it's restricted and you cannot change anything.

    Re: How to turn off 3G on the Captivate

    25 of 57 (10,324 Views)
    0
    (0)
    • Rate this reply
    View profile
    Jul 23, 2010 6:45:54 PM
    0
    (0)
    ACE - Teacher

     


    gadgetguy681 wrote:

    Well, it's off for now. I was able to switch it to GSM only in the phone settings. Scroll the list to the top and you'll see GSM only. I selected it and the first time it reverted back to GSM/CDMA. After I selected it the second time, I scrolled down the screen to where it shows SMSC: (not sure what it's for). I selected refresh, then update, and ever since, it's stayed in GSM only mode.

     

    Maybe it'll revert back to the original settings at some point in time but for now, it's staying in GSM Only.

     

    The entire procedure is:

     

    1. Go to the phone keypad

    2. enter *#*#4636#*#*  The phone enters a testing mode.

    3. Select Phone information. You'll see information regarding the network being used and different settings.

    4. Scroll down the screen to Set Preferred Network Type. Touch the down arrow and scroll the list up to GSM Only and select that.

    5. Scroll down to SMSC: and select refresh and then update.

    6. Press the home button. DO NOT PRESS THE BACK BUTTON AS THIS SEEMS TO MAKE THE SETTINGS REVERT BACK TO ORIGINAL

     

    So far it's working. We'll see if it will stay though. I have my doubts.


    WARNING - I had done some of what you mention here previously, but when I read that you added step #5, I went back and tried it again. Something I did here DISABLED the ability to send text messages. I could receive but not send. I went to the store and they were able to fix it.

     

    Re: How to turn off 3G on the Captivate

    26 of 57 (10,278 Views)
    0
    (0)
    • Rate this reply
    View profile
    Jul 24, 2010 10:52:10 PM
    0
    (0)
    ACE - Tutor

    The above version doesn't work. But, this one posted on another forum does:

     

    Originally Posted by BecomingxInsane  

     

    I found out that if you go into the dialer and type in *#*#197328640#*#* that it will take you into a menu that will allow you to change it. From the main menu of the ServiceMode screen, select DEBUG SCREEN, then PHONE CONTROL at the bottom, then UE STATE CONTROL. From there select CHANGE RAT TO WCDMA to enable 3G only, and select CHANGE RAT TO GSM for 2G only.

    Re: How to turn off 3G on the Captivate

    27 of 57 (10,162 Views)
    0
    (0)
    • Rate this reply
    View profile
    Jul 24, 2010 11:11:28 PM
    0
    (0)
    ACE - Tutor

    Doesn't appear to survive flight mode or reboot though.

    Re: How to turn off 3G on the Captivate

    28 of 57 (10,156 Views)
    0
    (0)
    • Rate this reply
    View profile
    Jul 28, 2010 4:33:12 PM
    0
    (0)
    ACE - Tutor

    I am having the text issue also do you know what they did exactly?

    Re: How to turn off 3G on the Captivate

    29 of 57 (9,787 Views)
    0
    (0)
    • Rate this reply
    View profile
    Jul 29, 2010 5:04:21 AM
    0
    (0)
    ACE - Teacher

    If I was at home, I could tell you, but it has something to do with deleting the access number for the server to send texts. Everyone's number is different,  so even if I gave you the number that they gave me, it may not work for you.

    Re: How to turn off 3G on the Captivate

    30 of 57 (9,730 Views)
    Share this post
    Share this post