Home sharing not working

Scholar

Home sharing not working

Is anyone having issues with their home sharing with the new iOS? I can't get mine to work. 

I downloaded iTunes 10.2. I went to preferences, then "sharing" and made sure there was a check mark in "share my library on my local network" I don't have a check in the password box. I went to my iPhone and went to settings, then iPod, then Home Sharing. I typed in my apple id and my iTunes password and it gives me a message, unable to turn on Home sharing.  I did it again and nothing happens. when I go back to iTunes it says "status on, no users connected".  From what I saw on the Apple forum, if the Home Sharing is working when you go to your iPod App it, and then choose "more" it will ask you to choose between your phone and your library name. You can only use one a a time. 

Message 1 of 16 (6,180 Views)
Guru

Re: Home sharing not working

I can't get my iPhone to connect. It has the option of my iPhone and my computer but it just keeps thinking and doesn't connect.
Message 2 of 16 (6,149 Views)
Scholar

Re: Home sharing not working

I don't even get that.  I restarted my iPhone and had to restart my computer after installing iTunes. 

Message 3 of 16 (6,143 Views)
Master

Re: Home sharing not working

After I had the dialog box on the iPhone open, I had to fully close my iTunes on my computer and when I started it back up I got the box for the home sharing.

Message 4 of 16 (6,110 Views)
Master

Re: Home sharing not working

I have not had any issues, it did take a few minutes to find the home sharing option within the "..." menu.  It will only show if a source for sharing is available.  I may have had to restart iTunes and the iDevice. 

_____________________

For service or support questions including existing order status, call:
Customer Support: 1-800-331-0500

Information on iPhone unlocking can be found here by copying this link into your browser:
https://www.att.com/deviceunlock/client/en_US/
Message 5 of 16 (6,065 Views)
Highlighted
Scholar

Re: Home sharing not working

Took me just a minute to setup after I read this how to article.

 

Message 6 of 16 (6,040 Views)
Professor

Re: Home sharing not working

Mine worked with no problems, right away.
Message 7 of 16 (6,006 Views)
Scholar

Re: Home sharing not working

mine worked right away after following instructions. but i wish it didn't turn off home sharing when you closed itunes.

if it  didn't that would be a cool way to sync all the stuff to your iphone that you wanted to use or watch for the day.

Message 8 of 16 (5,975 Views)
Teacher

Re: Home sharing not working

Docs44, did you resolve? Strange, mine worked when I first set it up now it appears the sharing option has vanished from the "More" tab in iPod. 

Message 9 of 16 (5,827 Views)
Contributor

Re: Home sharing not working

I havent been able to get my Home Share to work with my Iphone or Ipad with Uverse either. It will work with another computer but even though my Itunes Library name shows up on my Iphone and Ipad when I go to connect them .. it wont connect and will just time out !! It worked at the Apple store but it wont work on my ATT Uverse Modem.  Any Suggestions?  For those of you that did get it to work .. What uverse modem are you using at home and is it working on your iphone or ipad ?

Message 10 of 16 (5,562 Views)
Contributor

Re: Home sharing not working

But does it work with you iphone or ipad ? What moden do you have ?

Message 11 of 16 (4,806 Views)
Professor

Re: Home sharing not working

 


GregoryVincent wrote:

I havent been able to get my Home Share to work with my Iphone or Ipad with Uverse either. It will work with another computer but even though my Itunes Library name shows up on my Iphone and Ipad when I go to connect them .. it wont connect and will just time out !! It worked at the Apple store but it wont work on my ATT Uverse Modem.  Any Suggestions?  For those of you that did get it to work .. What uverse modem are you using at home and is it working on your iphone or ipad ?


Are you connected to your home network via Wi-Fi?  "Uverse modem" implies no router and no wireless.

 

Home Sharing only works via Wi-Fi.

Message 12 of 16 (4,800 Views)

Re: Home sharing not working


satchev wrote:

 

Are you connected to your home network via Wi-Fi?  "Uverse modem" implies no router and no wireless.

 

Home Sharing only works via Wi-Fi.


The "modem" that 'typically' comes with the Uverse service is the 2Wire Cable Modem/Router/WAP/10mb Switch device.

 

"IF" that's what he's talking about then he's got wireless.  The question is, wireless enabled, does he have the proper passphrase?

 

It's a bit cryptic, but from what I understand, he's got Home Share working between computers, the Home Share theoretically shows up on his iPhone/iPad, but when he attempts to connect, it doesn't.

 

It's possible his computers are connecting to each other via a physical wired network (the 2Wire switch has 8 ports on it if I remember correctly, so possibly this is a wireless only issue.

 

I would first, turn off (completely power it off) the 2Wire cable modem/router/WAP/10mb switch device for a minute, then turn it back on and make sure that my iPhone/iPad are able to access the internet via Wifi (you confirm this by making sure the 'connectivity' icon IS NOT '3G' when using an internet app like Safari), then I'd try, then I'd confirm pass phrase etc, working my way all the way back to the iTunes Home Share making sure all settings are correct and devices are properly registered.

 

The reason I start with reboot of the 2Wire box is because on my own 2Wire box, about once a month, I need to reboot the box because the WAP just disappears (probably some sort of memory leak), but a reboot ALWAYS returns it to functionality.

Message 13 of 16 (4,782 Views)
Contributor

Re: Home sharing not working

So here is my question. I am also on AT&T uverse with the 2wire modem/router. I am able to access. My lituneslibrary from our iPads and Apple tv. But it seems to only last for about 24 hours. Then it disappears and the only way to get it back on any of our devices is to reboot the 2wire router. Once a month would be okay but doing it every day is a big pain. Does any one have and suggestions? Thanks Keith
Message 14 of 16 (4,500 Views)
Scholar

Re: Home sharing not working


kacord99 wrote:
So here is my question. I am also on AT&T uverse with the 2wire modem/router. I am able to access. My lituneslibrary from our iPads and Apple tv. But it seems to only last for about 24 hours. Then it disappears and the only way to get it back on any of our devices is to reboot the 2wire router. Once a month would be okay but doing it every day is a big pain. Does any one have and suggestions? Thanks Keith

Use the devices less often.  Smiley Very Happy

 

Sounds like an issue to address with UVerse or DSL support and possibly get the router replaced.

Message 15 of 16 (4,489 Views)
Share this topic
Announcements

Welcome to the AT&T Community Forums!!! Stop by the Community How-To section for tips on how to get started.