Help please!

Contributor

Help please!

when i try to charge my motorola backflip a green flashing light appears instead of the usual constant green light. ive tooken out the battery and put it in again and it still doesnt work. any suggestions please?

Message 1 of 6 (448 Views)
Guru

Re: Help please!

I had the same problem when I first got my phone, but not only was the light blinking it my made sort of a chirping noise. I can't exactly recall what was causing it but since it was under warranty I sent it back to Motorola twice and they couldn't fix it so they wound up giving me a new phone. But make sure you are using the charger that came with the phone, also check to see if the pins in the charging port are not bent, and  try a different wall outlet.

Message 2 of 6 (427 Views)
Contributor

Re: Help please!

My phone does that chirping noise too! And ive been using the charger it came with. Ive checked the pens and there straight, ive also tried different wall outlets. And ive also bought a new battery and it worked. But i think it has something to do with the phone. I dont have warranty since ive gotten it wet and it was a gift for my birthday . Thanks for the advice!
Message 3 of 6 (405 Views)
Guru

Re: Help please!

I'm glad you mentioned getting it wet because if you were to contact Motorola that'd be one of the things they'd ask. Motorola's website has a troubleshooting page you might want to try. Also check out their forums there is forums manager named Mark who is very knowledgeable post a question to him and see if he can help.

Message 4 of 6 (397 Views)
Contributor

Re: Help please!

Ok thank you for the help!
Message 5 of 6 (392 Views)
Guru

Re: Help please!

Your welcome!

Message 6 of 6 (390 Views)
Share this topic
Announcements

Welcome to the AT&T Community Forums!!! Stop by the Community How-To section for tips on how to get started.