Ask a question
Search in Wireless Forums

Wireless Forum

Reply
Posted Aug 15, 2011
9:05:34 PM
View profile
Gmail and Talk issue on Atrix

I've been searching all over, Android Forums, XDA, google, etc, and haven't found an answer to my problem yet. Quite suddenly a couple of weeks ago, I found that I wasn't getting my push notifications for my gmail account to my Atrix, and when I did, they were dealyed from as little as 5 minutes to as much as 45 minutes. Shortly after this discovery, I also noticed that google's Talk app would no longer maintain a persistent connection to the server. A little research showed that the problems are related, but I have no idea how to fix it.

 

I don't switch between wifi and cellular data ever, so it's not a port issue on a wifi network. I do have the OTA update to gingerbread installed and running fairly well, aside from the afore mentioned issues. What I am wondering is, is this an Android problem or an AT&T issue. My gut says it's a network problem with my device, but I don't know. I've reset the phone, cleared data for both apps, uninstalled and reinstalled, powered down and removed the battery, etc. The only reason I haven't called customer service is due to not having a land line, and they always want you to call from a device other than the one you are trying to trouble shoot.

 

Maybe I'll toss my SIM into my backup phone and let the Atrix fall off the network for a day or so. Thank you in advance for any help!

I've been searching all over, Android Forums, XDA, google, etc, and haven't found an answer to my problem yet. Quite suddenly a couple of weeks ago, I found that I wasn't getting my push notifications for my gmail account to my Atrix, and when I did, they were dealyed from as little as 5 minutes to as much as 45 minutes. Shortly after this discovery, I also noticed that google's Talk app would no longer maintain a persistent connection to the server. A little research showed that the problems are related, but I have no idea how to fix it.

 

I don't switch between wifi and cellular data ever, so it's not a port issue on a wifi network. I do have the OTA update to gingerbread installed and running fairly well, aside from the afore mentioned issues. What I am wondering is, is this an Android problem or an AT&T issue. My gut says it's a network problem with my device, but I don't know. I've reset the phone, cleared data for both apps, uninstalled and reinstalled, powered down and removed the battery, etc. The only reason I haven't called customer service is due to not having a land line, and they always want you to call from a device other than the one you are trying to trouble shoot.

 

Maybe I'll toss my SIM into my backup phone and let the Atrix fall off the network for a day or so. Thank you in advance for any help!

Gmail and Talk issue on Atrix

923 views
10 replies
(0) Me too
(0) Me too
Reply
View all replies
(10)
0
(0)
  • Rate this reply
View profile
Aug 17, 2011 9:09:09 AM
0
(0)
Professor

I see that you have cellular and wifi.

 

Mine happened right after the Market updater changed to the new version in front of my eyes. Google's website says to log into Talk to make it work. I tried it but it did not work. Then I used my friend's wifi and things start to work. While it appears to be a wifi or IP network issue, I don't know. It has not been ruled out as an Android issue. This Monday I had to use friend's wifi once again to "reinitialize" Talk to make things work on my wifi.

I see that you have cellular and wifi.

 

Mine happened right after the Market updater changed to the new version in front of my eyes. Google's website says to log into Talk to make it work. I tried it but it did not work. Then I used my friend's wifi and things start to work. While it appears to be a wifi or IP network issue, I don't know. It has not been ruled out as an Android issue. This Monday I had to use friend's wifi once again to "reinitialize" Talk to make things work on my wifi.

Re: Gmail and Talk issue on Atrix

2 of 11 (891 Views)
0
(0)
  • Rate this reply
View profile
Sep 11, 2011 1:45:15 PM
0
(0)
Mentor
Edited by RedVFR on Sep 11, 2011 at 1:48:15 PM

UPDATE:
A replacement device has not helped the issue, nor has a replacement SIM. I Put my SIM in my Captivate, also running Gingerbread , and now there are no more issues with gtalk logging out, which seems to be the core problem.

My observations tell me to point my finger at Motoblur somehow interfering with a persistent connection to Google, this being the biggest difference between software on the two phones. I'm assuming something is wrong with my account, as my old atrix and replacement atrix are behaving identically.

UPDATE:
A replacement device has not helped the issue, nor has a replacement SIM. I Put my SIM in my Captivate, also running Gingerbread , and now there are no more issues with gtalk logging out, which seems to be the core problem.

My observations tell me to point my finger at Motoblur somehow interfering with a persistent connection to Google, this being the biggest difference between software on the two phones. I'm assuming something is wrong with my account, as my old atrix and replacement atrix are behaving identically.

Re: Gmail and Talk issue on Atrix

[ Edited ]
3 of 11 (753 Views)
0
(0)
  • Rate this reply
View profile
Sep 11, 2011 4:39:45 PM
0
(0)
Professor

I doubt if it's anything to do with your account. My WiFi only tablet has an issue with GTalk logging out.

I doubt if it's anything to do with your account. My WiFi only tablet has an issue with GTalk logging out.

Re: Gmail and Talk issue on Atrix

4 of 11 (744 Views)
0
(0)
  • Rate this reply
View profile
Sep 11, 2011 10:36:37 PM
0
(0)
Mentor
Edited by RedVFR on Sep 11, 2011 at 10:48:26 PM

I have to disagree, at least as far as my problem is concerned. My Asus Transformer (wifi only as well) NEVER has any issues with logouts. That coupled with the fact that my Captivate running Gingerbread also has no issues with logouts whatsoever on wifi or 3G leaves me with Motoblur as the odd man out in the equation. If I can get the Aria I loaned to a friend back, I'll try putting Gingerbread on that too, just to prove my case.

 

Do you have your tablet tethered to your Atrix when it has the logut problem? If you do, I'd bet that's the issue on the tablet having problems with logouts as well.

 

EDIT: And just so we're on the same page, when I say account, I'm referring to my Motoblur account. Not my Google account or my AT&T account.

I have to disagree, at least as far as my problem is concerned. My Asus Transformer (wifi only as well) NEVER has any issues with logouts. That coupled with the fact that my Captivate running Gingerbread also has no issues with logouts whatsoever on wifi or 3G leaves me with Motoblur as the odd man out in the equation. If I can get the Aria I loaned to a friend back, I'll try putting Gingerbread on that too, just to prove my case.

 

Do you have your tablet tethered to your Atrix when it has the logut problem? If you do, I'd bet that's the issue on the tablet having problems with logouts as well.

 

EDIT: And just so we're on the same page, when I say account, I'm referring to my Motoblur account. Not my Google account or my AT&T account.

Re: Gmail and Talk issue on Atrix

[ Edited ]
5 of 11 (735 Views)
0
(0)
  • Rate this reply
View profile
Sep 11, 2011 11:07:30 PM
0
(0)
Professor

Ok. I'm with you now. I now think that I have a different issue with a similar symptom.

Ok. I'm with you now. I now think that I have a different issue with a similar symptom.

Re: Gmail and Talk issue on Atrix

6 of 11 (731 Views)
0
(0)
  • Rate this reply
View profile
Sep 29, 2011 6:18:09 PM
0
(0)
Mentor
Ok, new development. I have also used a brand new, never used Inspire with the same issue. This leads me to believe that there must be an issue with Gingerbread on at&t's 4G network. My reason for believing this is the problem is that my 3g Captivate does not have the logout problem. If I could force my inspire or atrix to be on 3g, I could verify this, but I'm having no luck doing so. Is this a known issue, or not? I don't know if it's a problem only in my area or if it's network wide. Quite frankly, it's ticking me off. If I use one of my "high performance" phones, I have to wonder if I'll get my emails in a timely fashion or not.
Ok, new development. I have also used a brand new, never used Inspire with the same issue. This leads me to believe that there must be an issue with Gingerbread on at&t's 4G network. My reason for believing this is the problem is that my 3g Captivate does not have the logout problem. If I could force my inspire or atrix to be on 3g, I could verify this, but I'm having no luck doing so. Is this a known issue, or not? I don't know if it's a problem only in my area or if it's network wide. Quite frankly, it's ticking me off. If I use one of my "high performance" phones, I have to wonder if I'll get my emails in a timely fashion or not.

Re: Gmail and Talk issue on Atrix

7 of 11 (634 Views)
0
(0)
  • Rate this reply
View profile
Oct 6, 2011 10:06:56 PM
0
(0)
Mentor
Edited by RedVFR on Oct 6, 2011 at 10:12:45 PM

I think I just discovered what is happening, although the reason why is still not apparent. While playing with data settings, I unchecked the "Background data" option and tried to use the Google Talk app....bingo, the Talk app requires background data be enabled.

 

So, for some reason background data is not staying connected when enabled on both my Atrix and my Inspire, which would explain why push email isn't working properly or is delayed and why I'm constanly having to log in to the Talk app. As this does NOT happen with my Captivate or when on wifi, I can only assume that the responsibility for this is directly on AT&T's "4G" network and the way it handles background data.

 

Any network techs care to weigh in on this? I've had a LOT of time into researching this and effing around with settings on both 4G phones, and IMO, there is no other answer. What I want to know, make that DEMAND to know, is when will this issue be acknowledged and fixed? I've been a customer for almost ten years, I pay my bills, I even reccomend the service. To have to deal with this kind of problem and investing much personal time into figuring it out for myself makes me feel like exploring other options in wireless, even though I'd rather not.

I think I just discovered what is happening, although the reason why is still not apparent. While playing with data settings, I unchecked the "Background data" option and tried to use the Google Talk app....bingo, the Talk app requires background data be enabled.

 

So, for some reason background data is not staying connected when enabled on both my Atrix and my Inspire, which would explain why push email isn't working properly or is delayed and why I'm constanly having to log in to the Talk app. As this does NOT happen with my Captivate or when on wifi, I can only assume that the responsibility for this is directly on AT&T's "4G" network and the way it handles background data.

 

Any network techs care to weigh in on this? I've had a LOT of time into researching this and effing around with settings on both 4G phones, and IMO, there is no other answer. What I want to know, make that DEMAND to know, is when will this issue be acknowledged and fixed? I've been a customer for almost ten years, I pay my bills, I even reccomend the service. To have to deal with this kind of problem and investing much personal time into figuring it out for myself makes me feel like exploring other options in wireless, even though I'd rather not.

Re: Gmail and Talk issue on Atrix

[ Edited ]
8 of 11 (611 Views)
0
(0)
  • Rate this reply
View profile
May 7, 2012 1:22:49 PM
0
(0)
Contributor

I know this is a very delayed response, but I've been dealing with the exact same thing on my skyrocket and figured that it has to be a 4g network problem. It's not a problem with the physical phone (this is the second one i've seen the issue on), and not a problem with the gmail server (when I'm on wifi, I get notifications instantaneously). I've contacted ATT technical support numerous times and they seem clueless about any issue.

I know this is a very delayed response, but I've been dealing with the exact same thing on my skyrocket and figured that it has to be a 4g network problem. It's not a problem with the physical phone (this is the second one i've seen the issue on), and not a problem with the gmail server (when I'm on wifi, I get notifications instantaneously). I've contacted ATT technical support numerous times and they seem clueless about any issue.

Re: Gmail and Talk issue on Atrix

9 of 11 (319 Views)
0
(0)
  • Rate this reply
View profile
May 7, 2012 11:33:54 PM
0
(0)
Employee
Att won't have an answer from you unless Google or the device manufacturer tells us. They don't support Google apps.
Att won't have an answer from you unless Google or the device manufacturer tells us. They don't support Google apps.
*I am an AT&T employee and the postings on this site are my own and don’t necessarily represent AT&T’s position, strategies or opinions.

Re: Gmail and Talk issue on Atrix

10 of 11 (307 Views)
0
(0)
  • Rate this reply
View profile
May 9, 2012 6:59:30 AM
0
(0)
Tutor

Motorola has some really good forums, maybe check that out.

 

https://forums.motorola.com/hives/a3f29dc0f5/summary

Motorola has some really good forums, maybe check that out.

 

https://forums.motorola.com/hives/a3f29dc0f5/summary

Re: Gmail and Talk issue on Atrix

11 of 11 (289 Views)
Share this post
Share this post