Helpful Links

Galaxy S2 GPS not locking

Contributor

Galaxy S2 GPS not locking

I have been having problems with the GPS not locking position over the last 2 weeks. I have seen this problem while using Google Maps Navigation (ver 6.0.3) with 2.3.5 and 2.3.6 versions of Android. Tried a couple of GPS test apps - GPS status and GPS Test - both not able to lock in the current position with or without wifi. It has worked very well before. 

 

Any suggestions on what might have gone wrong?

 

 

1,118 Views
Message 1 of 4
Contributor

Re: Galaxy S2 GPS not locking

I am having the EXACT same problem as you.  Does anyone have any insight on this problem?

Message 2 of 4
Highlighted
Mentor

Re: Galaxy S2 GPS not locking

Yeah. Me too.

Message 3 of 4

Re: Galaxy S2 GPS not locking

Working fine for me.  Sometimes it seems that the GPS assistance data can get messed up though, so try the following:

 

Get GPS Status and Toolbox from the Market - {commercial link removed}

 

Go into it, and do Menu->Tools->Manage A-GPS State->Reset followed by Download

 

If that doesn't work - try locking when in airplane mode.  Give it 5 minutes or so for a cold lock, and make sure to be stationary with a clear view of the sky.

 

Usually once you get your first lock you shouldn't have trouble relocking in more typical use cases.

Message 4 of 4
Share this topic
Announcements

Is the iPhone X worth it? Find out why it totally is!

Find out how to track your iPhone's delivery!

Let us help you Give the Gift of AT&T Wireless this holiday season!

Additional Support