GS2 Max Video Size Error + Loss of Data

Tutor

GS2 Max Video Size Error + Loss of Data

I was recording an important event this weekend at 1080p and after ~30 minutes the camera pops an error stating I've reached the max file size.  At the time I thought nothing of it and just hit record again to continue recording the event.  The same error popped about 30minutes later.  Then recorded 2 more smaller videos.

 

To my surprise when I got back to the office, the first 2 videos that threw the error were on the filesystem as 0bytes.  When the camera throws this error, apparently it gives up and flags the main data file it's been writing for deletion and writes a video file of 0 bytes.  HUGE BUMMER to say the least.

 

I called Samsung and regrettably they said the files are lost forever, and nothing can be done (although I was pleased to have no hold time, and a US english speaking support rep).  It wouldn't hurt for anyone else having this issue to call and report it also to get the problem escalated so we can hope for a fix someday.

 

So at this point I run a data recovery tool on the flash drive.  The first video's sectors had been written over by a later video so it was unrecoverable; however, the 2nd video was in-tact.  The only problem is it was a .3gs file and every player I've tried it on says the file is corrupted.  I believe the video player never had time to write the header or footer and I haven't located any video repair utilities which will repair a 3gs file.  Anybody have any ideas on how I might be able to restore this?

Message 1 of 1 (113 Views)
Share this topic
Announcements

Welcome to the AT&T Community Forums!!! Stop by the Community How-To section for tips on how to get started.