Helpful Links

Can't connect Nook Simle Touch to home wifi


Can't connect Nook Simle Touch to home wifi

Windows 7 64-bit PC, 3801HGV Router


Trying to connect my new Nook Simple Touch reader to the home network. I have the wireless enabled in the Nook and it sees my home network SSID just fine. It also sees all my neighbors networks too. But when I try to connect the Nook to the network I constantly get a "incorrect passord" message. Tried using the 10 digit network key from the yellow sticker on the side of the box with no success. Also tried using the 10 digit "device access code" from the other side of the box and no luck with that either.  I also tried going into the Router control panel via to set my own custom wireless network key. And while that correctly save and displays in the router control panel it still won't work to connect the Nook to the network. What am I missing? 

Tags (1)
Message 1 of 4

Re: Can't connect Nook Simle Touch to home wifi

The password should be the password you set up for your WiFi access when you set up your router.
Employee Contributor*
*I am an AT&T employee and the postings on this site are my own and don't necessarily represent AT&T's position, strategies or opinions.
Message 2 of 4

Re: Can't connect Nook Simle Touch to home wifi

I am having the same problem with my Nook Simple Touch.  I am using the wireless password that works with all other wireless devices, but the Nook keeps saying incorrect password.  Browing some other sites there are suggestions that this is an incompatibility between the Nook and the 2Wire residential gateway.  If anyone has a real solution please post it.

Message 3 of 4

Re: Can't connect Nook Simple Touch to home wifi

This solved the issue for me:  Went to Nook support and found a suggestion to upgrade the software to v. 1.1.0 at this site:


It tells you to download a zip file, plug your Nook into your computer thru the USB port, and when the Nook shows up in your file director, move the zip file to the main folder of the Nook without taking any other action.  The directions say that when your Nook goes to sleep, it will automatically run the update, but my Nook never went to sleep so I thought the update failed.  But while I was on hold with BN support, I unpluggd the Nook from my computer and the update started running.  The update finished installing and I was then able to log into my network and complete the registration process with no further issues.


Hopes this helps someone.

Message 4 of 4
Share this topic

Learn how connect your AT&T holiday gifts at Unwrapped on Wednesday, 12/27 (1-4pm ET)!

Is the iPhone X worth it? Find out why it totally is!

Find out how to track your iPhone's delivery!

Additional Support