Beware! New Samsung Galaxy Skyrocket CAN'T EVEN MESSAGE!

Contributor

Beware! New Samsung Galaxy Skyrocket CAN'T EVEN MESSAGE!

[ Edited ]

What a rip off... It seems my smartphone is incapable of sending or receiving MMS messages (included in my UNLIMITED messaging plan) without access to packet data (but I bought the smallest plan, since that's all I need for actual DATA). 

 

I've had "dumb" phones for years that at least let me send and receive pictures.

 

Does anybody know if this is an idiotic Samsung hardware mistake or just AT&T being greedy and conniving?

Message 1 of 22 (13,518 Views)
Highlighted
Expert

Re: Beware! New Samsung Galaxy Skyrocket CAN'T EVEN MESSAGE!


nailbizarre wrote:
I found out today that mms messaging will not work if the mobile data setting is turned off. This is the setting on the actual phone. So if you are on wifi only, mms messages will not send or be recieved/downloaded . This is an obvious way for att to suck more money out of you. I had an Inspire that allowed me to send mms messages as well as receive them over my wifi, so I basically just spent a ton of money on this skyrocket which is basically a lower quality phone compared to my inspire.


No thisis the way that MMS works, if you have a data block on a qmd device or your data services turned off on a smarthpne you cannot send mms messages, this is true for any phone. In fact on a iphone if you turn data off not only does mms not work but visual voice mail does not either.

 

Unltimited texting includes mms message data. Not sure how you did it on the inspire, it won;t do it on mine if data is off

Message 16 of 22 (12,692 Views)
Contributor

Re: Beware! New Samsung Galaxy Skyrocket CAN'T EVEN MESSAGE!

If I read correctly even though you have to use data fro mms, if you have unlimited messaging then it should not count against you data? I have Skyrocket and others in family have non smartphones and no data plans and they send mms attachements in txt messages all day long.

Message 17 of 22 (12,619 Views)
Expert

Re: Beware! New Samsung Galaxy Skyrocket CAN'T EVEN MESSAGE!


ekalbach wrote:

If I read correctly even though you have to use data fro mms, if you have unlimited messaging then it should not count against you data? I have Skyrocket and others in family have non smartphones and no data plans and they send mms attachements in txt messages all day long.



it doesn.t but wirless data has to be turned on or not have a data block on the number for it to work.

Message 18 of 22 (12,616 Views)
Tutor

Re: Beware! New Samsung Galaxy Skyrocket CAN'T EVEN MESSAGE!

Have had my skyrocket for a week now, i cannot send or receive mms messages. I have unlimited internet and messaging. Is there something in the settings i should check. i can receive still picture thru text messaging and send.
Message 19 of 22 (11,960 Views)
Contributor

Re: Beware! New Samsung Galaxy Skyrocket CAN'T EVEN MESSAGE!

How do I know if my data package is turned on or off? I have problems with text messages failing when I am trying to send a picture. Sometimes it takes a long time for a message to go through or I have to repeatedly send the message after it fails over and over. Also there are times I can not access the interent or get my emails with the Skyrocket. It's a bit fustrating becuase I do not know how to fix the issue, Please help.

Message 20 of 22 (10,399 Views)
Contributor

Re: Beware! New Samsung Galaxy Skyrocket CAN'T EVEN MESSAGE!

My new Skyrocket can send texts & photos fine.  It can receive plain texts from my husband's & one son's iPhones, but not picture texts.  It also does not receive either plain or picture texts from my other son's Android phone. What's up with that???

Message 21 of 22 (9,277 Views)
Scholar

Re: Beware! New Samsung Galaxy Skyrocket CAN'T EVEN MESSAGE!

[ Edited ]

nugoosh wrote:

What a rip off... It seems my smartphone is incapable of sending or receiving MMS messages (included in my UNLIMITED messaging plan) without access to packet data (but I bought the smallest plan, since that's all I need for actual DATA)

 

I've had "dumb" phones for years that at least let me send and receive pictures.

 

Does anybody know if this is an idiotic Samsung hardware mistake or just AT&T being greedy and conniving?


WWOOOOWWWWW, there is sooooo much misinformation in this thread. The OP HAS a data plan as was clearly stated in the post. As some others have stated, sending MMS does require access to the data network, so if you have a data block on your line it will not work. That does not seem to be the case here though.

 

I know for a fact that you do NOT have to have packet data turned on in order to send MMS messages. You do, however, need to have your APN setup correctly. You can have your apn setup to use the internet (packet data) and it not be able to send or receive MMS messages. There is a specific setting for that. If the MMS settings in the APN are not configured, or are configured incorrectly it will not work. If you are using a custom APN without the correct settings it will not work either. You may have to revert to the default APN settings to see if that fixes the issue.

 

The reason I say I know this for a fact is that I just went through this with my wife's phone. She is using my x10 running GB and I specifically disabled packet data so she couldn't accidentally use data since there is no data plan on her line. I created the APN and as soon as I did she was able to send / receive MMS messages with packet data turned off.

 

Tl;dr Check your APN settings, or call AT&T about it. "Use packet data" has nothing to do with MMS.

 

Here is a screenshot of what your APN should look like for the MMS settings. (pulled from my SGS2). You access the APN settings by going into "Settings-->Wireless and network-->Mobile Networks-->Access Point Names". You can reset them to default by pressing the menu button on this screen and select "Reset to default".

 

Message 22 of 22 (9,210 Views)
Share this topic
Announcements

Welcome to the AT&T Community Forums!!! Stop by the Community How-To section for tips on how to get started.