AT&T Tilt WM6.1 DST Issue? Tilt created appointments WON'T sync

Highlighted
Tutor

AT&T Tilt WM6.1 DST Issue? Tilt created appointments WON'T sync

[ Edited ]
Since the daylight savings time change took effect on Sunday, appointments I create on my Tilt will no longer successfully sync to my Exchange Server (2003).  I have no problem synchronizing any other items (including Tasks) and am able to sync appointments created on my desktop to my Tilt without issue.
 
So far I've deleted/recreated my partnership with the Exchange Server, but it didn't make any difference.  I've also turned on verbose logging and compared Microsoft Exchange logs with a co-worker and can't identify any glaring differences other than his appointments will sync (he's a Sprint customer using a Touch though).
 
My time zone is correct and the local time on the Tilt matches the Exchange Server.  AT&T support handed me to HTC who told me to delete/recreate the partnership (which didn't fix it) and then recommended I perform a hard reset (which results in 3 or 4 hours of my time to get my phone back to where I want it) - haven't gone that far yet.
 
Anyone else experiencing this issue? 


Message Edited by dugsdad on 11-05-2008 10:38:53 AM
Message 1 of 43 (8,047 Views)
Scholar

Re: AT&T Tilt WM6.1 DST Issue?

There is a patch for DST.

 

Link to file

Message 2 of 43 (8,042 Views)
Tutor

Re: AT&T Tilt WM6.1 DST Issue?

The patch is for Windows Mobile versions 5.0 and 6.0.  This is happening on a 6.1 ROM which I would hope already includes this fix.  The device had no issue correctly changing over to the new time automatically.  I just haven't been able to sync appointments created on the Tilt since.
Message 3 of 43 (8,036 Views)
Scholar

Re: AT&T Tilt WM6.1 DST Issue?

Have you check you PC side for any pathces?

You might have had a corruption in the databases on your device that are used for Syncing your device.
Message 4 of 43 (8,030 Views)
Tutor

Re: AT&T Tilt WM6.1 DST Issue?

I'm not synchronizing with a PC, but directly to the Exchange server via Push.  Other mobile users aren't having the issue, but there are also no others using the Tilt with AT&T's WM6.1 ROM.
 
Can anyone else with a Tilt and the stock AT&T WM6.1 ROM confirm that they can/can't successfully create an appointment on their device and then sync to their Exchange Server over the air?
Message 5 of 43 (8,025 Views)
Scholar

Re: AT&T Tilt WM6.1 DST Issue?

Sorry, I didn't realize that you were directly communicating with your Exhcnage server. Different process for Syncing.

(bows head and gracefully backs away)
Message 6 of 43 (8,021 Views)
Tutor

Re: AT&T Tilt WM6.1 DST Issue? Tilt created appointments WON'T sync

Thank you for the attempts Smiley Happy
 
Any one out there able to verify this happens/doesn't happen on their WM6.1 Tilt?
Message 7 of 43 (7,982 Views)
Guru

Re: AT&T Tilt WM6.1 DST Issue? Tilt created appointments WON'T sync

same problem (patch did not work; using exchange server; no sync with physical PC) - solution was to manually adjust the clock.
Message 8 of 43 (7,966 Views)
Tutor

Re: AT&T Tilt WM6.1 DST Issue? Tilt created appointments WON'T sync

Thank you, thank you, thank you!!!! Smiley Very Happy
 
Now that you mentioned that I remember that part of the original patch back on WM5.0 and WM6.0 was to manually change the time zone after the patch was installed and then change it back in order for it to kick in. I never thought to try that here assuming that it wouldn't be necessary on WM6.1.  After doing exactly that, it worked.
 
If you have this problem, change your time zone to one that has a different offset from GMT than the zone you are currently in (I'm in GMT-6 so changed it to GMT-7).  Accept that change.  It will warn you ithat t will move your appointments, but that's alright because you'll move it right back.  Once accepted, go back and change it to your actual time zone.  Force a sync to Exchange and your appointments created on your Tilt should now sync without error.
 
Thank you again, prubin.  I was about 5 minutes away from restoring a backup and hoping for the best.
Message 9 of 43 (7,939 Views)
Voyager

Re: AT&T Tilt WM6.1 DST Issue? Tilt created appointments WON'T sync

[ Edited ]
I have the same problem.  I sync directly with the exchange server and noticed yesterday that calendar items created on the tilt didn't snyc to the exchange server.  I was getting an error at that time.  I ran across the information about changing time zones and did that then forced a sync.  I then changed my time zone back to the proper one and did the sync and calendar items were syncing just fine.  I even added some test ones and they worked.
 
Today the same problem (almost) is back.  Calendar items created on the tilt don't sync with exchange.  I don't get any error on activesync but they just don't sync.  Having to change the time zone back and forth each day isn't a workable solution.
Anyone else having the same problem? 


Message Edited by paperman on 11-06-2008 01:27:13 PM
Message 10 of 43 (7,866 Views)

Re: AT&T Tilt WM6.1 DST Issue? Tilt created appointments WON'T sync

I don't have this problem but has anyone looked at this from the exchange server side?  The assumption seems to be that this is a WM6.1 issue and that very well may be correct.  However, since the server side software probably had to be patched because the software was written before the DST changes were enacted there might also be something with how it processes and recognizes the data from a device that did not need a corresponding patch.  This might be something to look at in the Microsoft forums.
Message 11 of 43 (4,454 Views)
Tutor

Re: AT&T Tilt WM6.1 DST Issue? Tilt created appointments WON'T sync

Smiley IndifferentThink I'm going to have our Exchange Admin look into this a little deeper today as you suggest.  For the last two days things have been going fine with syncing appointments created on the Tilt (after the time zone switch/switch back fix), but now out of the blue the time zone on my Tilt keeps reverting back to GMT 0 (Casablanca). Pretty easy to notice as all my appointments moved 6 hours.  I'll go back in and apply the right time zone and it will be alright for a while and then I'll find it back to GMT0.  At first I thought it was happening every time i sync with the server, but after setting the time zone and immediately forcing a sync I found that not to be true.  Maybe it's only when there is something new to sync?
 
I spent a few minutes searching through the Msft forums this morning (mostly the Mobile forum) and I'm not finding any new postings. I will say though that many of the posts from back in Feb/Mar relating to the DST change sound very familiar to the issues showing up now.  Almost wonder if the WM6.1 updates didn't have the latest code base surrounding DST.  I know of at least two other WM6.1 users in our organization that are having similiar problems (both on Treos) and that the WM6.0 users I've talked to have NOT seen the issues.
 
Whatever the issue, I hope someone steps up to the plate with a fix soon. This is getting awful tiring.
Message 12 of 43 (4,438 Views)
Contributor

Re: AT&T Tilt WM6.1 DST Issue? Tilt created appointments WON'T sync

Same situation. Syncing with MS exchange directly and Tilt appointments not syncing back to exchange. I played around with the time clock on my Tilt and now everything is ok.
Message 13 of 43 (4,403 Views)
Contributor

Re: AT&T Tilt WM6.1 DST Issue? Tilt created appointments WON'T sync

I'm having the same problem ( events created on the tilt do not sync with the exchange server ). But the time settings seem to be just fine. Could someone explain a bit more about what you changed? I upgraded my tilt to the 6.1 version a couple of days ago which seems to have introduced the problem.
Message 14 of 43 (4,364 Views)
Tutor

Re: AT&T Tilt WM6.1 DST Issue? Tilt created appointments WON'T sync

I am having the same problem with my Tilt and WM6.1 ever since the Time Change. It is very annoying since I am in the field most of the day and rely on our Admin Assistant to look at my up-to- date calendar to see when I am available. I constantly add, change, and delete appointments while in the field and this function is critical. AT&T or HTC really needs to get this function fixed ASAP.

 

I have tried the altering the time clock a few times to no avail. If I have to go back to WM 6.0 until AT&T or HTC can get their act together for their customers I will. Since I bought this device right when WM6.1 came out and upgraded I am not sure if WM6.0 had the same issues. If I downgraded to 6.0 would it fix the situation? I also sync through Exchange Server. I am surprised that more are not posting this problem for the Tilt. Either 99% of the people do not use Exchange Server or there is a fix out there somewhere.

Message 15 of 43 (4,275 Views)
Share this topic
Announcements

Welcome to the AT&T Community Forums!!! Stop by the Community How-To section for tips on how to get started.