Reply
Posted Aug 9, 2012
10:37:57 AM
View profile
Lumia 900 touch screen problem (interlaced rows and digitizer is not picking up touches)

My Lumia 900 is giving me a really bad problem.Much of the screen is now interlaced - basically alternating rows (or perhaps groups) of pixels are not displaying on the screen. At the same time, the touch screen is very hard to use. It's hard to press keys, to swipe. I notice that in messaging (emails), it's very hard to even select emails or to swipe - (the screen background then is white).

 

For SMS, it's very difficult and slow to type messages now.

 

When this started happening, I would just turn off the screen and turn it back on - often the problem would go away (= I would see the full screen without the interlacing problem). Now, it's less "normal" - i rarely have a properly functioning screen.

I've used the On Service diagnostics (##634#) to check the "basic integrity of the touchscreen" - and it confirms that the touchscreen seems pretty dead. I'm traveling out of the country right now, so I won't be able to visit an AT&T service centre yet - althought I might try to drop in some of the Nokia shops

 

I've taken several pictures of the issue - you need to zoom into 100% (or more) to really see the problem.

 

I think the problem is with digitizer or maybe the connector for the digitizer. Has anyone had this problem? Any solutions?

 

More photos from my duplicate post to the Nokia Support forum.

 

Thanks!

 

My Lumia 900 is giving me a really bad problem.Much of the screen is now interlaced - basically alternating rows (or perhaps groups) of pixels are not displaying on the screen. At the same time, the touch screen is very hard to use. It's hard to press keys, to swipe. I notice that in messaging (emails), it's very hard to even select emails or to swipe - (the screen background then is white).

 

For SMS, it's very difficult and slow to type messages now.

 

When this started happening, I would just turn off the screen and turn it back on - often the problem would go away (= I would see the full screen without the interlacing problem). Now, it's less "normal" - i rarely have a properly functioning screen.

I've used the On Service diagnostics (##634#) to check the "basic integrity of the touchscreen" - and it confirms that the touchscreen seems pretty dead. I'm traveling out of the country right now, so I won't be able to visit an AT&T service centre yet - althought I might try to drop in some of the Nokia shops

 

I've taken several pictures of the issue - you need to zoom into 100% (or more) to really see the problem.

 

I think the problem is with digitizer or maybe the connector for the digitizer. Has anyone had this problem? Any solutions?

 

More photos from my duplicate post to the Nokia Support forum.

 

Thanks!

 

0
(0)
  • Rate this reply
View profile
Solved
Aug 29, 2012 9:32:10 AM
0
(0)
Tutor

Yup, I took it back. But at the AT&T corporate store, I was directed to the AT&T Wireless Device Service Centers (there are 2 in midtown NYC, another 2 more around NYC). There, the service agents must witness the error. The first time I went, the phone behaved itself. The next day it showed the problem and I was able to show the agent there. They gave me a new device and switched phones right away.

 

I tried to backup the phone (there are some tools in xda-developer forums that trick Zune to make a backup of the device), however, I couldn't successfully restore my data, so I had to re-install all the apps. All my data is online somewhere, so the sync was easy - except I didn't have call histories, SMS, linked contacts, any app data stored on the device (also all images, videos, music, podcasts - but that's a sync from Zune).

 

Another issue fixed: 4G LTE connections

On the first visit, I was given a new SIM card (I asked for one - as it was a regular SIM that was cut by someone at Best Buy). With the new device (which has the new SIM) I'm getting 4G LTE very consistently in the city, addressing this issue I had (and had posted here).

Accepted Solution

Lumia 900 touch screen problem (interlaced rows and digitizer is not picking up touches)

8,906 views
2 replies
(0) Me too
(0) Me too
Post reply
Cancel
Submit
View all replies
(2)
0
(0)
  • Rate this reply
View profile
Solved
Aug 17, 2012 10:47:45 PM
0
(0)
Scholar
Take it back and get a new one. I took mine back l, because I found a dead pixel in landscape mode. I couldn't type the letters n&j. I showed the representative at the at&t store and exchanged the phone for a replacement free of charge.
Take it back and get a new one. I took mine back l, because I found a dead pixel in landscape mode. I couldn't type the letters n&j. I showed the representative at the at&t store and exchanged the phone for a replacement free of charge.
Phones Owned (1999-Now): Nokia 5110, 3390, 3520, 6230, 6682, N72, 5800XM, Lumia 800, Lumia 900, Lumia 920 (Currently owned)

Re: Lumia 900 touch screen problem (interlaced rows and digitizer is not picking up touches)

2 of 3 (8,780 Views)
Solution
0
(0)
  • Rate this reply
View profile
Solved
Aug 29, 2012 9:32:10 AM
0
(0)
Tutor

Yup, I took it back. But at the AT&T corporate store, I was directed to the AT&T Wireless Device Service Centers (there are 2 in midtown NYC, another 2 more around NYC). There, the service agents must witness the error. The first time I went, the phone behaved itself. The next day it showed the problem and I was able to show the agent there. They gave me a new device and switched phones right away.

 

I tried to backup the phone (there are some tools in xda-developer forums that trick Zune to make a backup of the device), however, I couldn't successfully restore my data, so I had to re-install all the apps. All my data is online somewhere, so the sync was easy - except I didn't have call histories, SMS, linked contacts, any app data stored on the device (also all images, videos, music, podcasts - but that's a sync from Zune).

 

Another issue fixed: 4G LTE connections

On the first visit, I was given a new SIM card (I asked for one - as it was a regular SIM that was cut by someone at Best Buy). With the new device (which has the new SIM) I'm getting 4G LTE very consistently in the city, addressing this issue I had (and had posted here).

Yup, I took it back. But at the AT&T corporate store, I was directed to the AT&T Wireless Device Service Centers (there are 2 in midtown NYC, another 2 more around NYC). There, the service agents must witness the error. The first time I went, the phone behaved itself. The next day it showed the problem and I was able to show the agent there. They gave me a new device and switched phones right away.

 

I tried to backup the phone (there are some tools in xda-developer forums that trick Zune to make a backup of the device), however, I couldn't successfully restore my data, so I had to re-install all the apps. All my data is online somewhere, so the sync was easy - except I didn't have call histories, SMS, linked contacts, any app data stored on the device (also all images, videos, music, podcasts - but that's a sync from Zune).

 

Another issue fixed: 4G LTE connections

On the first visit, I was given a new SIM card (I asked for one - as it was a regular SIM that was cut by someone at Best Buy). With the new device (which has the new SIM) I'm getting 4G LTE very consistently in the city, addressing this issue I had (and had posted here).

Re: Lumia 900 touch screen problem (interlaced rows and digitizer is not picking up touches)

3 of 3 (8,621 Views)
Solution
Share this post
Share this post