Ask a question
Search in Wireless Forums

Wireless Forum

Reply
Posted Jan 29, 2013
6:10:07 PM
View profile
I put a new sim card in my nokia lumia 900 and the sim is saying invalid sim now
 
0
(0)
  • Rate this reply
View profile
Solved
Feb 7, 2013 12:16:39 PM
0
(0)
Employee

Hi! Try this link and let me know if it helped. Troubleshoot your device

*I am an AT&T employee and the postings on this site are my own and don’t necessarily represent AT&T’s position, strategies or opinions.
Accepted Solution

I put a new sim card in my nokia lumia 900 and the sim is saying invalid sim now

20,625 views
3 replies
(0) Me too
(0) Me too
Reply
View all replies
(3)
0
(0)
  • Rate this reply
View profile
Solved
Feb 7, 2013 12:16:39 PM
0
(0)
Employee

Hi! Try this link and let me know if it helped. Troubleshoot your device

Hi! Try this link and let me know if it helped. Troubleshoot your device

*I am an AT&T employee and the postings on this site are my own and don’t necessarily represent AT&T’s position, strategies or opinions.

Re: I put a new sim card in my nokia lumia 900 and the sim is saying invalid sim now

2 of 4 (20,487 Views)
Solution
0
(0)
  • Rate this reply
View profile
Feb 7, 2013 9:42:47 PM
0
(0)
Scholar

Not that uncommon. I had to go to an AT&T store to get another sim card for my out of the box Lumia 920.

The one that came with the phone was bad. Call customer service if the link doesn't help.

Not that uncommon. I had to go to an AT&T store to get another sim card for my out of the box Lumia 920.

The one that came with the phone was bad. Call customer service if the link doesn't help.

Re: I put a new sim card in my nokia lumia 900 and the sim is saying invalid sim now

3 of 4 (20,473 Views)
0
(0)
  • Rate this reply
View profile
Feb 23, 2013 10:21:33 PM
0
(0)
Contributor

I just had the same thing happen with the SIM that came in my out-of-the-box Lumia 920, which is extremely inconvenient because now both phones are completely useless to me until customer service opens!  Not terribly impressed with ATT right now. 

I just had the same thing happen with the SIM that came in my out-of-the-box Lumia 920, which is extremely inconvenient because now both phones are completely useless to me until customer service opens!  Not terribly impressed with ATT right now. 

Re: I put a new sim card in my nokia lumia 900 and the sim is saying invalid sim now

4 of 4 (20,213 Views)
Share this post
Share this post