Annoying Propel Connection Problem

Annoying Propel Connection Problem

I have an app on my propel that requires a constant network connection. On my phone, when I run the app and it requests access to the network, I get a notification with two options:

 

 "Allow access to application, ask again later"

"Don't allow access to application, ask again later"

 

Is there any way to enable a sort of "Allow access to application, DON'T ask again later"?

 

Thanks

 

-Andrew

Message 1 of 15 (3,594 Views)

Re: Annoying Propel Connection Problem

I am also having this same problem.  How can I allow a particular app to not require my constant approval.
Message 2 of 15 (3,548 Views)

Re: Annoying Propel Connection Problem

[ Edited ]

Here is the text from my conversation with AT&T reps which solved nothing.



Chat InformationPlease wait for a representative to respond.

Chat InformationWelcome to AT&T Data Support Chat. My name is 'Damon' and I’ll be happy to assist you today.

Damon: Hello. I apologize for the inconvenience you are experiencing today. Thank you for giving me the opportunity today to assist you with your issue of grating an application permanant permission to work. Before we begin how would you like to be addressed during our interaction today ( e.g. your first name, last name, Mr, Ms...etc.)?

Daniel Noltnesmeyer: Dan is fine

Damon: Ok Dan thank you. I will need to access your account. Will this be ok?

Daniel Noltnesmeyer: yes

Damon: This is a secure channel. Please provide the following information;

1-The wireless phone number you are inquiring about, area code first.
2-The first and last name as listed on the account.
3-Your full name.
4-The last four digits of the Social Security # or password listed on the account.

Please bear with me while I access your account. Once I have the information it may take me 1-2 minutes to complete this.
Thank you.

EDITED OUT PERSONAL INFO


Damon: Thank you Dan

Damon: Which application are you trying to downlaod

Daniel Noltnesmeyer: I have a couple that are having the problem. One is a messaging client that access Gtalk.

Daniel Noltnesmeyer: The other is an email client called flurrymail that I use to access my work email.

Damon: Are you trying to download the applications?

Daniel Noltnesmeyer: I have them downloaded and they work. I can use them but I am constantly prompted with:

Daniel Noltnesmeyer: "Allow access to application, ask again later" "Don't allow access to application, ask again later" Is there any way to enable a sort of "Allow access to application, DON'T ask again later"?

Damon: Okay so that pop up comes up every time you access the applications? Does it do it to all of them?

Daniel Noltnesmeyer: It pops up when I initially start the application, and pops up over and over again as the application is running.

Damon: It does that to both of those applications?

Daniel Noltnesmeyer: yes

Damon: have you reset the device at all?

Daniel Noltnesmeyer: no

Damon: Can you go ahead and remove your battery and sim card out of your device while your phone is powered on please?

Daniel Noltnesmeyer: ok

Daniel Noltnesmeyer: done

Damon: Okay we will need to leave them out for 3-5 minutes. Did you ever reboot the phone after downloading these applications?

Daniel Noltnesmeyer: yes

Daniel Noltnesmeyer: ok, its been about 5 minutes, I'm putting the sim card and battery back in now

Daniel Noltnesmeyer: OK, its back on now

Damon: Okay can you try and access those apps now and see if you get that pop up error please?

Daniel Noltnesmeyer: Ok, the application started and I was warned with this message. eBuddy will send personal data. This will require the use of airtime for which you may be charged. Continue?

Daniel Noltnesmeyer: I chose the option:

Daniel Noltnesmeyer: This time, Aske me again next time.

Daniel Noltnesmeyer: The application connects like it should, but I am constantly presented with that same message over and over again.

Daniel Noltnesmeyer: There needs to be an option to allow access, and never ask me again.

Damon: Okay, can you bear with me for 3-4 minutes please?

Daniel Noltnesmeyer: Also, This message is presented with any application on the phone, even the built in ones like the internet browser. They will prompt me for permission, but only once when I first launch the program, not constantly

Daniel Noltnesmeyer: yes I can wait.

Damon: Sorry for the delay

Damon: I am still working on that, can you bear with me 3-5 more minutes please?

Daniel Noltnesmeyer: take your time.

Damon: Okay Daniel I am sorry but I do not show an internal resolution for your problem, at this time I will have to refer you directly to the device manufacturer Samsung. Please call Samsung directly at Samsung (888) 987-4357

Damon: Daniel I am sorry I couldn't be of more help. May I assist you with anything else today?

 

Mod edit: Removed last name of representative per forum guidelines.

Message Edited by Sentry on 02-12-2009 03:31:14 PM
Message 3 of 15 (3,531 Views)

Re: Annoying Propel Connection Problem

I called Samsung and was told that they can only support applications that came pre-installed on the phone and could not help me.
Message 4 of 15 (3,513 Views)

Re: Annoying Propel Connection Problem

Perhaps the phone needs to be unlocked in order to modify or disable this "feature".  I'm not sure what exatly is going to happen to the the phone if it is unlocked so I am not going to attempt this until I learn more about what can or will happen.

 

I hope that there will be some sort of firmware released that will allow this "feature" to be turned off, or allow the logical choice of "allow the application to access the data network, and do NOT prompt me for permission again"

 

 

AT&T How does one go about making feature requests for the phone firmware?

Message 5 of 15 (3,511 Views)

Re: Annoying Propel Connection Problem

I also learned that unlocking the phone may be a solution. I'm about to unlock mine, and I'll report back what happens...

 

I'm still completely open for suggestions however

 

-Andrew

Message 6 of 15 (3,490 Views)

Re: Annoying Propel Connection Problem

Cool, let me know how that goes.

 

My main concern with unlocking it is if if will lose its built in IM functions.  I believe they use SMS not data traffic.

 

Also, I'm hoping that unlocking it will allow you to remove the built in programs like mobile banking and mobiTV.

Message 7 of 15 (3,487 Views)

Re: Annoying Propel Connection Problem

I believe it will, considering it gives you complete writable access to the filesystem
Message 8 of 15 (3,481 Views)

Re: Annoying Propel Connection Problem


Andrizzle4040 wrote:

I have an app on my propel that requires a constant network connection. On my phone, when I run the app and it requests access to the network, I get a notification with two options:

 

 "Allow access to application, ask again later"

"Don't allow access to application, ask again later"

 

Is there any way to enable a sort of "Allow access to application, DON'T ask again later"?

 

Thanks

 

-Andrew


In the other applications, it all asks for Dont ask again later.. I think it may be best to upgrade the software on the phone at the shop or something. Unlocking wont solve the problem.

Message 9 of 15 (3,348 Views)

Re: Annoying Propel Connection Problem

I think the problem comes from the fact that the java app is unsigned. 

 

I've read some things that say having the application signed will allow the option to "allow, and dont ask again."

 

 

 

I've also read that the process of getting a java application signed involves about $400-$700 for EVERY version of the software.  Also, the certificate expires after one year, so the application developers must pay the CA for every version every year to remain a signed application.

 

This makes sense why the authors of these applications don't bother with paying a CA like verisign or whomever else is in the application signing business.  Even the Google apps like gmail and google maps aren't signed.

 

The applications that do appear to be signed (the ones that come pre-installed on the phone, and the ones availiable to be purchased at the MEdia net) require you to pay for them.  Several of these apps require a subscription of about $3 a month.

 

You can check to see if the app is signed by going to the app and selecting properties.  You will also notice that the CA that has signed these apps is AT&T or Cingular.  So basically this "security feature" is a way for at&t to eliminate comptition of free java apps from their paid applications that you can buy from them.

 

 

 

I've looked for a way around this.  The closest I came was installing your own homemade certificate and the signing the app to that homemade certificate.  Unfortuantly, there is no way to add your homemade certificate to the Propel the way you can on other "real" smart phones.

 

 

So, Unless the developer decides to pay have their app signed by a CA(which will probably never happen for a free application), we are probably stuck having to constatly grant permission for our apps to be able to access the data network that we are already paying for.

 

The other alternative would be for at&t or samsung to release a firmware that would allow this "security feature" of prompting for net access to be removed completely, but why would they.  They have us locked into thier proprietary system.   Lets hope they do the right thing and serve their already paying customers instead of simply trying to bilk us for more money.

Message 10 of 15 (3,272 Views)
Solution
Accepted by topic author Andrizzle4040
‎09-30-2015 1:39 AM

Re: Annoying Propel Connection Problem

I think I may have found some information to help solve this problem.  I have gained access to the phones file system without having it unlocked from the provider.

 

You need a USB data cable,  Qualcomm drivers,  a free program called BitPim to access the file system.

 

Using this I was able to remove the mobile banking app that comes on the phone.  I've run out of time so I'll just post links to the information I found.

 

http://thesynchole.com/viewtopic.php?f=3&t=3384

 

http://thesynchole.com/viewtopic.php?f=18&t=1158

 

Others have used this method to remove the nagging "allow acess" issue that we are having.  I havent gotten that far yet, but when I get more time I'll attempt it and report back.

Message 11 of 15 (3,320 Views)

Re: Annoying Propel Connection Problem

Thanks for being so helpful. I'll pick up a USB cable tomorrow. I'm interested for your next update.

 

-Andrew

Message 12 of 15 (3,296 Views)

Re: Annoying Propel Connection Problem

Forgive me for the double post, but I figured it out, thanks to Dnoltensmeyer and his helpful posts.

 

You have to use  a USB cable, Qualcomm drivers, and a hex editer, but it works for me now. I'm now only asked for permission ONCE.

 

Follow the tutorials linked my Dnoltensmeyer in his previous post and it will work like a charm. 

 

-Andrew

Message 13 of 15 (3,270 Views)

Re: Annoying Propel Connection Problem

Glad to hear it worked for you too.
Message 14 of 15 (3,263 Views)

Re: Annoying Propel Connection Problem

[ Edited ]
OK, I've had some success in getting rid of the nag screen on one of my apps.  
The app I'm using is called ebuddy and allows me to connect to several IM services at the same time including GTALK.  Being that it is an IM client that needs constant status updates, it would prompt me for permission to access the network about every two seconds.
After modifying the settings.bin file with a HEX editor and rebooting the phone, eBuddy started up and prompted me to "Allow and don't ask again"  I chose that option and didn't get prompted after that until I added my MSN account to eBuddy.  When I added the account I was prompted and only had the regular options of "Allow, and ask again next time", but it never asked again.  It seems there are certain actions with this app that will cause it top prompt, but they are rare requests and for the most part I am not prompted anymore.  So, I would consider this a success.  

Google mail does not appear to have a settings.bin file.  However I have read that there are ways around this.  I'll try it when I have time.
Here are the steps I took to "fix" eBuddy.
1, Change the USB mode on the phone.
 
On the Propel, dial *#0523# (this gets you into some debug screen)(WARNING!!! I'm betting you can mess up the phone pretty bad by messing with these settings so proceed at your own risk)  keep pushing # until you get to a menu that looks like this:
 
[1] Debug Screen
[2] Version Information
[3] RF Test
[4] UMTS rf nv
[5] Read gsm rf nv
[6] Write gsm rf nv
[7] Band Base
[8] Audio  
 
 Now start pushing the down arrow( you will see the options change each time) until the menu looks like this:
 
[1] Batt.Temp
[2] FTM NV read
[3] FTM NV set
[4] FTM NV unset
[5] Version Info
[6] USB Configuration
[7] DIAG Configuration
[8] Power on info
 
Push 6 for USB Configuration.
 
You will see:
 
[1] Samsung USB [*]
[2] Qualcomm USB []
[3] PictBridge USB []
 
Push 2 for Qualcomm USB.  It will say "Qualcomm USB Configured.  Plz Reconnect the Cable.0"  Push confirm to exit.  If you want to change it back to the Samsung USB, just follow the same steps as before.  I have just left mine as the qualcomm usb and have had no problems charging or doing anything with USB on the phone.  I haven't found any reason to put it back to Samsung USB mode yet.
 
2. Download and install the qualcomm drivers on the PC.
 
I just did a google search for "qualcomm usb driver" and found the file hosted on rapid share. Then extract the drivers to a folder on your PC.
 
Connect the phone to the PC with the USB cable, then (on the phone) choose PC Studio.  The PC should then find new hardware.  When it asks for drivers, point the new hardware wizard to the folder that you extracted the Qualcomm drivers in.  It should do this three times(a modem, a diagnostics tool, and something else), though I think the only one that is important is the Qualcomm diagnostics, but Installed all three anyway (the all use the same drivers).
 
3.  Install the BitPim software
 
Do a goolge search on BitPim.  Download it and install it on the PC. Run it.
 
If it doesn't automatically try to detect your phone, then go to Edit and select Detect Phone.
 
Click the Phone Wizard button.
 
Select your provider (mine is at&t, but you can also select sprint, then select Samsung, then select SPH-A740 (the SPH-A747 or Propel is not listed).  Then click NEXT.
 
On the Comm port screen you want the one that has "Qualcomm diagnostics interface" in the description.  Mine was COM5, yours may be different.  
 
Dont click "detect phone" it won’t work anyway.  Click FINISH.
 
In BitPIM select VIEW, and then select VIEW FILESYSTEM.  Then, in the left most column near the bottom click on FILESYSTEM.  Now in the column just to the right of that column, select the folder "/" and it will retrieve the file system of the phone.
 
Browse to the folder /Media/Games and you will see all of the apps you have installed on the phone.  each app should have a sub folder called appdb.  Select that and you should see the settings.bin file(Gmail does not have the settings.bin file, that’s another story).  Right click it and choose SAVE, then save it to your PC.  Now make a copy of the original settings.bin as a backup.
 
 
Do a google search for "free hex editor" and install one.  (I know very little about HEX editing)  Open the settings.bin file with the HEX editor and look for byte 07.  change whatever is in that byte to 40.  Then save it.
 
Go back to BitPIM.  Right click on settings.bin and select DELETE.  Then right click in the white space and select new file.  A window will appear, browse to the settings.bin file you modified with the HEX editor.
 
Unplug the phone from the PC. .  Go to the app and launch it.  When I got prompted to allow access to the data network I had the option to "Allow, and don't ask again."   SUCCESS!
 
Here is where I got my information:
http://thesynchole.com/viewtopic.php?f=3&t=3384
and
http://thesynchole.com/viewtopic.php?f=18&t=1158
 
Message Edited by dnoltensmeyer on 02-16-2009 03:10:37 PM
Message Edited by dnoltensmeyer on 02-16-2009 03:11:23 PM
Message Edited by dnoltensmeyer on 02-16-2009 03:14:38 PM
Message 15 of 15 (3,261 Views)
Share this topic
Announcements

Welcome to the AT&T Community Forums!!! Stop by the Community How-To section for tips on how to get started.