Explore & discover

Helpful Links

activate showtime anytime on apple tv?

Contributor

activate showtime anytime on apple tv?

i am a uverse iuser with showtime subscription, but cant get it.. get a code to put in but that is as far as it goes.I

seem to be having that problem with other channels as well. They all want to know what carrier i subscribe with

and when it is att uverse, i get no further? Help?  BTW, i am also a Directv Now subscriber as well.  I called and talked 

to uverse who said someone we get in touch and never did.

10,453 Views
Message 1 of 3
Administrator

Re: activate showtime anytime on apple tv?

Hello @hapster6!


Welcome to the Community Forums! Thank you so much for reaching out and joining! We know how important it is to be able to watch Showtime anytime on your Apple TV. I am more than happy to help!


May I asked if you have created an account on Showtime’s website? You can reach the site here. If you do, and are still getting this message, Please let me know and I will message you to look further into this.


Thank you!


Jackie, AT&T Community Specialist


Need help?
Ask a question to get help from the AT&T Community or support from AT&T specialists. If this reply helped you please use Accept solution to mark it as an Accepted Solution.
*I am an AT&T employee, and the postings on this site are my own and don't necessarily represent AT&T's position, strategies or opinions.
Message 2 of 3

Re: activate showtime anytime on apple tv?

Any luck with this yet?

 

I can not activate my showtime anytime on any device, specifically my Apple TV because I can’t get past an “error” every time I click on U-verse as my provider at showtimeanytime.com/activate.  It simply says “error”, on my computer.  I have cleared all data.  I have even stopped it from automatically signing me in when it detects my U-verse Service.  I click on different user and sign in myself.  Same result.  On my iPhone app, when I log in, it also says “error, not available”. I definitely have a subscription to showtime via my U300 package.  

 

Up till yesterday, NONE of my online services/channels would accept my U-verse subscription; this included HBOGO, USA, WatchESPN, etc.  After 4 phone calls and agents, who didn’t have a clue how to help me, I finally got a senior analyst, who noticed that my ID wasn’t “synced” to my account.  They synced it (a one-minute process) and everything suddenly worked... Except showtime anytime, which still doesn’t work, a day later.  This seems to be a different issue, since everything else now works.  

 

I have researched this and it seems to be a well known issue for over 5 years, except people don’t like to come back and post their solutions.  It seems that several people have gotten help by PMs with ATTcares, who no longer cares, or at least no longer accepts PMs.

 

Can anyone help? Thanks!

Message 3 of 3
Share this topic
Share this topic
Announcements
Additional Support