Ask a question
Search in U-verse Forums

U-verse Forums

Reply
Posted Oct 3, 2013
7:25:07 AM
View profile
WD My Net N900 router setup behind RG

I just picked up a WD My Net N900 router. Wanted to use some of the features including guest account, USB mounted shared drive, Time of Day filtering, etc.It also has Wireless N at 2.4 and 5 GHz. I've read through the thread on setting up Access point and Router behind Router setup. I came up with

 

Access Point:

1. Turn off DHCP on your router. (Just set AP mode on WD)

2. Change the link between the 2Wire router and your router to use the LAN ports on both ends.  (In other words, plug the cable from one of the LAN ports of the 2Wire to one of the LAN ports of your router.  Leave your router's WAN port empty). (Doesn't matter on WD in AP mode)

3. Change the LAN IP address of your router to a static IP on the same subnet as the UVerse 2Wire router.  For example, if the 2Wire router is using 192.168.1.x, and the DHCP range is 192.168.1.64 - 192.168.1.253, set your router to 192.168.1.10.

4. If necessary, configure the wireless parameters on your router, such as SSID, encryption, pre-shared key, and MAC filtering.

 

 

The problem is that it looks like I can't use some of the features as an access point (USB drives, filtering, guest accounts). So, I guess I would have to do a router behind router config which can get a lot more complicated quickly.

 

The instructions for router behind router are as follows...

 

1. Set your router's WAN interface to get an IP address via DHCP.  This is required at first so that the 2Wire recognizes your router.

2. Plug your router's WAN interface to one of the 2Wire's LAN interfaces.

3. Restart your router, let it get an IP address via DHCP.

4. Log into the 2Wire router's interface.  Go to Settings -> Firewall -> Applications, Pinholes, and DMZ

5. Select your router under section (1).

6. Click the DMZPlus button under section (2).

7. Click the Save button.

8. Restart your router, when it gets an address via DHCP again, it will be the public outside IP address.  At this point, you can leave your router in DHCP mode (make sure the firewall on your router allows the DHCP renewal packets, which will occur every 10 minutes), or you can change your router's IP address assignment on the WAN interface to static, and use the same settings it received via DHCP.

9. On the 2Wire router, go to Settings -> Firewall -> Advanced Configuration

10. Uncheck the following: Stealth Mode, Block Ping, Strict UDP Session Control.

11. Check everything under Outbound Protocol Control except NetBIOS.

12. Uncheck NetBIOS under Inbound Protocol Control.

13. Uncheck all the Attack Detection checkboxes (7 of them).

14. Click Save.

 

 

I checked with the WD forum and got the following instructions:


 

N900 options are pretty limited when using in access point mode.  I'm currently using it as an AP too.  No guest network, parental controls. Setting up this router as AP is extremely simple in comparison with other routers.  Once you toggle the device mode to AP mode in advanced settings, you will see a bunch of menus go away.  No need to turn off DHCP, its taken care.  Just make sure to assign a static IP to the router to access its admin page in future.  In AP mode, the wan port also becomes a switch.

 

I'm not a uverse user so can't give you any suggestions regarding your setup.  But if you are trying to use router behind router configuration, try to setup static IP on your N900 for the WAN interface and setup a static route in your main router for the subnet you are using in the N900's LAN interface.  That will make both your subnets talk to each other.

 

For e.g.:

Main Router:

WAN IP Address = Assigned by DHCP from service provider

LAN IP Address = 192.168.1.1  /  subnet = 192.168.1.* / 255.255.255.0

 

Static Route Configuration in Main Router:

Destination Subnet: 192.168.2.* / 255.255.255.0    Gateway = 192.168.1.100

 

N900:

WAN IP Address = 192.168.1.100

Default Gateway = 192.168.1.1

LAN IP Address = 192.168.2.1   /   subnet = 192.168.2.* / 255.255.255.0

 

There may be some difficulties in getting NetBIOS and others working across both subnets but addressing it via IP addresses instead of machine names/domain would solve it.


Does this seem like a viable option? Is this any better than the other router behind router config? Is it even possible to add a static route to the Uverse box? Any other potential problems?

 

Thanks,

Dennis_H

 

I just picked up a WD My Net N900 router. Wanted to use some of the features including guest account, USB mounted shared drive, Time of Day filtering, etc.It also has Wireless N at 2.4 and 5 GHz. I've read through the thread on setting up Access point and Router behind Router setup. I came up with

 

Access Point:

1. Turn off DHCP on your router. (Just set AP mode on WD)

2. Change the link between the 2Wire router and your router to use the LAN ports on both ends.  (In other words, plug the cable from one of the LAN ports of the 2Wire to one of the LAN ports of your router.  Leave your router's WAN port empty). (Doesn't matter on WD in AP mode)

3. Change the LAN IP address of your router to a static IP on the same subnet as the UVerse 2Wire router.  For example, if the 2Wire router is using 192.168.1.x, and the DHCP range is 192.168.1.64 - 192.168.1.253, set your router to 192.168.1.10.

4. If necessary, configure the wireless parameters on your router, such as SSID, encryption, pre-shared key, and MAC filtering.

 

 

The problem is that it looks like I can't use some of the features as an access point (USB drives, filtering, guest accounts). So, I guess I would have to do a router behind router config which can get a lot more complicated quickly.

 

The instructions for router behind router are as follows...

 

1. Set your router's WAN interface to get an IP address via DHCP.  This is required at first so that the 2Wire recognizes your router.

2. Plug your router's WAN interface to one of the 2Wire's LAN interfaces.

3. Restart your router, let it get an IP address via DHCP.

4. Log into the 2Wire router's interface.  Go to Settings -> Firewall -> Applications, Pinholes, and DMZ

5. Select your router under section (1).

6. Click the DMZPlus button under section (2).

7. Click the Save button.

8. Restart your router, when it gets an address via DHCP again, it will be the public outside IP address.  At this point, you can leave your router in DHCP mode (make sure the firewall on your router allows the DHCP renewal packets, which will occur every 10 minutes), or you can change your router's IP address assignment on the WAN interface to static, and use the same settings it received via DHCP.

9. On the 2Wire router, go to Settings -> Firewall -> Advanced Configuration

10. Uncheck the following: Stealth Mode, Block Ping, Strict UDP Session Control.

11. Check everything under Outbound Protocol Control except NetBIOS.

12. Uncheck NetBIOS under Inbound Protocol Control.

13. Uncheck all the Attack Detection checkboxes (7 of them).

14. Click Save.

 

 

I checked with the WD forum and got the following instructions:


 

N900 options are pretty limited when using in access point mode.  I'm currently using it as an AP too.  No guest network, parental controls. Setting up this router as AP is extremely simple in comparison with other routers.  Once you toggle the device mode to AP mode in advanced settings, you will see a bunch of menus go away.  No need to turn off DHCP, its taken care.  Just make sure to assign a static IP to the router to access its admin page in future.  In AP mode, the wan port also becomes a switch.

 

I'm not a uverse user so can't give you any suggestions regarding your setup.  But if you are trying to use router behind router configuration, try to setup static IP on your N900 for the WAN interface and setup a static route in your main router for the subnet you are using in the N900's LAN interface.  That will make both your subnets talk to each other.

 

For e.g.:

Main Router:

WAN IP Address = Assigned by DHCP from service provider

LAN IP Address = 192.168.1.1  /  subnet = 192.168.1.* / 255.255.255.0

 

Static Route Configuration in Main Router:

Destination Subnet: 192.168.2.* / 255.255.255.0    Gateway = 192.168.1.100

 

N900:

WAN IP Address = 192.168.1.100

Default Gateway = 192.168.1.1

LAN IP Address = 192.168.2.1   /   subnet = 192.168.2.* / 255.255.255.0

 

There may be some difficulties in getting NetBIOS and others working across both subnets but addressing it via IP addresses instead of machine names/domain would solve it.


Does this seem like a viable option? Is this any better than the other router behind router config? Is it even possible to add a static route to the Uverse box? Any other potential problems?

 

Thanks,

Dennis_H

 

WD My Net N900 router setup behind RG

2,322 views
7 replies
(0) Me too
(0) Me too
Reply
View all replies
(7)
0
(0)
  • Rate this reply
View profile
Oct 4, 2013 11:33:57 AM
0
(0)
Community Support

Hello Dennis_H,

 

I have not had a chance to play with the WD My Net N900, but it appears to be your standard residential router with some pretty nice features. I currently have a router behind router setup in my house, and I am having no issues, so I would definitely suggest going the router behind router route, so you can take full advantage of the WD My Net N900.

Regarding the part where they suggested setting up a static route, unfortunately, on the U-verse router, you are not able to set a default static route in this manner, but you should not have to do this. If you wish to create a default exit path on the WD My Net N900, I do not see any issues with that.

The one thing you definitely want to be sure of is to separate your networks so internal traffic is not routed through the U-verse router unless absolutely necessary. So my suggestion on that would be to disable the wireless on our U-verse router, and have everything connected to your WD My Net N900 so that it obtains a 192.168.2.x address. If you have U-verse TV service, connect the STBs directly to the U-verse router so they obtain an address of 192.168.1.x.

 

Hopefully, that information helps, but let us know if you have any further questions.

 

-David T

If you encounter any issues with your service or equipment, I recommend checking out our Troubleshoot & Resolve solutions to help diagnose the issue.

Hello Dennis_H,

 

I have not had a chance to play with the WD My Net N900, but it appears to be your standard residential router with some pretty nice features. I currently have a router behind router setup in my house, and I am having no issues, so I would definitely suggest going the router behind router route, so you can take full advantage of the WD My Net N900.

Regarding the part where they suggested setting up a static route, unfortunately, on the U-verse router, you are not able to set a default static route in this manner, but you should not have to do this. If you wish to create a default exit path on the WD My Net N900, I do not see any issues with that.

The one thing you definitely want to be sure of is to separate your networks so internal traffic is not routed through the U-verse router unless absolutely necessary. So my suggestion on that would be to disable the wireless on our U-verse router, and have everything connected to your WD My Net N900 so that it obtains a 192.168.2.x address. If you have U-verse TV service, connect the STBs directly to the U-verse router so they obtain an address of 192.168.1.x.

 

Hopefully, that information helps, but let us know if you have any further questions.

 

-David T

If you encounter any issues with your service or equipment, I recommend checking out our Troubleshoot & Resolve solutions to help diagnose the issue.
I am an AT&T employee and the postings on this site are my own and don’t necessarily represent AT&T’s position, strategies or opinions.
*I am an AT&T employee and the postings on this site are my own and don’t necessarily represent AT&T’s position, strategies or opinions.

Re: WD My Net N900 router setup behind RG

2 of 8 (2,294 Views)
0
(0)
  • Rate this reply
View profile
Oct 4, 2013 1:47:10 PM
0
(0)
Mentor

That's kind of what I thought, but didn't know for sure about the static route table. I'll do the router behind router setup described. I have the STB/DVRs still direct connected to the RG, and then the new router behind it. I'm guessing the STBs won't be able to see the PCs with this config for media share, but that never worked correct anyway.

 

Thanks,

Dennis_H

That's kind of what I thought, but didn't know for sure about the static route table. I'll do the router behind router setup described. I have the STB/DVRs still direct connected to the RG, and then the new router behind it. I'm guessing the STBs won't be able to see the PCs with this config for media share, but that never worked correct anyway.

 

Thanks,

Dennis_H

Re: WD My Net N900 router setup behind RG

3 of 8 (2,283 Views)
Highlighted
0
(0)
  • Rate this reply
View profile
Oct 4, 2013 1:53:28 PM
0
(0)
Community Support

The media share should still work, but you are right, sometimes getting the media share to work right is an adventure in itself. Let us know how it goes!

 

-David T

Need more help?

Download the myAT&T App and click Fix It Now! Support Tools to get U-verse help. For more assistance, send a quick message to ATTU-verseCare. Be sure to include your account number, name, and contact number.

The media share should still work, but you are right, sometimes getting the media share to work right is an adventure in itself. Let us know how it goes!

 

-David T

Need more help?

Download the myAT&T App and click Fix It Now! Support Tools to get U-verse help. For more assistance, send a quick message to ATTU-verseCare. Be sure to include your account number, name, and contact number.
*I am an AT&T employee and the postings on this site are my own and don’t necessarily represent AT&T’s position, strategies or opinions.

Re: WD My Net N900 router setup behind RG

4 of 8 (2,281 Views)
0
(0)
  • Rate this reply
View profile
Jan 8, 2014 3:56:51 PM
0
(0)
Contributor

Thanks so much for this post Dennis and David.  I was able to fly through setting up my router behind router with this information.  Saved me lots of time.  

Appreciate your help!

Thanks so much for this post Dennis and David.  I was able to fly through setting up my router behind router with this information.  Saved me lots of time.  

Appreciate your help!

Re: WD My Net N900 router setup behind RG

5 of 8 (1,758 Views)
0
(0)
  • Rate this reply
View profile
Jan 9, 2014 8:28:30 AM
0
(0)
Community Support

Hi Marrissa_M,

 

Thank you for sharing your experience. I am glad this information was able to make this an easier and better experience for you.

 

-David T

If you encounter any issues with your service or equipment, I recommend checking out our Troubleshoot & Resolve solutions to help diagnose the issue.

Hi Marrissa_M,

 

Thank you for sharing your experience. I am glad this information was able to make this an easier and better experience for you.

 

-David T

If you encounter any issues with your service or equipment, I recommend checking out our Troubleshoot & Resolve solutions to help diagnose the issue.
I am an AT&T employee and the postings on this site are my own and don’t necessarily represent AT&T’s position, strategies or opinions.
*I am an AT&T employee and the postings on this site are my own and don’t necessarily represent AT&T’s position, strategies or opinions.

Re: WD My Net N900 router setup behind RG

6 of 8 (1,710 Views)
0
(0)
  • Rate this reply
View profile
Feb 2, 2014 5:39:53 PM
0
(0)
Contributor
Edited by argann on Feb 2, 2014 at 7:55:28 PM

I followed the  set a ap procedures for an access point with no luck.

range 192.168.1.1 to .25.  I set my WD to .76.   I see that address listed on the AT&T equipment as well as it being used and on.  

On the AT&T as well i listed a firewall route to allow the MAC of the AP to get pass through.  Also, set the DNS info to the router of the AT&T router.    

 

any tips?  next ia m going for the router behind the router.

 

 

***update**

just tried it in  router and router and it never even pulled an IP address from the AT&T router.  used the acutal address of the AT&T router.  Even tried the gateway listed on the AT&T router.  Been trying to get this thing to work on and off for 3 days.

 

I am starting to think the AT&T router needs to be replaced with a different model.  There are links all over about how horrible it is.

I followed the  set a ap procedures for an access point with no luck.

range 192.168.1.1 to .25.  I set my WD to .76.   I see that address listed on the AT&T equipment as well as it being used and on.  

On the AT&T as well i listed a firewall route to allow the MAC of the AP to get pass through.  Also, set the DNS info to the router of the AT&T router.    

 

any tips?  next ia m going for the router behind the router.

 

 

***update**

just tried it in  router and router and it never even pulled an IP address from the AT&T router.  used the acutal address of the AT&T router.  Even tried the gateway listed on the AT&T router.  Been trying to get this thing to work on and off for 3 days.

 

I am starting to think the AT&T router needs to be replaced with a different model.  There are links all over about how horrible it is.

Re: WD My Net N900 router setup behind RG

[ Edited ]
7 of 8 (1,472 Views)
0
(0)
  • Rate this reply
View profile
Feb 3, 2014 11:54:50 AM
0
(0)
Community Support

Hi argann,

 

I am so sorry about the issues you are having with setting up your router behind our router. One thing worth trying is to connect a computer with the same connection you are using to connect your router. If it gets assigned an IP address and can browse, check to make sure your router is setup to obtain an IP address automatically on our router. If still having issues, you may need to do a factory reset on our router.

 

-David T

If you encounter any issues with your service or equipment, I recommend checking out our Troubleshoot & Resolve solutions to help diagnose the issue.

Hi argann,

 

I am so sorry about the issues you are having with setting up your router behind our router. One thing worth trying is to connect a computer with the same connection you are using to connect your router. If it gets assigned an IP address and can browse, check to make sure your router is setup to obtain an IP address automatically on our router. If still having issues, you may need to do a factory reset on our router.

 

-David T

If you encounter any issues with your service or equipment, I recommend checking out our Troubleshoot & Resolve solutions to help diagnose the issue.
I am an AT&T employee and the postings on this site are my own and don’t necessarily represent AT&T’s position, strategies or opinions.
*I am an AT&T employee and the postings on this site are my own and don’t necessarily represent AT&T’s position, strategies or opinions.

Re: WD My Net N900 router setup behind RG

8 of 8 (1,455 Views)
Share this post
Share this post