Uverse Internet Router Returned yet was Charged / Billed

Highlighted
Contributor

Uverse Internet Router Returned yet was Charged / Billed

[ Edited ]

May 22nd my uverse internet went out.  Called in and the offshore representative told me that my router was broken, so he was going to send me a new one.  It would be a free replacement, but only if I returned the other router within 21 days.  I asked him when the 21 days would start and he informed me that It would be on the day that I received the item.  

May 26th (Labor Day) Internet miraculously started working again!  But.. It was working on the old "broken" router.

May 27th I received a "new" router from AT&T, but when I opened the box to get the shipping label, I immediately noticed I had received a refurbished model.  Due to the scuffs, dents, and scratches.  Called in to see if I could return the "new" dented router and was told I could since internet was working.

May 27th (midnight) Internet went out again.  Tried plugging in the "new" dented router to see if internet would work, but it did not.  So it wasn't even the router that was broken but I was sent another one.  

May 27th (midnight) I called in, and I guess there were line issues with in my neighborhood.  So the representative scheduled a tech to visit me tomorrow.  

May 28th Tech didn't arrive.  Received automated call and was rescheduled for May 29th.

May 29th Tech arrived, and problem resolved!  It wasn't the router that was broke, just some information was off in my profile, which cause internet to not work said Tech Guy.  In the earlier days when my internet went out, he said there was a cut line somewhere nearby by construction.

May 30th Return router via USPS.  Asked for receipt.

June 5th Received email that my new bill is $152.59.  I was being charged already for the router.  Why.


I was told by all of those representatives that I had 21 days to return the item before I would be billed.  I asked every one of them to make sure.  Worst part is that the router was misdiagnosed, and I was sent a second router for no reason.

Message 1 of 2 (384 Views)
Community Manager

Re: Uverse Internet Router Returned yet was Charged / Billed

Hello @thephamle 

 

Thanks for posting.

 

I'm sorry for the issue with your billing and all the frustration it's caused you. If you still need help, our team will be happy to assist! Please send us a private message by clicking here with your full name, phone number, account number and the best time you can be reached.

 

Thank you,

Dmitriy


Rethink Possible


Did a post have a solution that worked for you? Help other people find solutions faster by marking posts that helped you as an "Accepted Solution". Learn about accepted solutions: Learn More.

Employee Contributor*
*I am an AT&T employee and the postings on this site are my own and don't necessarily represent AT&T's position, strategies or opinions.
Message 2 of 2 (195 Views)
Share this topic
Announcements

Welcome to the AT&T TV Hub!
We have some helpful articles located under TV Hot Topics.
On the left you will see DIRECTV and U-verse TV links. Click on those links for more information regarding Apps, Billing, and TV troubleshooting tips.

Additional Support