Certificate verification errors with smtps

Contributor

Certificate verification errors with smtps

I am trying to send outbound emails using smtp.att.yahoo.com.  Occasionally, I see emails go through successfully, but most of the time, I get SSL certificate verification errors.

 

On a Linux box, I used "openssl s_client -connect smtp.att.yahoo.com:465" to take a look at the certificate, and I see just one certificate, which fails verifcation because it is not a trusted issuer.  That certifcate is:

  1: Subject: smtp.att.yahoo.com,  Issuer: DigiCert High Assurance CA-3

 

When it goes through successfully, my logs show that there were 2 certificates in a chain:

  1: Subject: smtp.att.yahoo.com,  Issuer: DigiCert High Assurance CA-3

  2: Subject: DigiCert High Assurance CA-3,  Issuer: DigiCert High Assurance EV Root CA

 

This verifies successfully because the second certificate is a trusted root certificate.

 

It seems to me that AT&T/Yahoo has a cluster of SMTP servers, and most of them are sending incomplete certificate information.  But occasionally I connect to a cluster member that is configured correctly and my email goes through.

 

This has been going on for quite a while now.  But recently, it got a lot worse, and my emails have been sitting in my outbox for 3 days!  Perhaps the correctly configured cluster member went offline and so now there are no good SMTP server left???  Please help me get this resolved, so that all SMTP servers have correct certificate information.

759 Views
Message 1 of 4
Highlighted
ACE - Master

Re: Certificate verification errors with smtps

I would recommend that you send a Private Message to the ATTU-verseCare Community Specialist team.  One of the specialists will respond to your PM shortly.  Please look for the flashing envelope at the top right of the page for your response from a team member.

 

Reference your post and they should be able to assist you.  You can copy and paste this: http://forums.att.com/t5/Features-and-How-To/Certificate-verification-errors-with-smtps/m-p/3645781

 

 

"If you find this post helpful and it solved your issue please mark it as a solution.  This will help other forum members locate it and will also let everyone know that it corrected your problem. If they have the same issue they will know how to solve theirs"

*The views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.
Message 2 of 4
Community Support

Re: Certificate verification errors with smtps

Hello heathens17715,

 

We have received your message and look forward to working with you on this issue to get it resolved.

 


Need more help? Feel free to search the AT&T Community for great answers. You can also get immediate troubleshooting steps from the myAT&T app. Simply login, scroll and click Fix it Now! Support Tools. You can also reach out to our Chat Support 24/7.

Employee Contributor*
*I am an AT&T employee and the postings on this site are my own and don't necessarily represent AT&T's position, strategies or opinions.
Message 3 of 4
Contributor

Re: Certificate verification errors with smtps

Thanks for the pointer.  The Private Message worked and the response was quick and to the point.

 

The solution was embarrassingly simple: switch to the new SMTP address (outbound.att.net).  This new address implements SSL certificates correctly and my emails are going through quicker than ever before.

Message 4 of 4
You must type a description before you click preview or reply.
Share this topic
Announcements

Welcome to the AT&T TV Hub!
We have some helpful articles located under TV Hot Topics.
On the left you will see DIRECTV and U-verse TV links. Click on those links for more information regarding Apps, Billing, and TV troubleshooting tips.

Additional Support