Helpful Links

Auto pay doesn't work consistently

Contributor

Auto pay doesn't work consistently

For the past two months, the auto pay process can not charge by credit card, but when I click then pay now (or whatever it's called button), my credit card is charged just fine.  Same number, no changes to my profile or card information. Simplely put: auto pay doesn't work while manual pay does work.  This has happened periodically with AT&T and it's just getting tedious.  Can anyone explain why this is happening?  (Note: This is really for billing of an analog phone billing but there's no forum for that).

617 Views
Message 1 of 2
Community Support

Re: Auto pay doesn't work consistently

Hello @ClayTex , welcome to the Community!  I'm sorry to hear you're having trouble with your autopay.  We can try to help. Send us a private message by clicking here. Include your full name, account number, contact information and the best time you can be reached. We have a team of amazing managers and they will be in touch within 2 business days to assist.

Did a post have a solution that worked for you? Help other people find solutions faster by marking posts that helped you as an "Accepted Solution". Learn about accepted solutions here.

Employee Contributor*
*I am an AT&T employee and the postings on this site are my own and don't necessarily represent AT&T's position, strategies or opinions.
Message 2 of 2
Share this topic
Announcements

Welcome to the AT&T TV Hub!
We have some helpful articles located under TV Hot Topics.
On the left you will see DIRECTV and U-verse TV links. Click on those links for more information regarding Apps, Billing, and TV troubleshooting tips.

Additional Support