Windows Home Server (WHS) with U-verse

Contributor

Windows Home Server (WHS) with U-verse

Has anyone had a succeful installation of WHS with U-verse 2Wire 3800HGV-B (RG).  My WHS worked great until my new service was installed.  The main WHS set up problem is that since the wireless router (2Wire 3800HGV-B) does not support UPnP,  and because I receceived the following messages:
                                                        Unable to verify that router is accepting Web site connections
                                                        Unable to verify that router is accepting Remote Access connectiond
                                                        Verifty forwarding port.
                                                          
 
 
 Microsoft recommended the following:
 

You may need to add services from your broadband provider to use the Remote Access features in Windows Home Server. For example, you need certain TCP “ports” to be open to use these features. Some broadband providers block certain ports for customers on some service plans. Also, some broadband providers’ terms of service may limit or prohibit setting up and running “servers” on their networks by some customers on some service plans. Ensure that your use of Windows Home Server features follows your broadband providers’ terms of service. Please contact your broadband provider if you have questions about their terms of service.

The following TCP ports need to be forwarded from your router to Windows Home Server to enable the Remote Access features in Windows Home Server:

Service or Protocol Port

HTTP

TCP 80

HTTPS

TCP 443

Remote Desktop Proxy

TCP 4125

  • HTTP is the protocol that your Web browser uses to view Web pages. You use this protocol to view your default Web page for Windows Home Server.

  • HTTPS is the protocol that your Web browser uses to view secure Web pages. You use this protocol to view your Remote Access Web page for Windows Home Server.

  • Remote Desktop Proxy is the service that is used to connect to your home computers via the Remote Access

       CAN I MAKE THESE CHANGES TO THE WIRELESS ROUTER??????

       Also has anyone used the Router behind Router setup!!!!!!!

 

      Thanks

      

Message 1 of 13 (2,219 Views)
Professor

Re: Windows Home Server (WHS) with U-verse

I will get working on a tutorial for you and have it posted later tonight.  I have to leave for a class here soon and won't be back until about 9:15PM CST.
Message 2 of 13 (2,219 Views)
Professor

Re: Windows Home Server (WHS) with U-verse - Tutorial

For the first step we are going to add the Remote Desktop Proxy protocol to your firewall rules.  All you have to do for this step is click on the following link and enter your password when prompted to do so then hit the Back button on the following screen and stay on it for the next step:
http://192.168.1.254/xslt?PAGE=E04_POST_ADD&APP=Remote%20Desktop%20Proxy&PROTO=TCP&SPORT=4125&EPORT=...

Now what we need to do is forward the ports to your WHS box.

From the page that you should be on from the last step (http://192.168.1.254/xslt?PAGE=E02 in case you aren't) select your WHS box from the pull-down menu in step 1: Select a Computer.

Then what you will need to do is find Remote Desktop Proxy on the left side of step 2 and click on add.  Each time you click add it will reload the page.  Do the same for HTTPS Server and Web Server (ports 443 and 80 respectively).

Now all of your ports should be forwarded and working fine.


Message Edited by Koolkid1935 on 03-26-2008 10:27 PM
Message 3 of 13 (2,219 Views)
Tutor

Re: Windows Home Server (WHS) with U-verse

Sorry but I can not get the server configured what am i missing afterwords
 
Thanks for your input
Message 4 of 13 (2,219 Views)
Tutor

Re: Windows Home Server (WHS) with U-verse

Any Help Please Cant get it to configure
Message 5 of 13 (2,219 Views)
Professor

Re: Windows Home Server (WHS) with U-verse

Personally I don't have WHS so I can only help with anything from the RG up to the WHS box, from that point I have no idea (unless it is something generic to Windows itself).
Message 6 of 13 (2,219 Views)
Contributor

Re: Windows Home Server (WHS) with U-verse

After quite a bit of kicking my server with my steel towed boots i decided to do some trouble shooting to this very issue.

 

In the end... the issue is the 3800HGV-B gateway itself.

 

I proved this by unpluging it's ethernet input and pluging the cable into a different router (DLINK DI-524). I then cloned the MAC address from the 3800HGV-B gateway  to the DI-524 and magically i had an internet connection!

I then went into my WHS console and REMOTE ACCESS now works!

i tried other methids such as plugging the server into the DI-524 then the DI-524 into the 3800HGV-B and selecting the DMZ for the DI-524 on the 3800HGV-B and no luck. I also tried to put a switch (Linksys EZXS55W v2.0) in line to split the input Cable to the 3800 and 524 with  no luck (don't clone the mac in this situation as neither units will work!.

 

at this point my only solution may be to get att to authorize the mac address from my DI-524 and then place the switch in line.

 

Message 7 of 13 (2,219 Views)
Teacher

Re: Windows Home Server (WHS) with U-verse

Well - I guess I'm the only one on the block! 

Here's what we're up against:

2Wire states that their RG is rock solid (nope)

ATT states their limit of responsiblity is to provide internet access (nothing more)

You need to follow the simple steps to get this to work as DHCP is the kicker here.

 

Basically, you're going to put your entire home LAN into a DMZ - and open up the RG by using that function.  This is known as cascading routers - but make sure you're not using the WARNING setting on the RG that will kluge this up.

 

Here's what I did - and mine's working... 

 

1) Unplug EVERYTHING from your network

2) Unplug the power from the 2wire and disconnect all the ethernet ports EXCEPT the TV Boxes (you'll lose TV in power-off states)

3) Plug a single computer workstation into the RG, fire it up and login to the RG

4) Plug the cable DSL router into the RG (nothing else plugged into the LAN side of the router!)

5) Turn off stealth mode in the firewall settings

6) Go to the RG ip address in your browser with the /MDC option (IP address/mdc)

7) Under Resets, CLEAR the home lan information

8) Unplug the power from the RG and wait 30 seconds before powering up

9) Login to the RG and go to the firewall settings

10) Put the CABLE/DSL Modem Router Into DMZ mode by selecting that IP address from the list of Home Network Devices

11) Unplug your PC from the RG and plug it into a port on the cable/dsl router.  This PC should be the ONLY PC connected to the router

12) Configure the cable/dsl router - DHCP on the WAN side, ENABLE DHCP on the LAN side

13) If you have a switch, plug all your LAN devices into the switch BUT DO NOT CONNECT to your router

14) Set up the rules for the WHS in your firewall's port forwarding settings and make sure you're using a static IP address on your WHS (I use the router's static mapping function in DHCP on the router)

15) After saving and rebooting on the router, confirm your IP address on your home lan workstation (should be from the DHCP pool on the router, not the RG)

16) Log back into the RG from your web browser, again, go to the /MDC option and check the firewall exceptions

17) Plug your computer into your switch, and plug your switch into your cable/DSL router

18) Go to the WHS console and run the remote admin setup and you should be up and running

 

Message 8 of 13 (2,219 Views)
Scholar

Re: Windows Home Server (WHS) with U-verse

 Thats a lot of work for something that should have been automatic.  My experience with 2wires is that they are very dependable but not very feature packed.
Message 9 of 13 (2,219 Views)
Contributor

Re: Windows Home Server (WHS) with U-verse - Tutorial


Koolkid1935 wrote:
For the first step we are going to add the Remote Desktop Proxy protocol to your firewall rules.  All you have to do for this step is click on the following link and enter your password when prompted to do so then hit the Back button on the following screen and stay on it for the next step:
http://192.168.1.254/xslt?PAGE=E04_POST_ADD&APP=Remote%20Desktop%20Proxy&PROTO=TCP&SPORT=4125&EPORT=...

Now what we need to do is forward the ports to your WHS box.

From the page that you should be on from the last step (http://192.168.1.254/xslt?PAGE=E02 in case you aren't) select your WHS box from the pull-down menu in step 1: Select a Computer.

Then what you will need to do is find Remote Desktop Proxy on the left side of step 2 and click on add.  Each time you click add it will reload the page.  Do the same for HTTPS Server and Web Server (ports 443 and 80 respectively).

Now all of your ports should be forwarded and working fine.


Message Edited by Koolkid1935 on 03-26-2008 10:27 PM

This solution workd great for me.  Thanks!

 


D

Message 10 of 13 (2,219 Views)
Contributor

Re: Windows Home Server (WHS) with U-verse - Tutorial

This worked for me as well.  Implementing your solution only took 2 minutes.

 

Thanks for sharing with the rest of us!

 

-Joseph

Message 11 of 13 (1,367 Views)

Re: Windows Home Server (WHS) with U-verse - Tutorial

Josepharmour -

 

Can you please help me?

 

I am trying to configure the AT&T RG router to port forward to my Windows Home Server.  The links that Koolkid1935 gave in his posts no longer work.

 

I am including screenshots of the RG firewall setup screen.  The microsoft WHS documentation says the ports should point toward the WHS IP which is 192.168.1.111 but it looks like the ports are pointing to a public IP 99.68.54.244 which I don't know if this is correct.

 

On one of the screenshots, please notice I don't have the DMZ radio button checked.

 

I would really appreciate any help you can give me.  Thanks.

 

Bill Artman - Kansas City

 

2170i7D520F8897D6770E2172i626C393146DC0FA8

Message 12 of 13 (1,367 Views)
Contributor

Re: Windows Home Server (WHS) with U-verse - Tutorial

I just followed these directions and they appear to have worked.  I was able to log in via the remote access url for my home server.  My Firewall status page looks just like your screenshot except with a different server name and Public IP (understandable) and mine says "Web Server" instead of HTTP (but is still port 80).  Sorry I don't have any advice to offer! 

Message 13 of 13 (1,367 Views)
Share this topic
Announcements

Welcome to the AT&T Community Forums!!! Stop by the Community How-To section for tips on how to get started.