Slingbox / "Aspect Ratio" Problem

Teacher

Slingbox / "Aspect Ratio" Problem

[ Edited ]

I have a STB connected using "HDMI to my TV" and "Component to my Slingbox".  With my TV powered off, I connected to my Slingbox and set the "Aspect ratio" on the STB to either:

 

  • 720p on high-definition screens
  • 1080i on high-definition screens

The blue HD light on the STB comes on and stays on.  And the signal to my Slingbox stays 720p or 1080i, even when I turn the STB on or off or disconnect and reconnect to my Slingbox.

 

Now when I turn my TV on, everything is still OK and it continues to output 720p or 1080i on both connections (TV and Slingbox), but when I turn my TV off, it communicates to the STB over the HDMI cable and the STB switches the "Aspect ratio" to:

 

  • 4:3 standard definition

So now when I connect to my Slingbox (with the TV powered off), the blue HD light on the STB is off and I get a 480i signal from the Component connection.  I have to go into the STB menus and set the "Aspect ratio" back to 720p or 1080i.

 

It's a pain in the butt to keep having to change the "Aspect ratio" of the STB back to 720p or 1080i almost every time I connect to my Slingbox.

 

Does anyone know a way of blocking the two-way communication that's happening over the HDMI connection?  I don't want the TV sending a signal to the STB everytime I turn my TV off and switching all the STB connections back to 480i.  I want the blue HD light on the STB to remain lit at all times.

Message 1 of 6 (1,926 Views)
Expert

Re: Slingbox / "Aspect Ratio" Problem

Look on your TV for a setting that will disable the HDMI communication protocol (called Consumer Electronics Control, or CEC).  Different manufacturers have different names for CEC:

 

Samsung - AnyNet

Sharp - AquosLink

Sony - BraviaSync

Hitachi - HDMI-CEC

Pioneer - KuroLink

Toshiba - RegzaLink or CE-Link

Onkyo - RIHD

LG - SimpLink

Panasonic - VieraLink, HDAVI Control, and EZ-Sync

Philips - EasyLink

Mitsubishi - NetCommand

 

 

Message 2 of 6 (1,870 Views)
Scholar

Re: Slingbox / "Aspect Ratio" Problem

[ Edited ]

EDIT: WOOPS NEVER MIND I THOUGHT THE OP'S PROB WAS DIFFERENT TIL I RE-READ

 

Message 3 of 6 (1,827 Views)
Highlighted
Teacher

Re: Slingbox / "Aspect Ratio" Problem

[ Edited ]

Thanks for the response SomeJoe7777.  I looked at the settings on my Sony TV (model KDL-32M4000) and couldn't find anything concerning "BraviaSync".  But in the Setup of the TV, I did find the setting "Control for HDMI".  The description for the setting reads "Allows the TV to control compatible HDMI devices".

 

I tested with "Control for HDMI" set to "On" and "Off", but it doesn't change the problem I'm having.  When I turn my TV off, the STB switches to 480i and the blue HD light goes out.  So my Slingbox (Component connection) is no longer HD or widescreen until I either turn the TV back on or go into the STB menus and change the "Aspect Ratio" back to "1080i on high-definition screens".

 

Does anyone else know a way to stop the two-way communication happening over the HDMI cable?

Message 4 of 6 (1,793 Views)
Expert

Re: Slingbox / "Aspect Ratio" Problem

You might want to try using component to both the Slingbox and the TV then, and remove the HDMI cable.

 

All you would need for this is to use 3 of these adapters from Monoprice.com, and the appropriate component cables.

 

Because U-Verse HD video does not contain any 1080p content, and is not a pristine source like Blu-Ray, you will not notice any difference in picture quality between HDMI and component.

 

Message 5 of 6 (1,782 Views)
Teacher

Re: Slingbox / "Aspect Ratio" Problem

Thanks for the suggestions!  Unfortunately, my TV is on a wall mount and component cables wouldn't work very well.  The HDMI cable goes through the wall and looks much nicer on the back of the TV.

 

I was hoping for an adapter or something that would just block the two-way communication, but allow audio and video from the STB to the TV.  Or a way to fix the STB so it doesn't always switch everything to 480i when you power off the TV.

 

Again, thanks for the suggestions!

Message 6 of 6 (1,758 Views)
Share this topic
Announcements

Welcome to the AT&T Community Forums!!! Stop by the Community How-To section for tips on how to get started.