New DHCP Problems

Teacher

New DHCP Problems

Hello all -- I've seen a few other DHCP discussions around but figured I'd post this separately.

 

For the last few days I've suddenly had a series of weird DHCP related issues. For over a year everything has worked absolutely flawlessly, but now it seems that for only specific devices, once a DHCP lease expires it won't get renewed.

 

What does work: Windows 7 laptop and Nintendo Wii

What doesn't work: Xbox 360, Blackberry, iPod Touch, Airport Express (which is just joined to my existing wireless network for iTunes speakers sake only, not set up as anything else).

 

If I reboot the RG everything gets a new IP. But the next day, presumably when the DHCP lease expires, the above devices lose connectivity.

 

I changed my iPod to a static IP and it immediately worked fine, so it would definitely seem to be a DHCP issue.

 

Wondering if this is related to the recent upgrade because I've seen similar issues on other posts (e.g. windows getting lease renewals, ubuntu not).

 

Also wondering -- is there a way to change the DHCP lease time to be unlimited instead of 24 hours? Not sure if setting it to "0" will make it unlimited or not.

 

Thanks for any input.

 

Terry

Message 1 of 9 (600 Views)
Master

Re: New DHCP Problems

In system summary for the RG under home network devices and to the right of each device in blue if you click on it under

IP Address Allocation does it state DHCP.

Message 2 of 9 (600 Views)
Teacher

Re: New DHCP Problems

Well, I can't answer that now because I redefined the DHCP range to restrict it from .100 to .200, then assigned static addresses above the DHCP range to the devices that didn't appear to be renewing correctly. So far all those devices are working again.

 

Is there a place in the logs that shows the date/time that updates were made to the RG? Because this really only started in the last week, all DHCP was working fine before that time.

Message 3 of 9 (600 Views)
Teacher

Re: New DHCP Problems

Did you get this working? I am having all kinds of trouble with dhcp at my parents house for my blackberry and laptop which are both on wireless.  Rebooting does fine till about a day then it cuts off again.

 

Funny thing is I ALSO have uverse at my home and have no issues whatsoever for almost 3 years.

 

Anyone have an answer to this one?

Message 4 of 9 (600 Views)
Teacher

Re: New DHCP Problems

Not really.

 

What I did was restrict the range of DHCP addresses available, leaving anything > .200 out of the DHCP pool, then gave all the devices I had that were not working (blackberry, airport express, xbox 360) a static IP > .200 and they all work fine.

 

So I bypassed what appears to be a problem with this firmware around DHCP lease renewals by taking DHCP out of the picture for the devices where it was happening. Not sure if it's been fixed yet or not, unfortunately.

Message 5 of 9 (600 Views)
Scholar

Re: New DHCP Problems

I had this same problem, except I wasn't able to get an IP address assigned to any of my devices except the set top boxes and those took a good hour to recover from a RG reboot.

 

This problem had been going on since late April and was still going on in late May and by then I had statically assigned addresses to all non-STBs attached to the RG.

 

Well, last week, I decided to check again and lo and behold it's assigned IP addresses again and I put everything back to DHCP.  I don't know what changed, but I do know that I ordered a new line for my U-Verse voice which meant someone, somewhere had to do something to activate that second line on the box, so I wonder if that was the kick in the head the RG needed

Message 6 of 9 (600 Views)
Scholar

Re: New DHCP Problems

In the case of the original poster, I would suggest to check that Airport Express unit and make certain that it is configured in "Bridge" mode, and that it is not acting as a DHCP server on your network.  Having two devices acting as DHCP servers can cause this type of problem.

 

Also, if the RG is not seemingly answering DHCP requests for clients, you might also try rebooting the RG.  I think a number of posters suggested they tried that - and it resolved the matter for some amount of time.  Here again, any number of network devices these days come with DHCP server function built in - and sometimes enabled by default - like routers (Linksys, Netgear, DLink, Buffalo, etc) but some print servers, NAS / external disk storage devices VOIP boxes from Vonage or other VOIP providers, etc., can have DHCP services running on them - which will cause trouble if you bridge those devices into your network incorrectly.

 

Message 7 of 9 (600 Views)
Teacher

Re: New DHCP Problems

No, the Airport Express is not configured as a DHCP server. And I've rebooted the RG numerous times. Yes, that works for a day or so, but next time the lease renewal comes around and one of these devices joins the network, an IP cannot be obtained.

 

This configuration has worked absolutely flawless until the end of May, suddenly all of these issues started then. I changed nothing on my end prior to the beginning of these issues.

 

Really seems to be related to the updates on the RG sent out in May.

 

 

Message 8 of 9 (600 Views)
Scholar

Re: New DHCP Problems

It could well be (and probably is) related to the new firmware.  I saw one post a couple of days ago that suggested there is a check box or option in the wireless settings for "protected wireless" mode on the new 2wire firmware.  The poster suggested NOT running the 2wire in protected mode. ** let me emphasize, I am NOTsuggesting you turn off wireless encryption (WPA or WEP)**.

 

I personally use another vendor (netgear) for my wireless, not the 2wire, so I haven't tried this suggestion.  But you might look for that and see if it is enabled on the offending 2wire RG. Often these vendor schemes for improving wireless can break or not play nice with different vendors' stuff.

Message 9 of 9 (600 Views)
Share this topic
Announcements

Welcome to the AT&T Community Forums!!! Stop by the Community How-To section for tips on how to get started.