Ask a question

    Reply
    Posted Oct 13, 2009
    5:23:02 PM
    3800HGV-B Port forwarding

    Hello everybody, first of all let me say I know this topic has been already discussed several times but still I can't figure out how to forward selected ports on this router.

    I'm pretty sure all my settings are correct, even enabling DMZ+ mode I still wouldn't be able to open ports even though in the "Firewall summary" page I get an "All" in the "Allowed applications" colum.

     

    I'm getting really frustrated, any hint?

     

    Thanks

    3800HGV-B Port forwarding

    4,021 views
    17 replies
    (0) Me too
    (0) Me too
    Post reply
    View all replies
    (17)
    0
    (0)
    • Rate this reply
    View profile
    Oct 13, 2009 10:29:47 PM
    0
    (0)
    Scholar
    Once you place the devicein dmz mode you have to restart the device that you areplacing in the dmz. The reson is the deice has to get the external ip address and the rg has to issueit to the new device.
    Message Edited by bsm2003 on 10-13-2009 10:29 PM

    Re: 3800HGV-B Port forwarding

    2 of 18 (4,021 Views)
    0
    (0)
    • Rate this reply
    View profile
    Oct 14, 2009 7:09:58 PM
    0
    (0)
    Tutor

    I know that and I can tell you I know it's alright because I can see an "All" under the allowed applications in the firewall summary; also my laptop is shown with its external ip. It must be something different: how could I know if it's the router that is actually closing all the ports or if the forwarding is set up correctly?

     

    Thanks

    Re: 3800HGV-B Port forwarding

    3 of 18 (4,021 Views)
    0
    (0)
    • Rate this reply
    View profile
    Oct 17, 2009 5:53:44 PM
    0
    (0)
    Tutor

    There are two modes that you seem to be confusing.

     

    You can set your laptop in DMZ+ mode, or you can forward individual ports to your laptop.  One or the other.

     

    If your laptop is getting an external IP, your 3800 is in DMZ+ mode and all ports are forwarded automatically.  Note that this makes your laptop essentially unprotected and directly on the internet.  Steps to get here are:

    1. Click Home Network

    2. Click Edit firewall settings on your laptop under the Local Devices section

    3. Check Allow all applications (DMZplus mode)

    4. Click Done

     

    *OR*

     

    If you would like a little more protection you can just forward individual ports to your laptop.  In this mode your laptop will get a private IP address.

    Steps to get here are:

    1. Click Home Network

    2. Click Edit firewall settings on your laptop under the Local Devices section

    3. Check Allow individual application(s)

    4. Click  Add a new user-defined application

    5. Give it a name, check TCP or UDP, and give it a port range, use the same number in both boxes for a single port, you can leave the rest blank or default.

    6. Click Add definition

    7. Keep adding definitions until you are down with that particular rule.  Note that you can define multiple rules too.

    8. Click back

    9. Check Allow individual application(s) again

    10. Select User-defined from the dropdown box.

    11. Select whatever you named your rule and click add

    12. When you are done, click done.

     

    To see what all you have forwarded, click Firewall, and then Summary.

     

    You can use DMZ+ and port forwarding simultaneously, just not to the same machine.  The only time I would recommend DMZ+ is if you are connecting another router and want it to get a public IP address.

    Message Edited by t1n0m3n on 10-17-2009 05:58 PM

    Re: 3800HGV-B Port forwarding

    4 of 18 (4,021 Views)
    0
    (0)
    • Rate this reply
    View profile
    Oct 18, 2009 1:54:50 PM
    0
    (0)
    Tutor

    No, I'm not confused, what I'm trying to say is that EVEN in DMZ+ mode I'm still not able to see ports open. I'm following both the procedures you're describing (either one or the other) and the firewall summary shows the ports I want to forward are open but they're actually not. That's what I'm trying to figure out.

    Thanks anyway

    Re: 3800HGV-B Port forwarding

    5 of 18 (4,021 Views)
    0
    (0)
    • Rate this reply
    View profile
    Oct 18, 2009 10:30:25 PM
    0
    (0)
    Tutor
    How do you know that it is not port forwarding and not just a misconfiguration on your laptop?

    Re: 3800HGV-B Port forwarding

    6 of 18 (4,021 Views)
    0
    (0)
    • Rate this reply
    View profile
    Nov 18, 2009 11:33:44 AM
    0
    (0)
    Tutor

    I have the exact same problem.  Whether using port-forwarding or DMZ mode, port 21 is not open for me.  I want to ftp externally into my network and can't for the life of me figure out how to open up port 21... I even disabeld my windows firewall and ran in DMZ mode and still no luck.. VERY FRUSTRATING, for something that seems so simple.  I've tried calling uverse support but they are useless.. they said all ports are open and to run in DMZ mode...  Did you have any luck figuring this out?

    Re: 3800HGV-B Port forwarding

    7 of 18 (4,021 Views)
    0
    (0)
    • Rate this reply
    View profile
    Nov 18, 2009 11:38:31 AM
    0
    (0)
    Scholar

    When you say "they're actually not open", how is it that you are determining that they are not actually open?

     

    I'm wondering if there's a problem with your port testing procedure.  

     

    Personally I opened a firewall port for my SlingBox device and it worked first time no problem.  I don't know what else you can do other than open the port!   

     

    Here's how I would test it if I were you.

     

    1)  Try to connect to the port from another computer in the internal network.  Be sure to use the internal network IP address, not the external one (that won't work).  If it connects, you know that the port actually is open on your server.

     

    2)  Open the port in your firewall.

     

    3)  Go to an outside network of some kind.  Make sure you are connected to that network and ONLY that network.  Try to access the port in the exact same manner as step 1, but use the external IP address instead.   

    Message Edited by MyDogHasFleas on 11-18-2009 01:40 PM

    Re: 3800HGV-B Port forwarding

    8 of 18 (4,021 Views)
    0
    (0)
    • Rate this reply
    View profile
    Nov 18, 2009 11:43:04 AM
    0
    (0)
    Tutor

    I ran online portchecking tools such as

     

    http://www.portforward.com/help/portcheck.htm

     

    and

     

    http://www.canyouseeme.org/

     

    Either way, when I put port 21 in, give error message that port is closed.

     

    Are you running in DMZ mode with your slingbox or are you doing port-forwarding?

     

    Re: 3800HGV-B Port forwarding

    9 of 18 (4,021 Views)
    0
    (0)
    • Rate this reply
    View profile
    Nov 18, 2009 11:44:58 AM
    0
    (0)
    Scholar

    Just port forwarding with the slingbox.

     

    Seriously... port forwarding works.  It's not like it's going to fail on a simple case like yours.  There's something else going on.  

     

    Maybe try my test procedure I gave in response to the other guy?  Maybe try a different port number just for experiment?   

    Re: 3800HGV-B Port forwarding

    10 of 18 (4,021 Views)
    0
    (0)
    • Rate this reply
    View profile
    Nov 18, 2009 11:49:26 AM
    0
    (0)
    Tutor

    I've tried different ports, all are closed.  I've pinged uverse support and all they say is that all ports are open.

     

    1)  Try to connect to the port from another computer in the internal network.  Be sure to use the internal network IP address, not the external one (that won't work).  If it connects, you know that the port actually is open on your server.

     

    >> How do I test this?  Go to another computer and try to ftp to the computer's internal ip?  Or should I just try to ping the computer in question on another computer in the network?

     

     

     

    Re: 3800HGV-B Port forwarding

    11 of 18 (3,140 Views)
    0
    (0)
    • Rate this reply
    View profile
    Nov 18, 2009 6:46:04 PM
    0
    (0)
    Scholar

    Khua911 wrote:

    I've tried different ports, all are closed.  I've pinged uverse support and all they say is that all ports are open.

     

    1)  Try to connect to the port from another computer in the internal network.  Be sure to use the internal network IP address, not the external one (that won't work).  If it connects, you know that the port actually is open on your server.

     

    >> How do I test this?  Go to another computer and try to ftp to the computer's internal ip?  Or should I just try to ping the computer in question on another computer in the network?

     

    Yes, FTP to the internal address. 

     

     

     


     

    Re: 3800HGV-B Port forwarding

    12 of 18 (3,140 Views)
    0
    (0)
    • Rate this reply
    View profile
    Nov 20, 2009 7:16:29 AM
    0
    (0)
    Tutor

    I've been able to FTP to my NAS using the internal IP address.  I guess that's good news...

     

    How do I check that my port 21 is open in my Firewall? 

     

    I've set up the following:

     

    Device           Allowed Applications      Application Type                       Protocol      Port Number(s)      Public IP
    N3200PRO     FTP Server                FTP (file transfer protocol) server     TCP                  21                      99.x.xx.xx

     

     I've tried to FTP from outside my network and the request times out.. I've also added exceptions to my Windows Firewall to no avail.  I've also turned off the Windows Firewall security to no avail... Any other suggestions?

     

     

    Re: 3800HGV-B Port forwarding

    13 of 18 (3,140 Views)
    0
    (0)
    • Rate this reply
    View profile
    Nov 20, 2009 8:05:11 AM
    0
    (0)
    Scholar

    Looks like FTP is a little more complicated than just opening Port 21.  See here:

     

    http://www.mdjnet.dk/router.html

     

    or just Google search "open firewall for FTP" or the like to find other references.

     

    If I were you, I'd try this experiment:  from an outside network, issue

     

    telnet <public-ip-address> 21

     

    and see if you get connected.  If you are connected, it will prove that port 21 is actually open on the gateway, and yours is a firewall/server/client configuration issue.  If not, the port is really, truly blocked for some reason.

     

    I know that AT&T does block Port 25 (SMTP) by default.  I've never heard of them blocking Port 21. 

    Re: 3800HGV-B Port forwarding

    14 of 18 (3,140 Views)
    0
    (0)
    • Rate this reply
    View profile
    Nov 20, 2009 2:20:35 PM
    0
    (0)
    Contributor

    Similar problem, hoping for help.  Here is my setup:

     

    3800HGV-B Gateway with a Linksys WRT54-GL connected with DMZplus enabled.  (Linkysys does in fact have the external IP address).

     

    Port 3389 on the Linksys router forwarded to my specific computer on the network (192.168.2.150).

     

    I can remote desktop into this particular computer from other locations INSIDE the Linksys network, so I know that there isn't any computer software preventing the RDP connection.

     

    I cannot, however, access RDP from outside the network.  I have tried several port checking tools, all say that 3389 is closed.

     

    Does anyone have any suggestions?  Do I need to set up anything else on the 3800?  It is my understanding that with the Linksys router under DMZplus, I do not need to make any other changes on the Uverse 3800. 

     

    Thanks very much.


    CS

    Re: 3800HGV-B Port forwarding

    15 of 18 (3,140 Views)
    0
    (0)
    • Rate this reply
    View profile
    Nov 20, 2009 2:51:39 PM
    0
    (0)
    Contributor
    To make things even more confusing... I forwarded port 1723 on the Linksys router for VPN.  I went to an online port checker, and 1723 is OPEN!  3389 is still closed.  How can one port forward properly but another does not?

    Re: 3800HGV-B Port forwarding

    16 of 18 (3,140 Views)
    0
    (0)
    • Rate this reply
    View profile
    Nov 20, 2009 3:30:13 PM
    0
    (0)
    Scholar

    Go to this page on your router to confirm that you don't accidentaly have 3389 assigned to another client instead of the DMZplus device. The DMZplus device only gets ports that not already mapped by the Firewall in the RG.

     

     http://192.168.1.254/xslt?PAGE=E01&THISPAGE=A01&NEXTPAGE=E01

     

    Dave

    Re: 3800HGV-B Port forwarding

    17 of 18 (3,140 Views)
    Highlighted
    0
    (0)
    • Rate this reply
    View profile
    Nov 20, 2009 8:19:48 PM
    0
    (0)
    Contributor

    Strange...  My DMZ'd router is the only item in the custom firewall list with "All" allowed applications and (all) port numbers...  Any other thoughts?  Thanks..


    CS

    Re: 3800HGV-B Port forwarding

    18 of 18 (3,140 Views)
    Share this post
    Share this post