Ask a question

Reply
Posted Feb 21, 2013
2:05:29 PM
View profile
Using your own router with the Motorola NVG510 - it absolutely works and it's easy to do!
Edited by ATTDmitriyCM on Dec 5, 2013 at 8:10:36 AM

 

Hello.  I am writing this in an attempt to save other customers (and the AT&T staff) from many hours of work and frustration.  I was a long-time DSL customer and had always used my own router behind the DSL modem.  A simple setting on the modem turned it into a "dumb" pass-through and allowed my router to handle all the traffic as I pleased.  Changing over to U-verse required a new modem and at first, that presented a huge problem with my router.

 

What took me about 7 hours of work, online chatting with multiple agents and even finally trying paid support with AT&T (and in both cases being told it's not possible to do), I succeeded in using my own home router with the NVG510 modem under the U-verse service.  The process is fast and simple (in retrospect) and should take you about 10 minutes.

 

See below...

5
(1)
  • Rate this reply
View profile
Solved
Dec 5, 2013 8:09:02 AM
5
(1)
Teacher

You will need to adjust settings on both the NVG510 and your router.  In my example, I'm using a Linksys E3000, but based on how these settings work, I would state that you can use any decent router of choice.  There's nothing being set that's "router-specific"; every modern router should have these settings.

 

The NVG510 (modem)...

 

Step 1:  connect the NVG510 with a computer.  This can be done through a wired or wireless connection.  I won't get into those details here, but you'll want to open the interface to the NVG510 in a browser (e.g. Internet Explorer).  The default IP for the modem is 192.168.1.254.  You will need the access code (on the side of the modem) to make changes in the settings.  Point your browser to "http://192.168.1.254".

 

With the modem's interface showing in your browser...

 

Step 2:  click on "Home Network | Subnets & DHCP".  Here you'll want to use settings similar to the example below.  The key here is that the IP address pattern of your NVG510 and your home router's set of IP addresses must differ in the 3rd offset.  As in:

 

"xxx.xxx.yyy.xxx".  So the "yyy" segment (offset) needs to be different.  I used "1" for the modem (which is how it's defaulted to with 192.168.1.254) and then "0" for my router as in 192.168.0.110.

 

Here are the modem's settings:

untitledNVG510 modem - screenshot of subnets and dhcp.JPG

 

 

Save the changes, but don't reboot yet.  We have another change to make (if you reboot, it's ok as it won't hurt anything, just takes longer).

 

 

Step 3:  click on "Firewall | Ip Passthrough".  Update the settings as follows:

untitledNVG510 modem - screenshot of default server under firewall.JPG

 

The "allocation mode" should be on "default server".  I tried both "off" and "passthrough" and neither worked.  This seems to be a crucial step.  Note that the "default server internal address" must match the address of our single DHCP one being assigned by the NVG510.

 

Be sure to SAVE the changes.  Don't bother rebooting - just unplug the power cord from the NVG510.  We are moving on to the settings in the router and the next time we plug-in the modem, that will serve as its reboot.

 

 

Home Router (Linksys E3000)...

 

Step 1:  Unplug the NVG510 from your computer (or disconnect if connected wirelessly) and connect to your home router.  In my case, I'm connecting to a Linksys E3000 (again, not really important here on the brand/model you have; everything here should work the same).

 

 

With the router's interface showing in your browser...

 

Step 2:  Find the "setup" page (usually the default screen which comes up) to where you establish the connection type (e.g. PPPoe, static, etc.) and set the connection type to "static IP".  We're going to configure to have a static IP because of the single, static IP coming from the NVG510, the 192.168.1.1It seems the NVG510 handles all the authentication for us:

 

Linksys router setup screenshot.jpg

 

 

Notice that the router's IP address has the "0" in the 3rd offset.  Remember, this 3rd offset must be different than that of the modem's.  You can use whatever you want, but the router and modem must differ there.

 

The "default gateway" and "dns" are both set to that of the NVG510 address.  I suppose you can use whatever you want such as Google's "8.8.8.8".  Regarding the gateway address, if you changed yours from the modem's default, be sure to reflect that here as well in the router. 

 

Be sure to SAVE your changes.  That's it!

 

There are no more steps required in your router to operate with the NVG510.

 

To ensure everything takes effect, turn off your router (unplug if no power switch).  Then plug in your NVG510 and power-on the router (at same time is fine; otherwise, do modem then router).

 

The end result of the network setup is depicted here:

NVG510 and home router IP config example.jpg

 

 

Once again, you can use any IP configurations you want.  Just use this example to correspondingly change the addresses in both the modem and router to meet your liking.

 

I hope this feedback is able to benefit others.  I would hate to learn that someone else is having to spend 7 hours on the chats and phone calls only to have this quick process done at the end.

Accepted Solution

Using your own router with the Motorola NVG510 - it absolutely works and it's easy to do!

[ Edited ]
78,110 views
29 replies
(4) Me too
(4) Me too
Post reply
View all replies
(29)
5
(1)
  • Rate this reply
View profile
Solved
Dec 5, 2013 8:09:02 AM
5
(1)
Teacher

You will need to adjust settings on both the NVG510 and your router.  In my example, I'm using a Linksys E3000, but based on how these settings work, I would state that you can use any decent router of choice.  There's nothing being set that's "router-specific"; every modern router should have these settings.

 

The NVG510 (modem)...

 

Step 1:  connect the NVG510 with a computer.  This can be done through a wired or wireless connection.  I won't get into those details here, but you'll want to open the interface to the NVG510 in a browser (e.g. Internet Explorer).  The default IP for the modem is 192.168.1.254.  You will need the access code (on the side of the modem) to make changes in the settings.  Point your browser to "http://192.168.1.254".

 

With the modem's interface showing in your browser...

 

Step 2:  click on "Home Network | Subnets & DHCP".  Here you'll want to use settings similar to the example below.  The key here is that the IP address pattern of your NVG510 and your home router's set of IP addresses must differ in the 3rd offset.  As in:

 

"xxx.xxx.yyy.xxx".  So the "yyy" segment (offset) needs to be different.  I used "1" for the modem (which is how it's defaulted to with 192.168.1.254) and then "0" for my router as in 192.168.0.110.

 

Here are the modem's settings:

untitledNVG510 modem - screenshot of subnets and dhcp.JPG

 

 

Save the changes, but don't reboot yet.  We have another change to make (if you reboot, it's ok as it won't hurt anything, just takes longer).

 

 

Step 3:  click on "Firewall | Ip Passthrough".  Update the settings as follows:

untitledNVG510 modem - screenshot of default server under firewall.JPG

 

The "allocation mode" should be on "default server".  I tried both "off" and "passthrough" and neither worked.  This seems to be a crucial step.  Note that the "default server internal address" must match the address of our single DHCP one being assigned by the NVG510.

 

Be sure to SAVE the changes.  Don't bother rebooting - just unplug the power cord from the NVG510.  We are moving on to the settings in the router and the next time we plug-in the modem, that will serve as its reboot.

 

 

Home Router (Linksys E3000)...

 

Step 1:  Unplug the NVG510 from your computer (or disconnect if connected wirelessly) and connect to your home router.  In my case, I'm connecting to a Linksys E3000 (again, not really important here on the brand/model you have; everything here should work the same).

 

 

With the router's interface showing in your browser...

 

Step 2:  Find the "setup" page (usually the default screen which comes up) to where you establish the connection type (e.g. PPPoe, static, etc.) and set the connection type to "static IP".  We're going to configure to have a static IP because of the single, static IP coming from the NVG510, the 192.168.1.1It seems the NVG510 handles all the authentication for us:

 

Linksys router setup screenshot.jpg

 

 

Notice that the router's IP address has the "0" in the 3rd offset.  Remember, this 3rd offset must be different than that of the modem's.  You can use whatever you want, but the router and modem must differ there.

 

The "default gateway" and "dns" are both set to that of the NVG510 address.  I suppose you can use whatever you want such as Google's "8.8.8.8".  Regarding the gateway address, if you changed yours from the modem's default, be sure to reflect that here as well in the router. 

 

Be sure to SAVE your changes.  That's it!

 

There are no more steps required in your router to operate with the NVG510.

 

To ensure everything takes effect, turn off your router (unplug if no power switch).  Then plug in your NVG510 and power-on the router (at same time is fine; otherwise, do modem then router).

 

The end result of the network setup is depicted here:

NVG510 and home router IP config example.jpg

 

 

Once again, you can use any IP configurations you want.  Just use this example to correspondingly change the addresses in both the modem and router to meet your liking.

 

I hope this feedback is able to benefit others.  I would hate to learn that someone else is having to spend 7 hours on the chats and phone calls only to have this quick process done at the end.

Re: Using your own router with the Motorola NVG510 - it absolutely works and it's easy to do!

2 of 30 (76,526 Views)
Solution
Highlighted
1
(1)
  • Rate this reply
View profile
Dec 5, 2013 11:09:12 AM
1
(1)
ACE - Expert

This process appears to work for NVG 589 as well.

*The views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.

Re: Using your own router with the Motorola NVG510 - it absolutely works and it's easy to do!

3 of 30 (76,497 Views)
0
(0)
  • Rate this reply
View profile
Dec 5, 2013 1:16:39 PM
0
(0)
Expert
This does work for both the NVG510 and NVG589, however, using the Default Server mode results in double-NAT. To get as close to bridge as possible, you need to use Passthrough mode, which will require the WAN interface of your router to be set to DHCP.

Re: Using your own router with the Motorola NVG510 - it absolutely works and it's easy to do!

4 of 30 (76,490 Views)
1
(1)
  • Rate this reply
View profile
Dec 5, 2013 1:58:49 PM
1
(1)
ACE - Expert

I wonder if someone with a NVG 589 could put together the screen shots of it conifigured that way?

 

*The views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.

Re: Using your own router with the Motorola NVG510 - it absolutely works and it's easy to do!

5 of 30 (76,486 Views)
0
(0)
  • Rate this reply
View profile
Dec 7, 2013 6:41:47 PM
0
(0)
Tutor
THANK YOU DONLUZ!!! Your solution has solved my problem with terrible upstream when using the NVG510. I set up my E1000 as you described and my upstream has gone from .2 - .3 with the NVG back to .9 that I used to have.
Thank you again.

Re: Using your own router with the Motorola NVG510 - it absolutely works and it's easy to do!

6 of 30 (76,322 Views)
0
(0)
  • Rate this reply
View profile
Dec 23, 2013 10:21:40 PM
0
(0)
Voyager
Edited by Kichigai_Dave on Dec 23, 2013 at 10:22:53 PM

I'm using gaming systems so I really want to use this gateway/modem as a simple pass through and use my own ASUS router that works great! I saw you (SomeJoe7777) posted about a double-NAT issue and that sounds like it would be an issue with what I want to do. I also noticed on the Home Netowork > Settings & DHCP section of the NVG510 that there's a Cascaded Router option/feature. Isn't this was this is for? Or should I use the method posted by donluz and set my router WAN to DHCP?

 

Thanks,

 

Re: Using your own router with the Motorola NVG510 - it absolutely works and it's easy to do!

[ Edited ]
7 of 30 (74,875 Views)
0
(0)
  • Rate this reply
View profile
Jan 1, 2014 12:16:54 PM
0
(0)
Contributor

can we add additional addresses/connections on the ATT router in this setup? i'd like to keep separate the wireless video traffic from the internal subnet.

 

so to restate in your diagram you have a single connection to the ATT gateway can we have additional devices at that level?

Re: Using your own router with the Motorola NVG510 - it absolutely works and it's easy to do!

8 of 30 (74,040 Views)
0
(0)
  • Rate this reply
View profile
Feb 1, 2014 7:36:12 AM
0
(0)
Contributor

Is there an A/C replacement for the Motorola NVG510, which is only wireless N??

Motorola NVG510 A/C replacement

9 of 30 (71,322 Views)
0
(0)
  • Rate this reply
View profile
Feb 1, 2014 8:59:59 AM
0
(0)
Employee
For RevJeff144, there are currently NO AC routers in Uverse inventory of RGs either adsl2+ circuits using the 510 or vdsl circuits using various RGs.

If desire an AC router, will need to purchase your own and place behind the 510 in DMZ or IP pass through.
*I am an AT&T employee and the postings on this site are my own and don’t necessarily represent AT&T’s position, strategies or opinions.

Re: Motorola NVG510 A/C replacement

10 of 30 (71,309 Views)
0
(0)
  • Rate this reply
View profile
Feb 1, 2014 1:10:34 PM
0
(0)
Contributor
Thank you! :-)

Re: Motorola NVG510 A/C replacement

11 of 30 (71,276 Views)
0
(0)
  • Rate this reply
View profile
Feb 14, 2014 6:16:12 PM
0
(0)
Voyager

I was able to connect a personal router to the NVG589 by doing this.

 

1.Configure personal router

a. Set IP to 192.168.2.254

b. DHCP enabled as it was previously with DSL

 

2.Configure NVG589 using a pc connected to a LAN port

a. Set allocation mode to IP Passthrough

b. Set passthrough mode to DHCPS-fixed

c. Enter personal router’s MAC address in the Passthrough Fixed MAC address field

d. Reset the NVG589.  It takes a couple of minutes.

e. After the NVG589 reset I had to restart the phone

f. Connect LAN 1 from NVG589 to personal router’s WAN input

 

3. Plugged all wired devices into LAN ports of personal router and setup wireless LAN.

 

I didn’t disable any of the firewall settings on the NVG589 and also kept DHCP enabled.   Now comes the interesting part, after enabling the NVG589’s wireless LAN it functioned correctly as wireless router.   Without knowing what the NVG589 is doing internally it appears that this setup has two separate networks.    Everything tied to the personal router is behind its firewall.   I think the NVG589’s firewall is set up and protecting the NVG589’s wireless network.   My plan is to configure the NVG589 WLAN as a guest network (192.168.1.x) and the personal router will be the private network (192.168.2.x).  Does someone who knows more about the NVG589 confirm that the guest network is protected by the firewall even it is set up for passthrough mode?    I’m assuming that the NVG’s firewall is not filtering the connection to the personal router, but that doesn’t really matter.

 

Does anyone see any issues with this setup from the perspective of conflicts / speed issues and also from a security perspective?

Re: Using your own router with the Motorola NVG510 - it absolutely works and it's easy to do!

12 of 30 (70,171 Views)
0
(0)
  • Rate this reply
View profile
Apr 4, 2014 3:11:46 PM
0
(0)
Teacher

I had the UVerse NVG589 installed about three weeks ago, and need to get my security cameras back online, so I can view them remotely.  I was on AT&T DSL prior with a Superstream modem, and now with this new modem I can not find the Port Forwarding Mode to work on this. 

 

After reading this blog, I see others have struggled too, but Steve74123 may have my answer.  I had a D-Link router connected to my old DSL modem; prior to this changeover.  Now I see I need to connect this router to the NVG589 to get my system back to normal. 

 

Seems like I really won't have to change much on my router, just plug it into an open port on the NVG589 and set the NVG589 to Passthrough mode, andset my routers address to the NVG589 access IP address.  I hope this works.  If it does, I'll post some pictures on here next week. 

 

By the way, I  only have internet access and no TV or Phone on this NVG589.  Just fyi....

 

Fingers crossed....

Re: Using your own router with the Motorola NVG510 - it absolutely works and it's easy to do!

13 of 30 (66,361 Views)
0
(0)
  • Rate this reply
View profile
Apr 9, 2014 12:31:49 PM
0
(0)
Contributor

I tried to change the address in the first step but I don't know if I'm doing it right. I'm using a linksys e1000 behind a nvg589. Do I change the start and ending or do I select cascading and then change it?? I'm so confused. Any help would be appreciated.

 

Re: Using your own router with the Motorola NVG510 - it absolutely works and it's easy to do!

14 of 30 (66,023 Views)
0
(0)
  • Rate this reply
View profile
Apr 17, 2014 6:47:55 PM
0
(0)
Voyager
Edited by RazeNCain on Apr 17, 2014 at 6:52:41 PM

I got my NVG589 today, just got everything working. It's very simple.

 

Connect your personal router to your computer and login to the administration panel.

 

Change your router IP to 192.168.2.1 you should be able to keep everything else the same.

 

Connect your router to your modem at this point you should be able to connect to the internet, in order to make your router have full control go to 192.168.1.254 on your PC after the modem and router is connected, go to Firewall > IP Passthrough change Allocation Mode to Default Server. Under Default Server Internal Address your router IP will be showing select it from the list, mine was 192.168.1.68

 

Save settings and reboot modem. Once it reboots you should be golden. All my game systems now show NAT Open, and no longer have connection problems. I tried all the post I could find.

 

You may or may not have to disable packet filters, I did since my router has this feature. You may also want to go into  Home Network > Wireless and disable the wireless so you don't have two showing on your laptop.

 

Hope this helps someone else. I did 3 resets until I got my settings right, and it was much more simple than people were making it seem. Smiley Wink

 

Here's my router settings, it's a Linksys WRT150N (yeah its old). I am using OpenDNS servers, you can leave those default. These are the only settings on your router you need to change to make it work with the NVG589 or any other modem. I have been using these for years, 5 different modems. My main issue was the Strict Nat, and very slow connections speeds and the modem settings fixed that.

router settings.jpg

Re: Using your own router with the Motorola NVG510 - it absolutely works and it's easy to do!

[ Edited ]
15 of 30 (65,276 Views)
0
(0)
  • Rate this reply
View profile
Apr 21, 2014 5:52:41 PM
0
(0)
Contributor

Uh - double NAT.  Good luck with that.

 

Set the NVG to passthrough, set the WAN on your router to DHCP, and go with it.

 

- or -

turn your router/AP into a bridge and go that route.

 

Re: Using your own router with the Motorola NVG510 - it absolutely works and it's easy to do!

16 of 30 (64,918 Views)
0
(0)
  • Rate this reply
View profile
Apr 29, 2014 12:21:55 PM
0
(0)
Voyager
Edited by try93 on Apr 29, 2014 at 12:22:54 PM

I have the Motorola NVG510 and another Netgear router WGR614v6 . I have followed your steps and nothing works. Help.

Re: Using your own router with the Motorola NVG510 - it absolutely works and it's easy to do!

[ Edited ]
17 of 30 (64,261 Views)
0
(0)
  • Rate this reply
View profile
Jun 13, 2014 2:24:06 PM
0
(0)
Contributor

1) I got the setup to work, with the second Linksys E1200 router, directly connect to the nvg510 lan port in the back.  I hide the nvg510 SSID. 

  - Is there a way to disable the nvg510 LAN ports in the back.  If yes then I can setup the 2nd router through wireless.

 

2) the e1200 now uses OpenDNS.  My next question is I want to register my network with OpenDNS, so I can modify using my own filtering configuration/categories.  When I tried to add ip address, the e1200 ip address is a private network address, so I cannot add.  The nvg510 ip address already existed according to OpenDNS. 

  - Which ip address can/should I use to register under my OpenDNS account?  So I can block some of the categories.

 

tia

Re: Using your own router with the Motorola NVG510 - it absolutely works and it's easy to do!

18 of 30 (60,838 Views)
0
(0)
  • Rate this reply
View profile
Jun 18, 2014 9:56:36 PM
0
(0)
Voyager
Edited by Mithral on Jun 18, 2014 at 10:07:56 PM

Much thanks for these instructions.  it is a year later and still a valuable post.

 

One small detail that is easily missed by a novice:

 

You say to set the DHCP address to 192.168.1.1  in the NGV510.  This is the default address of Linksys routers and causes an IP conflict.

 

So with these instrucitons we end up changing the Linksys address to 192.168.0.110.   Many novices will not realize as soon as they do this they can no longer log back on their Linksys routers with the default address.

 

Seems like a simple little detail, but if the instructions where clearer on this point my setup time would have been about 15 minutes instead of 3 frustrating hours trying to figure out the IP address conflict issue.

 

I suggest editing instructions for leaving the Linksys IP address as it's default and setting the DHCP in thel NVG510 to something different.   Then maybe we wouldn't have to reconfigure much in the Linksys.

 

I figured out the the instrucitons above and just left it working as is.  Then taped a note to the router with the new IP address for reference in a year or two when I forget all of this.

 

...

 

So Uverse in my area isn't any better than the DSL I replaced.  Now that it is working, I'm not impressed with the service.   It is within parameters.  Download speed is acceptable, but Upload is disappointing.   It is the Upload speed I wanted to upgrade the most and on that I didn't get what was expected.

 

Got a great settup deal, switched for virtually no cost because ATT was pretty deseprate to get me off the Analog DSL network and on the digital Uverse.   But at the end of the 12 months when prices jump up and the service is still disappointing, I might end up going back to cable as a better price option.  I hope ATT gets their act together by then because I really dislike the cable company here.

 

 

Re: Using your own router with the Motorola NVG510 - it absolutely works and it's easy to do!

[ Edited ]
19 of 30 (60,334 Views)
0
(0)
  • Rate this reply
View profile
Jun 19, 2014 4:44:07 AM
0
(0)
Contributor

Hello all, I'm new to the Uverse setup and have been able to make the changes that are needed to use my own Asus AC router with the ATT RG. One question that I have is that now this is all setup and everything works how do you get the ATT Uverse App to connect? My 3 TV's work without any issues but when on my Phone or Tablet on my local wireless (Asus not the RG) I can't get the Uverse app to realize that I am on my home network so no remote, no local channels and I can only see the out of home live shows. If I turn on the ATT RG wireless and connect to it, the APP's work like they should.

 

 

Also when I run a tracert to the internet I hit the Asus gateway and then the RG gateway and then my external IP address. If I look at the ASUS WAN setting I have the external IP address gateway as the WAN gateway.

 

Any information will be helpfull. 

Re: Using your own router with the Motorola NVG510 - it absolutely works and it's easy to do!

20 of 30 (60,308 Views)
1
(1)
  • Rate this reply
View profile
Jun 19, 2014 11:14:24 AM
1
(1)
ACE - Expert

Sinman wrote:

...

Also when I run a tracert to the internet I hit the Asus gateway and then the RG gateway and then my external IP address. If I look at the ASUS WAN setting I have the external IP address gateway as the WAN gateway.

 ...


The NVG doesn't have a true bridge mode, so it still routes the packets from the ASUS and is thus a hop.  

 


Sinman wrote:

Hello all, I'm new to the Uverse setup and have been able to make the changes that are needed to use my own Asus AC router with the ATT RG. One question that I have is that now this is all setup and everything works how do you get the ATT Uverse App to connect? My 3 TV's work without any issues but when on my Phone or Tablet on my local wireless (Asus not the RG) I can't get the Uverse app to realize that I am on my home network so no remote, no local channels and I can only see the out of home live shows. If I turn on the ATT RG wireless and connect to it, the APP's work like they should.

 

...



I don't think AT&T has documented just how a mobile device decides that it is in a U-verse home network, but I believe that it is by using a discovery protocol with the RG.  Your ASUS router doesn't pass that protocol between your RG and your mobile device, thus the mobile device doesn't know that it's in-home.  I've seen posts where users were able to convince some models of Cisco router to pass the traffic necessary so that U-verse connected apps work.

 

 

*The views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.

Re: Using your own router with the Motorola NVG510 - it absolutely works and it's easy to do!

21 of 30 (60,267 Views)
0
(0)
  • Rate this reply
View profile
Jun 30, 2014 5:19:59 AM
0
(0)
Contributor

Thanks for the reply. I guess I will call support and see what I can get out of them. I would like to be able to turn the wireless off on the RG and use my own for the in home features on my tablets and phones.

 

Re: Using your own router with the Motorola NVG510 - it absolutely works and it's easy to do!

22 of 30 (59,171 Views)
1
(1)
  • Rate this reply
View profile
Jun 30, 2014 5:35:33 AM
1
(1)
ACE - Expert

Don't count on telephone support to be able to help you with this.  You're in the "too technical" range.

 

If you don't really need the router functionality and you just want better WiFi signal, you could operate your router as a Wireless Access Point.  See post 13 in this thread for instructions.

*The views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.

Re: Using your own router with the Motorola NVG510 - it absolutely works and it's easy to do!

23 of 30 (59,165 Views)
0
(0)
  • Rate this reply
View profile
Jul 15, 2014 1:37:49 PM
0
(0)
Tutor

I've gone through various of the suggested methods and finally have ended up with the following:

 

I have an Apple Airport Extreme (AE), which has only limited settings compared to the typical routers like Netgear and Linksys. I've set up the AE Network on "bridged mode," and with Internet settings on DHCP. The AE has "acquired" an IPv4 address of 192.168.1.67 from the NVG 510 whose router address is 192.168.1.254. Under the Internet settings it allows me to enter my own DNS addresses (I use 8.8.8.8 from Google and 208.67.222.222 from OpenDNS) which I assume the system uses now rather than the AT&T DNS addresses (is there a way to check this?). I think I might have had to first set the AE to a manual IP address before then going to DHCP--I can't recall.

 

The NVG51 settings are essentially unchanged from default. It is set on "off", not to passthrough or anything else. I didn't make any changes in the IPv4 address range on the NVG510. The NVG510 wireless function is turned off and the NVG510 has a cable going to the AE input. That's it.

 

The DL and UL speeds are about 14 and .9 respectively, which is as expected with UVerse.

Re: Using your own router with the Motorola NVG510 - it absolutely works and it's easy to do!

24 of 30 (57,520 Views)
0
(0)
  • Rate this reply
View profile
Jul 23, 2014 11:16:52 AM
0
(0)
Contributor

I am having issues and need some advice on what i can do. I have 2 xboxes with xbox live accounts. One of us can play but the other is having NAT errors that says its at moderate. I have called both xbox live and they said to call my internet service provider and i did that and they want 50 bucks and thats no guarnetee they can fix the issue.

 

My question is how is the easiest way for me to set this Motorola NVG510 to open NAT up so we can both play?

 

What is ur suggestions on what i should do......... help please

Re: Using your own router with the Motorola NVG510 - it absolutely works and it's easy to do!

25 of 30 (56,317 Views)
0
(0)
  • Rate this reply
View profile
Sep 19, 2014 8:05:59 PM
0
(0)
Tutor
Edited by sogar on Sep 19, 2014 at 11:37:11 PM

If I were to do this, which router would be my best bet for my xbox 360? I just wanna be able to play and connect to anyone in a party without any problems. BTW, we do have multiple Xboxs in the houses, and other consoles as well.

Re: Using your own router with the Motorola NVG510 - it absolutely works and it's easy to do!

[ Edited ]
26 of 30 (46,766 Views)
5
(1)
  • Rate this reply
View profile
Dec 20, 2014 4:27:49 PM
5
(1)
Contributor
Edited by throwaway2 on Dec 20, 2014 at 4:29:11 PM

I registered just to give this post a bump because it works (Linksys E4200 router over here). Just rememeber to follow the instructions EXACTLY!

 

Thanks for the help!

Re: Using your own router with the Motorola NVG510 - it absolutely works and it's easy to do!

[ Edited ]
27 of 30 (31,598 Views)
0
(0)
  • Rate this reply
View profile
Dec 27, 2014 5:55:39 AM
0
(0)
Contributor
You have opened my eyes up. I just signed up for att static IP address. My intent is to assign the static IP address to my router, but when I place in the information to assign the IP address, it gives me the error static IP address and default gateway must come from the same subnet.

Can you or anyone help?

Re: Using your own router with the Motorola NVG510 - it absolutely works and it's easy to do!

28 of 30 (30,316 Views)
0
(0)
  • Rate this reply
View profile
May 25, 2015 9:41:40 PM
0
(0)
Voyager

Hi ,

 

I followed your instructions to connect my Asus RT-AC68U router behnd my NVG modem,

 

everything seamed fine, my Asus did instruct me to change it's default IP from 192.168.1.1, it selected 192.168.2.1, other than that part now problems, did the reboot fo the modem and my router, fired it all up and my router was working, connected some devices and all was good.

 

That was until I tried to turn on the Uverse STB,  I have 2 boxes, the one that connects to the NVG moem just shows the blue screen with the "ATT Uverse" logo, I did reset it but  it always got stuck at the blue screen,

 

I then went upstairs to the my other STB, it seamed to be ok, TV picture working fine, I then decided to reboot that one also, and it then went the same state as my main STB - stuck at "Blue Screen" with ATT logo etc,

 

so I then reverted back to my original (default) settings and disconnected my Router, turned back on the NVG wireless, turned off the IP Pass through and changed the Private LAN subnet back to what it was before I changed anything,

 

When I did the initial set up I did not remove the STB connection to the Modem LAN port, not sure if that has a play here,

 

it does sound lke I am missing a step that will allow my wifi to flow via my router and my STB's to provide the TV service,

 

any help or gudiance appreciated,

 

I have to say I have tried twice before to set up my router with little success until I found this thread, ad now I managed to get the Wireless part working so I can use my A/C router on 5G for smooth streaming but need my STB's to play nice also,

 

thanks in advance,

 

Re: Using your own router with the Motorola NVG510 - it absolutely works and it's easy to do!

29 of 30 (6,470 Views)
0
(0)
  • Rate this reply
View profile
Jun 19, 2015 3:32:06 PM
0
(0)
Contributor

This setup will also work for using your own router with the NVG510 ( http://www.ron-berman.com/2011/11/24/motorola-nvg510-help-page-for-att-u-verse-users/)

On the NVG510:

1. Under "Home Network->Subnets & DHCP":
- Device IPv4 Address: 192.168.1.254 (this is the default)
- DHCPv4 Start Address: 192.168.1.1
- DHCPv4 End Address:  192.168.1.1
(This tells the NVG510 to only allocate one address to a device connected to it)

2. Under "Home Network->Wireless"
- Wireless Operation: Off
(Since you will be using your own WiFi router)

3. Under "Firewall->IP Passthrough"
- Allocation Mode: Passthrough
- Passthrough Mode: DHCPS-fixed
- Passthrough Fixed MAC Address: <MAC address of the home router>
(You can find your home router MAC address on the home router's status page.
Make sure to enter the WAN MAC address).

3. Under "Home Network->Configuration", change IPv6 to "Off", unless you know how to configure IPv6 to work with your router. This will save you some issues in the future.

On the Home Router

1. Make sure the home router allocates DHCP addresses on the LAN on a different range than 192.168.1.xxx. For example, 192.168.2.xxx will work (with a subnet mask of 255.255.255.0) or 10.0.0.1 will work (with a subnet mask of 255.255.0.0)2.

2. Tell the router to use a fixed WAN IP address (to not use DHCP to get an IP address from the NVG510). Then use the address from the NVG510 configuration page under "Broadband->Broadband IPv4 Address" as the WAN IP address, 255.255.0.0 as the subnet mask, the address under "Broadband->Gateway IPv4 Address" as the gateway address and the DNS server addresses from question #4 above as the primary and secondary addresses. 

 

. I had problem getting my Xbox One Nat off strict with it though. It was like the NVG wasnt letting my router outside the LAN. Even with me setting the port forwards up on the NVG with router IP as the source. But this setup worked. But it still seems when I turn on my Xbox my network speed drops. 

Re: Using your own router with the Motorola NVG510 - it absolutely works and it's easy to do!

30 of 30 (2,326 Views)
Share this post
Share this post