Ask a question
Search in U-verse Forums

U-verse Forums

Reply
Highlighted
Posted Feb 7, 2014
8:26:30 PM
NVG589 port forwarding not working

I have seen this issue in the forum a few times and have tried solutions but not working for me. 

 

I am trying to open up a few ports and not working.  I called support, they said something with my line and sending a tech out, but I do not think that is the issue.

 

When I add a new port, I notice the following in the system log

 

2014-02-07T22:06:11-05:00 L3 sdb[331]: TAI: iptables creation failed for nat prerouting
2014-02-07T22:06:11-05:00 L3 sdb[331]: TAI: iptables creation failed for filter forward
2014-02-07T22:06:11-05:00 L3 sdb[331]: TAI: iptables creation failed for mangle prerouting
2014-02-07T22:06:11-05:00 L3 sdb[331]: TAI: iptables creation failed for filter input
2014-02-07T22:06:13-05:00 L3 sdb[331]: radv: enabled 

 

 

I have disabled Packet filter 

Under firewall advanced,  it stated to turn off drop IGMP echo, I assume ICMP echo was meant.  So this is off.

 

I have tried with ip passhtrough off and on.  When on , I used DHCPS-fixed, mac address of the device I want to send to. 

 

Still no luck.  From the logs, just looks like it can not update, but it does add it to the NAT screen.

 

I have used www.checkmyports.net  It has my att router ip,  and when I put in 443 it states it is open, when I try any of the ports I configured it states it is closed.  I assume this is checking at the firewall.  IE I have configured port 4433 to a web server.  On the server, it works fine, but on any other computer to access, it hangs likely being blocked by router. 

 

Checking the log after restarting such as when I changed to ipforwarding.  I notice the same iptable errors repeated several times. 

 

Any help appreciated.

 

I am trying to connect my Windows Home server to use within my house, and outside access would be nice.  Default port is 443, but that is used, so I changed to 4433.  It works on the server, but thats it. 

 

 

 

I have seen this issue in the forum a few times and have tried solutions but not working for me. 

 

I am trying to open up a few ports and not working.  I called support, they said something with my line and sending a tech out, but I do not think that is the issue.

 

When I add a new port, I notice the following in the system log

 

2014-02-07T22:06:11-05:00 L3 sdb[331]: TAI: iptables creation failed for nat prerouting
2014-02-07T22:06:11-05:00 L3 sdb[331]: TAI: iptables creation failed for filter forward
2014-02-07T22:06:11-05:00 L3 sdb[331]: TAI: iptables creation failed for mangle prerouting
2014-02-07T22:06:11-05:00 L3 sdb[331]: TAI: iptables creation failed for filter input
2014-02-07T22:06:13-05:00 L3 sdb[331]: radv: enabled 

 

 

I have disabled Packet filter 

Under firewall advanced,  it stated to turn off drop IGMP echo, I assume ICMP echo was meant.  So this is off.

 

I have tried with ip passhtrough off and on.  When on , I used DHCPS-fixed, mac address of the device I want to send to. 

 

Still no luck.  From the logs, just looks like it can not update, but it does add it to the NAT screen.

 

I have used www.checkmyports.net  It has my att router ip,  and when I put in 443 it states it is open, when I try any of the ports I configured it states it is closed.  I assume this is checking at the firewall.  IE I have configured port 4433 to a web server.  On the server, it works fine, but on any other computer to access, it hangs likely being blocked by router. 

 

Checking the log after restarting such as when I changed to ipforwarding.  I notice the same iptable errors repeated several times. 

 

Any help appreciated.

 

I am trying to connect my Windows Home server to use within my house, and outside access would be nice.  Default port is 443, but that is used, so I changed to 4433.  It works on the server, but thats it. 

 

 

 

NVG589 port forwarding not working

6,512 views
12 replies
(0) Me too
(0) Me too
Reply
View all replies
(12)
0
(0)
  • Rate this reply
View profile
Feb 8, 2014 10:17:45 AM
0
(0)
Tutor

I am spending / wsting so much time with this.  I believe this is either issue with router, or ATT uverse blocking the services.

 

I have had 3 calls to ATT support plus and they do the same configuration I do, and then say, ok the ports are open.  But they only say that because they configure the router to open.   But the logs have the  errors when ever they add.   I have tried using many of the misc default games to add, and they have the defined ports to open.  But if you try to get to that port via a port checker, it is blocked.

 

I would not even be able to play games between computers in the house becasue they go through the router and it is blocking internal traffic also.  

 

Support tech and uverse support state it is now open, and will work.   I cannot not seem to get anyone to understand that just becasue you configure on the router, does not actually mean it is open.  Only ones that seem to be open is 443 and 80, which I can not use. 

 

Any thoughts who I need to contact to get this resolved?  Support plus states it is uverse issue, uverse states this is for connect plus since my internet is working Smiley Sad

I am spending / wsting so much time with this.  I believe this is either issue with router, or ATT uverse blocking the services.

 

I have had 3 calls to ATT support plus and they do the same configuration I do, and then say, ok the ports are open.  But they only say that because they configure the router to open.   But the logs have the  errors when ever they add.   I have tried using many of the misc default games to add, and they have the defined ports to open.  But if you try to get to that port via a port checker, it is blocked.

 

I would not even be able to play games between computers in the house becasue they go through the router and it is blocking internal traffic also.  

 

Support tech and uverse support state it is now open, and will work.   I cannot not seem to get anyone to understand that just becasue you configure on the router, does not actually mean it is open.  Only ones that seem to be open is 443 and 80, which I can not use. 

 

Any thoughts who I need to contact to get this resolved?  Support plus states it is uverse issue, uverse states this is for connect plus since my internet is working Smiley Sad

Re: NVG589 port forwarding not working

2 of 13 (6,469 Views)
0
(0)
  • Rate this reply
View profile
Feb 8, 2014 5:54:14 PM
0
(0)
Tutor

As a workaround, I saw one of the uverse wireless devices was assigned 443 in the nat table and this does work.   It is the wireless device that plugs into the router.  As a workaround, I unplugged it, changed my server to that IP address, and now I can acess my server via 443 and port 80.   I then plugged in the uverse device again.   My wireless receiver works, all else is working.   So not sure what that port is needed for on the device.  Maybe for download of movies.  

 

So I guess I have workaround for now.  I will see if it is the line to the house, but I doubt it.   Tech is coming tomorrow. 

As a workaround, I saw one of the uverse wireless devices was assigned 443 in the nat table and this does work.   It is the wireless device that plugs into the router.  As a workaround, I unplugged it, changed my server to that IP address, and now I can acess my server via 443 and port 80.   I then plugged in the uverse device again.   My wireless receiver works, all else is working.   So not sure what that port is needed for on the device.  Maybe for download of movies.  

 

So I guess I have workaround for now.  I will see if it is the line to the house, but I doubt it.   Tech is coming tomorrow. 

Re: NVG589 port forwarding not working

3 of 13 (6,455 Views)
0
(0)
  • Rate this reply
View profile
Feb 8, 2014 7:33:00 PM
0
(0)
ACE - Expert
Edited by JefferMC on Feb 8, 2014 at 7:35:20 PM

That port is used by AT&T for management of the Wireless Receiver's WAP.  Things will likely "go funny" if you leave it like that.  Those who have tried to re-enable the firewall on 443 or forward it to another device have found it back the way "it's supposed to be" after a few days.

 

I don't know why they had to reserve a well known port for this, but... they did.

 

BTW, CheckMyPorts.com checks the ports by trying to open a socket to the IP/port.  If there's nothing behind the firewall listening to the port, checkmyports will report it as closed, even if the Firewall isn't blocking it.

 

That port is used by AT&T for management of the Wireless Receiver's WAP.  Things will likely "go funny" if you leave it like that.  Those who have tried to re-enable the firewall on 443 or forward it to another device have found it back the way "it's supposed to be" after a few days.

 

I don't know why they had to reserve a well known port for this, but... they did.

 

BTW, CheckMyPorts.com checks the ports by trying to open a socket to the IP/port.  If there's nothing behind the firewall listening to the port, checkmyports will report it as closed, even if the Firewall isn't blocking it.

 

*The views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.

Re: NVG589 port forwarding not working

[ Edited ]
4 of 13 (6,449 Views)
0
(0)
  • Rate this reply
View profile
Feb 11, 2014 5:25:19 PM
0
(0)
Tutor

Thank you for info.  

 

Well I have changed the webserver to port 4433, but still blocked, when I open to 443, then it works. I am not sure how to get to open.  I think there is something about those ipaddr errors, but not sure what.  Probably some other config on the router.  Support plus is suppose to know that, but they do not.  

 

And the Uverse Support plus that you pay $ for support, changed it to 443 and said use that.  During their config change it says this may cause issues, and I said for testing yes, you can do so.  They did, and then left it saying, if you have TV issues call ATT.

 

Well a day or 2 later my one TV was having on / off issues, but now seems to work.  Sill on port 443

 

The ATT connect people do not understand very well.  

 

A friend has uverse, but different router, we checked his NAT and only open port was 443 for the att wireless.  But his sony x box worked fine.  So I  am not sure without other ports open, how it works. 

 

Still looking for solution. 

Thank you for info.  

 

Well I have changed the webserver to port 4433, but still blocked, when I open to 443, then it works. I am not sure how to get to open.  I think there is something about those ipaddr errors, but not sure what.  Probably some other config on the router.  Support plus is suppose to know that, but they do not.  

 

And the Uverse Support plus that you pay $ for support, changed it to 443 and said use that.  During their config change it says this may cause issues, and I said for testing yes, you can do so.  They did, and then left it saying, if you have TV issues call ATT.

 

Well a day or 2 later my one TV was having on / off issues, but now seems to work.  Sill on port 443

 

The ATT connect people do not understand very well.  

 

A friend has uverse, but different router, we checked his NAT and only open port was 443 for the att wireless.  But his sony x box worked fine.  So I  am not sure without other ports open, how it works. 

 

Still looking for solution. 

Re: NVG589 port forwarding not working

5 of 13 (6,386 Views)
0
(0)
  • Rate this reply
View profile
Feb 11, 2014 6:12:20 PM
0
(0)
Employee
Does your friend have the Wireless Access Point (WAP) supporting wireless receiver(s).
If are willing to hardwired the wireless tv receiver by Ethernet to port on RG, can remove WAP should be no conflict.

I believe I recall a post from Somejoe7777 on this issue, recommending remove WAP or purchase a block of static IPs for $15 a month to provide port 443 for other devices. Could be wrong but believe within past 4 months.
Does your friend have the Wireless Access Point (WAP) supporting wireless receiver(s).
If are willing to hardwired the wireless tv receiver by Ethernet to port on RG, can remove WAP should be no conflict.

I believe I recall a post from Somejoe7777 on this issue, recommending remove WAP or purchase a block of static IPs for $15 a month to provide port 443 for other devices. Could be wrong but believe within past 4 months.
*I am an AT&T employee and the postings on this site are my own and don’t necessarily represent AT&T’s position, strategies or opinions.

Re: NVG589 port forwarding not working

6 of 13 (6,380 Views)
0
(0)
  • Rate this reply
View profile
May 17, 2014 6:40:09 PM
0
(0)
Contributor
Did you ever figure out a solution? I am having the same exact problem. Can't for the life of me get port forwarding to work, no matter what port I use. I haven't tried 443 like you said though.

I also see the errors in the log regarding port forwarding. Trying to get this working for an IP camera I have, which works when I use my local address.
Did you ever figure out a solution? I am having the same exact problem. Can't for the life of me get port forwarding to work, no matter what port I use. I haven't tried 443 like you said though.

I also see the errors in the log regarding port forwarding. Trying to get this working for an IP camera I have, which works when I use my local address.

Re: NVG589 port forwarding not working

7 of 13 (5,948 Views)
0
(0)
  • Rate this reply
View profile
May 18, 2014 11:47:02 AM
0
(0)
Contributor

I've even checked my ports, 8080, online and it says it is open.  I have the NATrule setup to forward and everything.  But when I throw in my dns name with the :8080 it never at all reaches it.

 

Anyone?  Really need help on this.  Spent 2 days on it and nothing.  I have also disabled packet filtering and disabled drop incoming ICMP echo requests.

I've even checked my ports, 8080, online and it says it is open.  I have the NATrule setup to forward and everything.  But when I throw in my dns name with the :8080 it never at all reaches it.

 

Anyone?  Really need help on this.  Spent 2 days on it and nothing.  I have also disabled packet filtering and disabled drop incoming ICMP echo requests.

Re: NVG589 port forwarding not working

8 of 13 (5,901 Views)
0
(0)
  • Rate this reply
View profile
May 23, 2014 3:08:42 PM
0
(0)
Contributor

I spent literally days on this and made the huge mistake of using the wrong public ip address.  Be sure and click on the broadband link and use the Broadband IP4 address as your external IP.  That would have saved me hours and hours.

I spent literally days on this and made the huge mistake of using the wrong public ip address.  Be sure and click on the broadband link and use the Broadband IP4 address as your external IP.  That would have saved me hours and hours.

Re: NVG589 port forwarding not working

9 of 13 (5,755 Views)
0
(0)
  • Rate this reply
View profile
Oct 17, 2014 7:00:59 PM
0
(0)
Contributor

Stevenza,

 

I realize uou posted a while back, but did you find an answer?  I've been struggling for days with the same problem.

 

Thanks,

AGuy

Stevenza,

 

I realize uou posted a while back, but did you find an answer?  I've been struggling for days with the same problem.

 

Thanks,

AGuy

Re: NVG589 port forwarding not working

10 of 13 (4,273 Views)
0
(0)
  • Rate this reply
View profile
Oct 22, 2014 2:03:48 PM
0
(0)
Contributor

So I'm having the same issue on my end here's what I've done for troubleshooting.

default port forward is what I assume an ATT admin SSL port @ 443 

nc -nz <router public ip> 443 from my lab at work... Port OPEN!

So decided to select an few random ports that showed open on my windows box at home,

nz -nz <router public ip> # from the lab .... Port Closed!


hrrm... now mind you I've temporarily disabled any packet filtering on the host and router at this point and still no love. Also this is what Destination NAT portforward setup to the appropriate ports. 

Horay for consumer routers that won't give you a CLI... this stuff always happens and you spend way more time trying to fix it had I just been able to use a spare Linux machine laying around..

So I'm having the same issue on my end here's what I've done for troubleshooting.

default port forward is what I assume an ATT admin SSL port @ 443 

nc -nz <router public ip> 443 from my lab at work... Port OPEN!

So decided to select an few random ports that showed open on my windows box at home,

nz -nz <router public ip> # from the lab .... Port Closed!


hrrm... now mind you I've temporarily disabled any packet filtering on the host and router at this point and still no love. Also this is what Destination NAT portforward setup to the appropriate ports. 

Horay for consumer routers that won't give you a CLI... this stuff always happens and you spend way more time trying to fix it had I just been able to use a spare Linux machine laying around..

Re: NVG589 port forwarding not working

11 of 13 (4,210 Views)
0
(0)
  • Rate this reply
View profile
Oct 22, 2014 7:43:03 PM
0
(0)
ACE - Expert

I see your words, but they're not actually communicating much to me as to what you've actually tried.  Could you try being either, more, less or at least differently technical?

 

 

I see your words, but they're not actually communicating much to me as to what you've actually tried.  Could you try being either, more, less or at least differently technical?

 

 

*The views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.

Re: NVG589 port forwarding not working

12 of 13 (4,194 Views)
0
(0)
  • Rate this reply
View profile
Jun 30, 2016 10:10:41 AM
0
(0)
Contributor

Im trying to get a 3306 port open on my uverse NVG589 router so that i can host a mySQL server off a SBC (Single Board Computer).

 

I have experience port forwarding making an ssh and a minecraft server. But I am not sure why, despite doing it properly, the port still says closed when I made it open.

 

My router works fine. We get internet.

 

One of my friends said AT&T blocks ports like these because they dont like customers making home servers. If this was true then why isn't 22 blocked? I really can't equate this issue to anything else other than the router. MySQL is running fine with all the right permissions and the SBC has all ports open. And yet no one can access 3306. Why?

Im trying to get a 3306 port open on my uverse NVG589 router so that i can host a mySQL server off a SBC (Single Board Computer).

 

I have experience port forwarding making an ssh and a minecraft server. But I am not sure why, despite doing it properly, the port still says closed when I made it open.

 

My router works fine. We get internet.

 

One of my friends said AT&T blocks ports like these because they dont like customers making home servers. If this was true then why isn't 22 blocked? I really can't equate this issue to anything else other than the router. MySQL is running fine with all the right permissions and the SBC has all ports open. And yet no one can access 3306. Why?

Re: NVG589 port forwarding not working

13 of 13 (221 Views)
Advanced
You must be signed in to add attachments
Share this post
Share this post