Explore & discover

Helpful Links

Wifi Calling in airplane mode not working

Tutor

Wifi Calling in airplane mode not working

I have a galaxy s8 and s8+.  Both have wifi calling turned on.  When I put them in airplane mode and try to make a call from my house it says I can't make a call with airplane mode on.  Any suggestions?  I have very poor service in my home.

1,930 Views
Message 1 of 9
ACE - Sage
Solution
Accepted by ACE - Sage (ACE - Sage)
Accepted by lizdance40
‎12-01-2018 4:01 PM

Re: Wifi Calling in airplane mode not working

Once you turn airplane mode on, you have to turn Wifi back on (your “fan” would be dark until you do).  

 

(The following is included after all posts to save typing) I don’t work for AT&T. My replies are based on experience and reading content available on the website. Our answers are honest, but not always appreciated. If you posted personal information, please edit and remove.
Award for Community Excellence 2019 Achiever*
*The views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.
Tags (1)
Message 2 of 9
Tutor

Re: Wifi Calling in airplane mode not working

Thanks.  I know that I have turned wifi back on after airplane mode.  

Message 3 of 9
Tutor

Re: Wifi Calling in airplane mode not working

So your accepted solution is not a solution.  I have airplane mode on with wifi turned back on and can't make calls.

Message 4 of 9
Tutor

Re: Wifi Calling in airplane mode not working

The solution is for AT&T to fix whatever they messed up.   This is ridiculous.

 

It isn't your router, or your phone...it is an AT&T problem.

 

I have verizon and my wifi calling/text is working fine in the same house where an iphone and an android AT&T phones can't make or receive any wifi calls/texts.

Message 5 of 9
ACE - Sage

Re: Wifi Calling in airplane mode not working


@jms54 wrote:

So your accepted solution is not a solution.  I have airplane mode on with wifi turned back on and can't make calls.


So the next question is , “do you have home internet?”   It may sound like a stupid question, but unless you have all the boxes checked, Wifi calling isn’t going to work.   

You need an ATT branded phone.  Capable phone, the S8+S8+ is.  Home internet with Wifi.  You need to set up Wifi calling in settings, verify your e911 address, then your phone will show either the + on the Wifi fan, or AT&T Wifi in notification bar.  

If neither phone will connect to Wifi calling despite all being correct, it is a phone problem.  Although 2 would be very odd.  There have been a few phones reported that won’t connect after recent updates.  Solution is to reset network settings and sign in to Wifi again.  

 

 

(The following is included after all posts to save typing) I don’t work for AT&T. My replies are based on experience and reading content available on the website. Our answers are honest, but not always appreciated. If you posted personal information, please edit and remove.
Award for Community Excellence 2019 Achiever*
*The views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.
Message 6 of 9
ACE - Expert

Re: Wifi Calling in airplane mode not working

@lizdance40 There have been multiple WiFi calling not working posts since yesterday, enough to conclude there might be some issue on the ATT side. No problem on our two phones, though. WiFi calling is working fine. @goodsizer, have you tried rebooting your phone? The last time my phone would not go to WiFi calling, a reboot fixed it.

Award for Community Excellence 2019 Achiever*
*The views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.
Message 7 of 9
Tutor

Re: Wifi Calling in airplane mode not working

Yes, I have high-speed internet, two different wifi compatible phones and have tried it at home and at a neighbor.  I have reset my settings.  I have called tech support and spent quite a lot of worthless time on the phone with them.  I will wait as it does seem that the problem is on AT&T's side.

Message 8 of 9
Tutor

Re: Wifi Calling in airplane mode not working

Ive tried everything and it is two different phones

Message 9 of 9
Share this topic
Share this topic
Announcements...

Are you Missing Your BOGO Credits? If so, QuarryRye can you help figure out what happened and what to do about it!

Additional Support