Explore & discover

Helpful Links

Galaxy j3 2017 phone

Highlighted
Contributor

Galaxy j3 2017 phone

Can't create a contract on phone. It only shows numbers no names. All my other contact in phone are showing only numbers and no names also. How do I fix this. Do not know who's calling anymore.

260 Views
Message 1 of 3
Administrator
Solution
Accepted by topic author
Accepted by Joyceguillory56
‎05-02-2019 9:47 PM

Re: Galaxy j3 2017 phone

Hello, @Joyceguillory56,

 

We'd love to help with this. Do you have the AT&T Call Protect app on your Galaxy phone? There's a known issue with caller ID when the device also has the app on it. You might be able to restore your caller ID by going into Apps and find AT&T Call Protect. In Settings, you should be able to disable the app. After doing that, press and hold the Power/Lock button, then select Power Off. Select Power Off again to confirm. After, press and hold the Power/Lock button again until the screen lights up.

 

Let us know if this helps.

 

James, AT&T Community Specialist


Need help?
Ask a question to get help from the AT&T Community or support from AT&T specialists. If this reply helped you please use Accept solution to mark it as an Accepted Solution.
*I am an AT&T employee, and the postings on this site are my own and don't necessarily represent AT&T's position, strategies or opinions.
Tags (1)
Message 2 of 3
Contributor

Re: Galaxy j3 2017 phone

Accepted solution . It works great . Thank you 

Message 3 of 3
Share this topic
Share this topic
Help for your AT&T Phone service. View AT&T Phone Help!
Additional Support