Ask a question
Search in U-verse Forums

U-verse Forums

Reply
Posted Jul 15, 2014
11:02:46 AM
View profile
VPN problems since Gateway firmware update

For several years now, I have been using a PPTP VPN to access my work from home via my UVerse connection.  This just uses the standard WIndows built-in PPTP client (Windows 7 and Windows 8 currently in use here).

 

Last Wednesday night my router was reset from ATT's end, to push new firmware, and since then I have been unable to establish the VPN.  I have had 5 chats with online support, and three sessions with ConnecTech (escalating to tier 3 there).  Nobody was able to resolve the issue or see anything wrong with the gateway configuration, so eventually they decided to send me a new gateway as mine was a bit old (3800HGV-B).

 

Yesterday the new gateway unit arrived (3801HGV), so I connected it, and as soon as internet connecivity was verified attempted to connect the VPN.  This worked!

 

Five minutes later the router was reset from the ATT end and had its firmware updated.  The VPN no longer works.  I take this as (VERY) strong evidence that the firmware update is implicated.  However, clearly this is not happening to everyone or there would be a rash of such complaints.

 

I spent several hours with my employer's IT admin going over VPN server logs, and trying various things.  Logs show I am able to connect , but that the authentication exchange is unable to complete.  Error messages at both ends suggest that the most likely cause is some device on the route not passing GRE through.  The 3801HGV admin is fairly locked down, and does not allow you to directly see which protocols it passes through (there is a list of protocol names, but neither GRE nor PPTP appear, however 'other protocols' IS enabled).

 

Confusing matters further - I have another VPN to a customer which DOES still work (from the same computer as the one to my employer that fails).  Its client configuration (apart from IP address of course) is identical to the one that does not (PPTP, max encryption, IPV4 only, ...).

 

We then installed WireShark to take a closer look at what was going on, but this didn't really clarify much.  The attempted connection to my employer fails prior to attempting any GRE activity.  The successful attempt to the customer shows GRE activity working just fine (so we can rule out any absolute block of GRE in the gateway router).

 

We then attempted a connection to another of my employer's offices, which uses a slightly different version of the VPN server (which is a Windows RAS server running on Windows Server 2008 at one office, Windows Server 2003 at the other).  It failed in the same manner.

 

I also configured the VPN on my laptop (Windows 7) and verified that it too failed the same way (it does).  However, if I take it down the street to a friend who has a different ISP (TWC), it works fine without any configuration changes.

 

So here is what we know:

 

1) PPTP VPN connections to either of my employer's offices fail over the ATT gateway with latest firmware (6.11.1.29-enh.tm)

2) The same connection suceeded with the previous firmware prior to last Wednesday on an older gateway (3800HGV-B).  I do not know what that firmware rev. was

3) The same connection suceeded with the factory-shipped firmware on the newer gateway (HGV3801HGV).  I didn't think to look at the firmware version in the 5 minutes I turned out to have before it self-destructed

4) Apparently identically configured VPNs do not fail to a customer VPN (server unknown, but same protocol)

 

Conclusion - there is some interaction between the latest firmware and something about the VPN, which looks like it must be server-dependent (not just protocol dependent)

 

Ideally I'd like ATT to wind back my firmware, as we seem to have run out of other options.  Does anyone have any suggestions to offer?

For several years now, I have been using a PPTP VPN to access my work from home via my UVerse connection.  This just uses the standard WIndows built-in PPTP client (Windows 7 and Windows 8 currently in use here).

 

Last Wednesday night my router was reset from ATT's end, to push new firmware, and since then I have been unable to establish the VPN.  I have had 5 chats with online support, and three sessions with ConnecTech (escalating to tier 3 there).  Nobody was able to resolve the issue or see anything wrong with the gateway configuration, so eventually they decided to send me a new gateway as mine was a bit old (3800HGV-B).

 

Yesterday the new gateway unit arrived (3801HGV), so I connected it, and as soon as internet connecivity was verified attempted to connect the VPN.  This worked!

 

Five minutes later the router was reset from the ATT end and had its firmware updated.  The VPN no longer works.  I take this as (VERY) strong evidence that the firmware update is implicated.  However, clearly this is not happening to everyone or there would be a rash of such complaints.

 

I spent several hours with my employer's IT admin going over VPN server logs, and trying various things.  Logs show I am able to connect , but that the authentication exchange is unable to complete.  Error messages at both ends suggest that the most likely cause is some device on the route not passing GRE through.  The 3801HGV admin is fairly locked down, and does not allow you to directly see which protocols it passes through (there is a list of protocol names, but neither GRE nor PPTP appear, however 'other protocols' IS enabled).

 

Confusing matters further - I have another VPN to a customer which DOES still work (from the same computer as the one to my employer that fails).  Its client configuration (apart from IP address of course) is identical to the one that does not (PPTP, max encryption, IPV4 only, ...).

 

We then installed WireShark to take a closer look at what was going on, but this didn't really clarify much.  The attempted connection to my employer fails prior to attempting any GRE activity.  The successful attempt to the customer shows GRE activity working just fine (so we can rule out any absolute block of GRE in the gateway router).

 

We then attempted a connection to another of my employer's offices, which uses a slightly different version of the VPN server (which is a Windows RAS server running on Windows Server 2008 at one office, Windows Server 2003 at the other).  It failed in the same manner.

 

I also configured the VPN on my laptop (Windows 7) and verified that it too failed the same way (it does).  However, if I take it down the street to a friend who has a different ISP (TWC), it works fine without any configuration changes.

 

So here is what we know:

 

1) PPTP VPN connections to either of my employer's offices fail over the ATT gateway with latest firmware (6.11.1.29-enh.tm)

2) The same connection suceeded with the previous firmware prior to last Wednesday on an older gateway (3800HGV-B).  I do not know what that firmware rev. was

3) The same connection suceeded with the factory-shipped firmware on the newer gateway (HGV3801HGV).  I didn't think to look at the firmware version in the 5 minutes I turned out to have before it self-destructed

4) Apparently identically configured VPNs do not fail to a customer VPN (server unknown, but same protocol)

 

Conclusion - there is some interaction between the latest firmware and something about the VPN, which looks like it must be server-dependent (not just protocol dependent)

 

Ideally I'd like ATT to wind back my firmware, as we seem to have run out of other options.  Does anyone have any suggestions to offer?

VPN problems since Gateway firmware update

1,169 views
7 replies
(1) Me too
(1) Me too
Reply
View all replies
(7)
0
(0)
  • Rate this reply
View profile
Jul 15, 2014 11:10:26 PM
0
(0)
ACE - Expert

No way to keep the old software as the next download would wipe it out again.  It would be automatic as you had the old software.

 

Check this support page from 2-wire/Pace on VPN:

http://support.2wire.com/?page=view&article=20&text=VPN&cat=&sort=

 

If that does not help. Contact ATT Uverse Care here:
https://forums.att.com/t5/notes/privatenotespage/tab/compose/note-to-user-id/2365485

Send them a private message, on this link, and they should be able to give the help needed to solve your Uverse VPN service problems. They are available M-F 8am-11pm Eastern time, response may take up to 2 business days.

This is not the regular CS/TS people, but the social media Community Specialists that know the people to contact to get things done. I personally know as they've helped me on a DVR swap.

Include your account#, email address and a good phone # (land or cell) and time to contact you on.

Check for the blue PM envelope to appear, upper right on every page, for their reply.

 

Good luck Smiley Wink

 

Chris

_____________________________________________

Please NO SD stretch-o-vision or 480 SD HD Channels
Need Help? PM ATT Uverse Care (all service problems)
or ATT Customer Care (all other problems)

Your Results May Vary, In My Humble Opinion
I Call It Like I See It, Simply a U-verse user, nothing more

No way to keep the old software as the next download would wipe it out again.  It would be automatic as you had the old software.

 

Check this support page from 2-wire/Pace on VPN:

http://support.2wire.com/?page=view&article=20&text=VPN&cat=&sort=

 

If that does not help. Contact ATT Uverse Care here:
https://forums.att.com/t5/notes/privatenotespage/tab/compose/note-to-user-id/2365485

Send them a private message, on this link, and they should be able to give the help needed to solve your Uverse VPN service problems. They are available M-F 8am-11pm Eastern time, response may take up to 2 business days.

This is not the regular CS/TS people, but the social media Community Specialists that know the people to contact to get things done. I personally know as they've helped me on a DVR swap.

Include your account#, email address and a good phone # (land or cell) and time to contact you on.

Check for the blue PM envelope to appear, upper right on every page, for their reply.

 

Good luck Smiley Wink

 

Chris

_____________________________________________

Please NO SD stretch-o-vision or 480 SD HD Channels
Need Help? PM ATT Uverse Care (all service problems)
or ATT Customer Care (all other problems)

Your Results May Vary, In My Humble Opinion
I Call It Like I See It, Simply a U-verse user, nothing more

*The views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.

Re: VPN problems since Gateway firmware update

2 of 8 (1,148 Views)
0
(0)
  • Rate this reply
View profile
Jul 16, 2014 6:41:03 AM
0
(0)
Contributor

I have contacted ATTU-verseCare as you suggested, with a full history and details.

 

Meanwhile I did one further experiment, which was to (temporarily) place my desktop in the residential gateway's DMZ.  Even in this environment it still blocks the VPN, which suggesst that the firmware update impacted something at quite a low level (in the router itelf rather then the firewall perhaps).  This rules out the possibility of hanging my own router off the gateway's DMZ and connecting through that.

I have contacted ATTU-verseCare as you suggested, with a full history and details.

 

Meanwhile I did one further experiment, which was to (temporarily) place my desktop in the residential gateway's DMZ.  Even in this environment it still blocks the VPN, which suggesst that the firmware update impacted something at quite a low level (in the router itelf rather then the firewall perhaps).  This rules out the possibility of hanging my own router off the gateway's DMZ and connecting through that.

Re: VPN problems since Gateway firmware update

3 of 8 (1,125 Views)
0
(0)
  • Rate this reply
View profile
Jul 23, 2014 5:12:55 AM
0
(0)
Contributor

Status update - no resolution so far, but we've managed to work around the issu by now by having my employer instatiate a second VPN that uses different protocols.  Still unable to connct to the PPTP one.

Status update - no resolution so far, but we've managed to work around the issu by now by having my employer instatiate a second VPN that uses different protocols.  Still unable to connct to the PPTP one.

Re: VPN problems since Gateway firmware update

4 of 8 (1,056 Views)
0
(0)
  • Rate this reply
View profile
Jul 23, 2014 6:51:07 AM
0
(0)
Contributor
I'm having similar problems. Not a VPN, but a P2P failure. Another source (EA Games Tech support, Tier 3), said ATT's recent firmware update blocked peer to peer. This makes sense that you would be experiencing issues with PPTP.
I'm having similar problems. Not a VPN, but a P2P failure. Another source (EA Games Tech support, Tier 3), said ATT's recent firmware update blocked peer to peer. This makes sense that you would be experiencing issues with PPTP.

I'm having similar problems. Not a VPN, but a P2P failure...

5 of 8 (1,042 Views)
0
(0)
  • Rate this reply
View profile
Nov 3, 2014 4:34:45 PM
0
(0)
Voyager
Edited by SonyFocus on Nov 3, 2014 at 4:35:47 PM

Hello!  Did you ever receive any further resolution to this problem?  I have been experiencing the exact same issue for about the same time period with the exact same configuration.  I have not spent much time trying to resolve it because I haven't needed to access it as much lately.  When I do need to conntect to the VPN I just use my Verizon Wireless broadband which connects effortlessly.  However, I am annoyed that I can't connect from home and would like to see a resolution.  I figured that the usual tech support would not be much help.  I have been searching for an answer since the problem occured but didn't find anything specific to this issue until today.  I too was suprised there was not more of an uproar if it is a wider issue.  Appreciate any further insight!  Thanks!

Hello!  Did you ever receive any further resolution to this problem?  I have been experiencing the exact same issue for about the same time period with the exact same configuration.  I have not spent much time trying to resolve it because I haven't needed to access it as much lately.  When I do need to conntect to the VPN I just use my Verizon Wireless broadband which connects effortlessly.  However, I am annoyed that I can't connect from home and would like to see a resolution.  I figured that the usual tech support would not be much help.  I have been searching for an answer since the problem occured but didn't find anything specific to this issue until today.  I too was suprised there was not more of an uproar if it is a wider issue.  Appreciate any further insight!  Thanks!

Re: VPN problems since Gateway firmware update

[ Edited ]
6 of 8 (881 Views)
0
(0)
  • Rate this reply
View profile
Nov 4, 2014 10:49:58 AM
0
(0)
Community Support

Hi @SonyFocus,

 

We have received your message and look forward to working with you to get this issue resolved.

 

-David T

Need more help?

Download the myAT&T App and click Fix It Now! Support Tools to get U-verse help. For more assistance, send a quick message to ATTU-verseCare. Be sure to include your account number, name, and contact number.

Hi @SonyFocus,

 

We have received your message and look forward to working with you to get this issue resolved.

 

-David T

Need more help?

Download the myAT&T App and click Fix It Now! Support Tools to get U-verse help. For more assistance, send a quick message to ATTU-verseCare. Be sure to include your account number, name, and contact number.
*I am an AT&T employee and the postings on this site are my own and don’t necessarily represent AT&T’s position, strategies or opinions.

Re: VPN problems since Gateway firmware update

7 of 8 (851 Views)
0
(0)
  • Rate this reply
View profile
Nov 17, 2015 4:44:49 PM
0
(0)
Tutor

I have the same problem. How did you fix it?
I've tried dmz mode/firewall disabled and still cant connect through PPTP to our office.VPN works on all other internet providers.

3801HGV
Hardware Version 000778-004
Software Version 6.11.1.29-enh.tm

I have the same problem. How did you fix it?
I've tried dmz mode/firewall disabled and still cant connect through PPTP to our office.VPN works on all other internet providers.

3801HGV
Hardware Version 000778-004
Software Version 6.11.1.29-enh.tm

Re: VPN problems since Gateway firmware update

8 of 8 (315 Views)
Share this post
Share this post