U-verse Forums

Reply
Posted Jan 27, 2013
10:58:51 PM
View profile
Computers and NAS don't communicate with each other at gigabit speed
Edited by cathy2981 on Jan 28, 2013 at 2:13:07 PM

I have a 2Wire 3800HGV-B Gateway. I have attached to it via a lan port, a Netgear GS605v3 gigabit switch. The switch is connected to 3 computers and a NAS. Everything works except the computers and NAS don't communicate with each other at gigabit speed. Is there a way to configure my system so the computers and the NAS communicate with each other at gigabit speed? or do I need to buy a gigabit router and configure it as suggested in post #2? TIA

I have a 2Wire 3800HGV-B Gateway. I have attached to it via a lan port, a Netgear GS605v3 gigabit switch. The switch is connected to 3 computers and a NAS. Everything works except the computers and NAS don't communicate with each other at gigabit speed. Is there a way to configure my system so the computers and the NAS communicate with each other at gigabit speed? or do I need to buy a gigabit router and configure it as suggested in post #2? TIA

0
(0)
  • Rate this reply
View profile
Solved
Jan 28, 2013 6:53:30 PM
0
(0)
ACE - Master

gh2013 wrote:

..  As you know a switch is a dumb device. Once it is connected to 2Wire gateway, it recieves ip addresses from 2Wire and acts as an extension of the 2wire....


Switches are not dumb devices.  They make decisions about what to do with packets, etc.  They operate at level 2 of the TCP/IP stack, vs level 3 where a router operates.  If you have a group of TCP/IP node on the same subnet on the same physical LAN, then once they've found each other via ARP, there is no more routing going on, the nodes communicate directly to each other using MAC addresses, which the switch handles putting out on the right ports.


This is unlike a hub, which is indeed a dumb device.  It repeats everything it hears on any port out all ports.

 

Connecting to the 2WIRE should not be changing your speed equation, especially not so dramatically.  Something is missing from this picture.


What other devices do you have in your network?

 

*The views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.
Accepted Solution

Computers and NAS don't communicate with each other at gigabit speed

[ Edited ]
859 views
4 replies
(0) Me too
(0) Me too
Post reply
Cancel
Submit
Replies
(4)
0
(0)
  • Rate this reply
View profile
Jan 28, 2013 1:32:20 PM
0
(0)
ACE - Master
Edited by cathy2981 on Jan 28, 2013 at 2:13:24 PM

If the NAS and all the computers:

  • all have gigabit ethernet ports,
  • are directly connected to a gigabit switch,
  • using CAT 5e or better cabling, and
  • are configured in the same IP subnet,

then they should be able to communicate at Gigabit speeds.  Check each computer's adapter to confirm the Gigabit connection.  The NAS appliance should have some way to check that too.  There may also be indicators on your switch that the connection is Gigabit.

 

So... how do you know they're not communicating a gigabit speeds?  If you're checking via transfer rate, is it better than 100 Mbps, just not close enough to 1000 Mbps for your liking?

 

If the NAS and all the computers:

  • all have gigabit ethernet ports,
  • are directly connected to a gigabit switch,
  • using CAT 5e or better cabling, and
  • are configured in the same IP subnet,

then they should be able to communicate at Gigabit speeds.  Check each computer's adapter to confirm the Gigabit connection.  The NAS appliance should have some way to check that too.  There may also be indicators on your switch that the connection is Gigabit.

 

So... how do you know they're not communicating a gigabit speeds?  If you're checking via transfer rate, is it better than 100 Mbps, just not close enough to 1000 Mbps for your liking?

 

*The views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.

Re: Computers and NAS don't communicate with each other at gigabit speed

[ Edited ]
2 of 5 (824 Views)
0
(0)
  • Rate this reply
View profile
Jan 28, 2013 2:57:50 PM
0
(0)
Contributor

All computers have gigabit ethernet cards. The NAS is a Seagate Backarmor, it also has a gigabit port. All cables ate cat6, non longer than 6 feet. Windows 7 reports a gigbit connection on all computers.  As you know a switch is a dumb device. Once it is connected to 2Wire gateway, it recieves ip addresses from 2Wire and acts as an extension of the 2wire. If I discounect the Netgear switch and manually assign an ip address to the nas and the computers, then they work at gigabit speed (about 60MB/s vs about 15MB/s if they are connected to 2wire gateway). Now if I connect the switch back to the gateway with all devices having manually assigned ip addresses then I don't get interenet access on computers. So I am wondering if I need to buy a gigabit router and follow the insrtuction that "SomeJoe" suggested or if there is a way for the switch to work with 2wire and all the gigabit devices behind it communicate with each other at gigabit speed. TIA

All computers have gigabit ethernet cards. The NAS is a Seagate Backarmor, it also has a gigabit port. All cables ate cat6, non longer than 6 feet. Windows 7 reports a gigbit connection on all computers.  As you know a switch is a dumb device. Once it is connected to 2Wire gateway, it recieves ip addresses from 2Wire and acts as an extension of the 2wire. If I discounect the Netgear switch and manually assign an ip address to the nas and the computers, then they work at gigabit speed (about 60MB/s vs about 15MB/s if they are connected to 2wire gateway). Now if I connect the switch back to the gateway with all devices having manually assigned ip addresses then I don't get interenet access on computers. So I am wondering if I need to buy a gigabit router and follow the insrtuction that "SomeJoe" suggested or if there is a way for the switch to work with 2wire and all the gigabit devices behind it communicate with each other at gigabit speed. TIA

Re: Computers and NAS don't communicate with each other at gigabit speed

3 of 5 (782 Views)
0
(0)
  • Rate this reply
View profile
Jan 28, 2013 5:04:15 PM
0
(0)
Professor
If your ethernet wiring was done correctly, and using known good patch cords, the switch is something like Netgear's GS series, you should not be having a problem.

Try powering down everything and rebooting to see if the NAS works. Now of course, there is no problem with assigning a Static IP to the NAS, even though the RG's use a sticky DHCP Ip scheme.
________________________________________________________________

"Ren: Now listen, Cadet. I've got a job for you. See this button? Don't touch it! It's the History Eraser button, you fool!

Stimpy: So what'll happen?

Ren: That's just it. We don't know. Maybe something bad, maybe something good. I guess we'll never know, 'cause you're going to guard it. You won't touch it, will you?"
________________________________________________________________
If your ethernet wiring was done correctly, and using known good patch cords, the switch is something like Netgear's GS series, you should not be having a problem.

Try powering down everything and rebooting to see if the NAS works. Now of course, there is no problem with assigning a Static IP to the NAS, even though the RG's use a sticky DHCP Ip scheme.
________________________________________________________________

"Ren: Now listen, Cadet. I've got a job for you. See this button? Don't touch it! It's the History Eraser button, you fool!

Stimpy: So what'll happen?

Ren: That's just it. We don't know. Maybe something bad, maybe something good. I guess we'll never know, 'cause you're going to guard it. You won't touch it, will you?"
________________________________________________________________

Re: Computers and NAS don't communicate with each other at gigabit speed

4 of 5 (757 Views)
0
(0)
  • Rate this reply
View profile
Solved
Jan 28, 2013 6:53:30 PM
0
(0)
ACE - Master

gh2013 wrote:

..  As you know a switch is a dumb device. Once it is connected to 2Wire gateway, it recieves ip addresses from 2Wire and acts as an extension of the 2wire....


Switches are not dumb devices.  They make decisions about what to do with packets, etc.  They operate at level 2 of the TCP/IP stack, vs level 3 where a router operates.  If you have a group of TCP/IP node on the same subnet on the same physical LAN, then once they've found each other via ARP, there is no more routing going on, the nodes communicate directly to each other using MAC addresses, which the switch handles putting out on the right ports.


This is unlike a hub, which is indeed a dumb device.  It repeats everything it hears on any port out all ports.

 

Connecting to the 2WIRE should not be changing your speed equation, especially not so dramatically.  Something is missing from this picture.


What other devices do you have in your network?

 


gh2013 wrote:

..  As you know a switch is a dumb device. Once it is connected to 2Wire gateway, it recieves ip addresses from 2Wire and acts as an extension of the 2wire....


Switches are not dumb devices.  They make decisions about what to do with packets, etc.  They operate at level 2 of the TCP/IP stack, vs level 3 where a router operates.  If you have a group of TCP/IP node on the same subnet on the same physical LAN, then once they've found each other via ARP, there is no more routing going on, the nodes communicate directly to each other using MAC addresses, which the switch handles putting out on the right ports.


This is unlike a hub, which is indeed a dumb device.  It repeats everything it hears on any port out all ports.

 

Connecting to the 2WIRE should not be changing your speed equation, especially not so dramatically.  Something is missing from this picture.


What other devices do you have in your network?

 

*The views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.

Re: Computers and NAS don't communicate with each other at gigabit speed

5 of 5 (740 Views)
Solution
Share this post
Share this post