Sony Ericsson z310a "Blue Flashing LED's of Death"

Contributor

Sony Ericsson z310a "Blue Flashing LED's of Death"

I bought my z310a about six months ago and havent had any problems with it till yesterday. I was walking back from class and turned my on to make a call and noticed that my phone was just flashing blue. This video better explains the problem http://www.youtube.com/watch?v=lttYI9sqI9E. If anyone can shed some light on this problem i owe you much thanks.
4,570 Views
Message 1 of 6
Highlighted
ACE - Expert

Re: Sony Ericsson z310a "Blue Flashing LED's of Death"


Dr.Tusculum wrote:
I bought my z310a about six months ago and havent had any problems with it till yesterday. I was walking back from class and turned my on to make a call and noticed that my phone was just flashing blue. This video better explains the problem http://www.youtube.com/watch?v=lttYI9sqI9E. If anyone can shed some light on this problem i owe you much thanks.

 

A similar problem dubbed BROD (Blue Ring Of Death) has plagued the SE K850i. The later versions of SEUS fixed BROD through reflashing and the DaVinci Team has always worked as a last resort. The Youtube video you linked to has the following update added:

UPDATE: I have fixed my phone! Basically, remove the battery, connect to the charger, press and hold C while plugging charger into wall, continue holding C while placing battery back into phone. If that doesn't work for you, then flash the phone...or get a new phone.

 

Hope this helps.

*The views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.
Message 2 of 6
Contributor

Re: Sony Ericsson z310a "Blue Flashing LED's of Death"

Cheers mate, Ive tried to use the video descrition fix but didn't have any luck with it. But thanks for the response and info. Smiley Happy
Message 3 of 6
Contributor

Re: Sony Ericsson z310a "Blue Flashing LED's of Death"

Fixed it.
Message 4 of 6
ACE - Expert

Re: Sony Ericsson z310a "Blue Flashing LED's of Death"


Dr.Tusculum wrote:
Fixed it.

 

Glad to hear that — since your previous response indicated the advice in the video didn't help, would you mind telling us what you ended up doing?
*The views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.
Message 5 of 6
Contributor

Re: Sony Ericsson z310a "Blue Flashing LED's of Death"

First of all, this phone is complete garbage. I've gone through three of them so far, with AT&T replacing all but the last one free of charge. That they charged me for the last one when I'd done nothing to it is but one of many reasons I'll be going to Verizon after my contract ends, after renewing three times with AT&T. But anyway, I solved this problem by basically turning off the phone, then turning it back on while holding down the "C" button. I had to do this two or three times, but it worked.

 

As for AT&T and Sony Ericsson phones... suck it. 

Message 6 of 6
You must type a description before you click preview or reply.
Share this topic
Announcements

Are you looking to upgrade and activate your device?

Let us help make Ordering, Upgrading and Activating easy!

Additional Support