Explore & discover

Helpful Links

Trouble Connecting International Roaming

Tutor

Trouble Connecting International Roaming

US resident traveling in New Zealand. Using the international day pass. Using s6 active. The coverage map says I should be fine. My wife's T-mobile phone is having no trouble staying connected to 4g. My phone is either stuck in no service or call only. I have hit some very spotty 4g but it has been very sluggish. I know all my settings are correct.

 

My only question: Is there an apn change I can make that lets my phone use international roaming easier?

3,858 Views
Message 1 of 4
Tutor
Solution
Accepted by topic author
Accepted by lhmiller
‎01-27-2018 5:54 PM

Re: Trouble Connecting International Roaming

The answer turned out to be a combo of clearing cache on the phone and doing a "reset network settings" on phone. Not sure i needed to do the cache clear or not, I just happened to do that before i reset the network settings.  Either way running much better.

 

If you are wondering if you need to change your apn:  if you are running the "ATT nextgenphone" apn you are ready running best option.

Tags (1)
Message 2 of 4
Community Manager

Re: Trouble Connecting International Roaming

Hi @lhmiller

 

Thank you for the update! I think it's a good tip and a good solution. I have an international trip coming up soon myself, so that's good to know!

 

Dmitriy


Rethink Possible


Did a post have a solution that worked for you? Help other people find solutions faster by marking posts that helped you as an "Accepted Solution". Learn about accepted solutions: Learn More.

*I am an AT&T employee, and the postings on this site are my own and don't necessarily represent AT&T's position, strategies or opinions.
Message 3 of 4
Tutor

Re: Trouble Connecting International Roaming

It turned out my previous solution was only temporary, but I did figure out a permanent fix.  I finally figured out there were two different cell services that my phone was trying to connect to while on international roam.  It appears either my phone or ATT in general preferred the service that had spottier coverage. This meant my phone would constantly try to connect to that slower provider instead of the other provider that had 4G coverage everywhere.  So when I was doing the reset and cache clear the phone would initially connect to the stronger of the two providers but then after a short amount of time would switch to what ill call the "prefer provider" even though it could not provide me with 4G.  This caused a very large amount of frustration while trying to navigate the South Island of New Zealand without getting lost.

 

After striking out with tech support I stumbled upon my own fix. My shoehorn fix was to "Disable 2G" which is an option on the S6 Active under "Settings>Connections>Mobile Networks>Disable 2G."  So if the preferred network couldn't give me 4G,  my phone would force a switch to the provider that could get it.  This worked without fail for the remainder of my trip, little over a week and a half. I hope this helps the next frustrated traveler about to spike his phone :-P

Message 4 of 4
Share this topic
Share this topic
Additional Support