Ask a question
Search in U-verse Forums

U-verse Forums

Reply
Posted Aug 23, 2013
3:06:53 PM
How to put the Motorola NVG589 in 'bridge mode' (or as close as you can).
Edited by frostcall on Aug 23, 2013 at 9:13:32 PM

Overview

Most people don't need advanced features that personally owned routers offer and will be just fine using the NVG589 and turning off their personally owned router.  But if you're like me (and I know I am!) then you are probably reading this thread because you have ip cameras, personal clouds, photo servers, guest wifi, VPN's, xbox, QOS settings, et al.  I have an ASUS RT-N66U , a VIP2250, and a wireless reciever with a WAP; but your settings should be similar. 

 

The NVG589 does not have a simple 'Bridge mode' setting so you will need to get into weeds to get this working.  I hope you're ready.

 

First Steps

Make sure you have a laptop or a computer that you can connect directly into the NVG589.

Unplug all ethernet cables from the NVG589 except for the one going into the aforementioned laptop.

Write down the MAC address of your personal router (the WAN MAC address if you see different ones for LAN and WAN)

 

Settings on the NVG589

  • Login to your NVG589 by going to 192.168.1.254
  • Go to 'Home Network' then 'Subnets & DHCP'.  Your password is on the side of the modem.
  • If your 'Device IPv4 Address' is the same subnet as your local router, I suggest changing it.  I changed mine to 192.169.2.254 but you can stick with whatever you like / need.  My subnet Mask remains at 255.255.255.0
  • Change 'DHCPv4 Start Address' to 192.169.2.1 (or whatever your above Device IPv4 address is but with a 1 at the end instead of .254)
  • Change 'DHCPv4 End Address' to 192.169.2.5, Just a few more than the Start Address.  We need these for any WAP extenders for wifi TV's.  It's important that you only have the laptop plugged into the ethernet at this point.
  • Click 'SAVE' at the bottom.
  • Go to 'Home Network'  then 'Wireless' and turn wireless off.  You want to use the wifi on your own router right?
  • Go to 'Firewall' then ' 'Packet Filter'.  Disable Packet Filters.  Again, we want our router to do the work.
  • Make sure you don't have any of your own settings turned on in 'NAT/Gaming' (don't worry if you see 1 in there already that you can't delete).
  • Go to 'Firewall' then 'IP Passthrough'.  For 'Default Server Internal Address', select or type in 192.169.2.1.
  • For 'Allocation Mode' select 'Passthrough' (I had to do it in this reverse order to be able to type for some reason)
  • For 'Passthrough Mode', select 'DHCPS-Fixed'
  • Type in the MAC address for your router under 'Manual Entry', lowercase is fine.
  • Click SAVE.  It will tell you that it needs to reboot.  Hang on for a minute.
  • Go to 'Firewall Advanced' at the top and turn everything OFF.
  • Near the top of your screen, you should see an option telling you to reboot the router. Go ahead and do this now. It takes about 2 minutes.

Personal Router Settings.

 

  • Unplug your laptop and plug in your personal router while the NVG589 reboots.  
  • Plug your laptop into your personal router and login to it.  For me, it was 192.168.1.1 (hence why I changed things above)
  • For the ASUS RT-N66U, I had to go to my WAN settings, then 'Internet Connection'.
  • Change 'WAN Connection Type' to 'Automatic IP'.  This will give your personal router the external IP of the NVG589 and is the key to making this whole thing work. Some folks will have to manually enter in an IP and this can be found under the 'Broadband - Status' section of the NVG589 settings.  If you don't have 'automatic IP' then I feel bad for you since you will have to manually change this every time your IP changes.
  • 'Enable WAN', 'Enable NAT' and 'Enable UPnP' is all set to YES for me.  
  • I recomend Setting your own DNS server.  I use Google's but you use whatever you like.  Google's is 8.8.8.8 and 8.8.4.4
  • 'Account Setting - Authentication' is 'None'.
  • There are no Special requirements from ISP at the bottom.
  • Hit APPLY at the bottom and your router will reboot.

I also changed settings in my IPTV under LAN:

  • Profile was None.
  • Choose IPTV STB port, I set to LAN3 & LAN4.  I plugged my U-Verse WAP for the wireless reciver into the NVG589 and I plugged the ethernet cable going to the VIP2250 into LAN3 on my personal router.  I'm really not sure if this was necessary but I'm having 0 issues with this setup.  I initially tried putting the WAP on my personal router but had issues so I stuck it back on the NVG589 and it's fine.  I could probably just plug the VIP2250 into the NVG589 as well but I'm just enjoying the small victory of using my personal router for now.  
  • Hit apply at the bottom, another possible reboot.

At this point, I checked the internet and everything was working great through the router.  I restarted by 2 TV boxes (the VIP and the wifi ones).  Everything is peachy.

 

Your mileage may vary.  Good luck.

 

 

 

 EDIT to update WAP configuration. 

 

Overview

Most people don't need advanced features that personally owned routers offer and will be just fine using the NVG589 and turning off their personally owned router.  But if you're like me (and I know I am!) then you are probably reading this thread because you have ip cameras, personal clouds, photo servers, guest wifi, VPN's, xbox, QOS settings, et al.  I have an ASUS RT-N66U , a VIP2250, and a wireless reciever with a WAP; but your settings should be similar. 

 

The NVG589 does not have a simple 'Bridge mode' setting so you will need to get into weeds to get this working.  I hope you're ready.

 

First Steps

Make sure you have a laptop or a computer that you can connect directly into the NVG589.

Unplug all ethernet cables from the NVG589 except for the one going into the aforementioned laptop.

Write down the MAC address of your personal router (the WAN MAC address if you see different ones for LAN and WAN)

 

Settings on the NVG589

  • Login to your NVG589 by going to 192.168.1.254
  • Go to 'Home Network' then 'Subnets & DHCP'.  Your password is on the side of the modem.
  • If your 'Device IPv4 Address' is the same subnet as your local router, I suggest changing it.  I changed mine to 192.169.2.254 but you can stick with whatever you like / need.  My subnet Mask remains at 255.255.255.0
  • Change 'DHCPv4 Start Address' to 192.169.2.1 (or whatever your above Device IPv4 address is but with a 1 at the end instead of .254)
  • Change 'DHCPv4 End Address' to 192.169.2.5, Just a few more than the Start Address.  We need these for any WAP extenders for wifi TV's.  It's important that you only have the laptop plugged into the ethernet at this point.
  • Click 'SAVE' at the bottom.
  • Go to 'Home Network'  then 'Wireless' and turn wireless off.  You want to use the wifi on your own router right?
  • Go to 'Firewall' then ' 'Packet Filter'.  Disable Packet Filters.  Again, we want our router to do the work.
  • Make sure you don't have any of your own settings turned on in 'NAT/Gaming' (don't worry if you see 1 in there already that you can't delete).
  • Go to 'Firewall' then 'IP Passthrough'.  For 'Default Server Internal Address', select or type in 192.169.2.1.
  • For 'Allocation Mode' select 'Passthrough' (I had to do it in this reverse order to be able to type for some reason)
  • For 'Passthrough Mode', select 'DHCPS-Fixed'
  • Type in the MAC address for your router under 'Manual Entry', lowercase is fine.
  • Click SAVE.  It will tell you that it needs to reboot.  Hang on for a minute.
  • Go to 'Firewall Advanced' at the top and turn everything OFF.
  • Near the top of your screen, you should see an option telling you to reboot the router. Go ahead and do this now. It takes about 2 minutes.

Personal Router Settings.

 

  • Unplug your laptop and plug in your personal router while the NVG589 reboots.  
  • Plug your laptop into your personal router and login to it.  For me, it was 192.168.1.1 (hence why I changed things above)
  • For the ASUS RT-N66U, I had to go to my WAN settings, then 'Internet Connection'.
  • Change 'WAN Connection Type' to 'Automatic IP'.  This will give your personal router the external IP of the NVG589 and is the key to making this whole thing work. Some folks will have to manually enter in an IP and this can be found under the 'Broadband - Status' section of the NVG589 settings.  If you don't have 'automatic IP' then I feel bad for you since you will have to manually change this every time your IP changes.
  • 'Enable WAN', 'Enable NAT' and 'Enable UPnP' is all set to YES for me.  
  • I recomend Setting your own DNS server.  I use Google's but you use whatever you like.  Google's is 8.8.8.8 and 8.8.4.4
  • 'Account Setting - Authentication' is 'None'.
  • There are no Special requirements from ISP at the bottom.
  • Hit APPLY at the bottom and your router will reboot.

I also changed settings in my IPTV under LAN:

  • Profile was None.
  • Choose IPTV STB port, I set to LAN3 & LAN4.  I plugged my U-Verse WAP for the wireless reciver into the NVG589 and I plugged the ethernet cable going to the VIP2250 into LAN3 on my personal router.  I'm really not sure if this was necessary but I'm having 0 issues with this setup.  I initially tried putting the WAP on my personal router but had issues so I stuck it back on the NVG589 and it's fine.  I could probably just plug the VIP2250 into the NVG589 as well but I'm just enjoying the small victory of using my personal router for now.  
  • Hit apply at the bottom, another possible reboot.

At this point, I checked the internet and everything was working great through the router.  I restarted by 2 TV boxes (the VIP and the wifi ones).  Everything is peachy.

 

Your mileage may vary.  Good luck.

 

 

 

 EDIT to update WAP configuration. 

 

5
(2)
  • Rate this reply
View profile
Solved
Oct 9, 2013 1:40:17 PM
5
(2)
Employee

 

a couple of notes I would like to make on this. for the most part it's correct.

 

Bullet 1.) 192.169.2.254-

 

would not change it outside the 192.168.x.x class network specification. Doing this can cause some connectivity , DNS, and routing problems going outside the class. 

 

Example (and yes I did this once!)--

 

I changed my base IP address to 135.153.1.1 as well as changed everything else. Everything worked ok till I do a traceroute or a path ping. This problem was really pervasive when on my iphone, speed tests would be way, way off, and wireless would sometimes have problems connecting. many times the first hop which should be my router didn't resolve properly and I also created other DNS problems (page can't be displayed, etc...) For this example I would stay within the confines of the wikipedia entry for private network. 

 

 

http://en.wikipedia.org/wiki/Private_network

 

it states

24-bit block

10.0.0.0 - 10.255.255.255 16,777,216
single class A network
10.0.0.0/8 (255.0.0.0)
24 bits
8 bits


20-bit block
172.16.0.0 - 172.31.255.255 1,048,576
16 contiguous class B networks 172.16.0.0/12 (255.240.0.0)
20 bits 12 bits

of course the common block everyone with a router uses.


16-bit block
192.168.0.0 - 192.168.255.255
65,536
256 contiguous class C networks 192.168.0.0/16 (255.255.0.0)
16 bits 16 bits


In this addendum I would say use
192.168.2.254 or 192.168.168.10.254

172.16.0.1 or 172.17.0.1

10.20.1.1 or 10.30.1.1

 

Either or would be fine.

 

Avoid the headache I created and stay within a private network setting. most DNS boxes already know what the private networks are. If you stay within the confines of them you are not adding frustration to your cause.

 

 

 

 

bullet 3 to bullet 5.) a tweak of subnets and IP's

 

Now you can leave this at 255.255.255.0 /24 (default) which would give you 254 Ip addresses on that NVG589 to use. however if you are not going to use them just eliminate them. Much less work on broadcasting that the router will have to do. Since you are passing the IP right to your router anyway save the work for the router behind.

for instance if you want a shorter range

255.255.255.240 would allow 14 IP addresses total this can also known as 255.255.255.240 /28

255.255.255.224 /27 This would allow 30 IP addresses total


what you essentially do is cut down on how many hosts you actually have. Essentually you are making the NVG (as well as any router made by any manufacturer) smarter buy giving it a short phone book to work with.

 

An example below for the NVG589

device IPv4 address: 172.21.0.1
DHCPv4 start IP address: 172.21.0.7
DHCPv4 end IP address: 172.21.0.14
Subnet mask: 255.255.255.240

 

DHCP addresses available: 8

Static IP's available: 5

 


Another example I would use

device IPv4 address: 10.20.1.1
DHCPv4 start IP address: 10.20.1.5
DHCPv4 end IP address: 10.20.1.30
Subnet mask: 255.255.255.224

 

DHCP addresses avaialble: 25

static IP addresses available: 4

 


Another example using 192.168.x.x

Device IPv4 address: 192.168.15.1
DHCPv4 start IP address: 192.168.15.5
DHCPv4 end IP address: 192.168.15.30
Subnet mask: 255.255.255.224

 

DHCP addresses avaialble: 25

static IP addresses available: 4

 

Note: I do not count the base IP address as a useable IP (another headache I learned to avoid the hard way).  

 

 

Continue on: 

 

From the bullet point of

 

  • Go to 'Home Network' then 'Wireless' and turn wireless off. You want to use the wifi on your own router right?

I would continue on.

 

 

Final note: 

 

I don't get here all the time to check and see who replied so if there is any questions please drop me a line as I don't come here very often. 

 

Thanks

david

 

 

 

 

*I am an AT&T employee and the postings on this site are my own and don’t necessarily represent AT&T’s position, strategies or opinions.
Accepted Solution

How to put the Motorola NVG589 in 'bridge mode' (or as close as you can).

[ Edited ]
286,790 views
241 replies
(15) Me too
(15) Me too
Reply
View all replies
(241)
0
(0)
  • Rate this reply
View profile
Feb 5, 2014 6:18:00 PM
0
(0)
Tutor

First of all... I also want to thank you for the directions!

 

Following the instructions worked fine except for:

 

  • Go to 'Firewall' then 'IP Passthrough'.  For 'Default Server Internal Address', select or type in 192.169.2.1.
  • For 'Allocation Mode' select 'Passthrough' (I had to do it in this reverse order to be able to type for some reason)
  • For 'Passthrough Mode', select 'DHCPS-Fixed'
  • Type in the MAC address for your router under 'Manual Entry', lowercase is fine.

On my NVG589 gateway the field for the Default Server Internal Address is "greyed out" and not editable. I tried various combinations with the Allocation Mode but nothing seemed to open the field. I could set all other fields.

 

I did continue with the instructions through the local router and, so far, it seems I do get internet through my ASUS RT-N66W. I suppose I'm trying to find out how critical setting the Default Server Internal Address is.

 

One other thing... I set the Device IPv4 Address as 192.168.2.254 not 192.169.2.254 as stated in the instructions.

 

Any suggestions? Thanks again for the help!

First of all... I also want to thank you for the directions!

 

Following the instructions worked fine except for:

 

  • Go to 'Firewall' then 'IP Passthrough'.  For 'Default Server Internal Address', select or type in 192.169.2.1.
  • For 'Allocation Mode' select 'Passthrough' (I had to do it in this reverse order to be able to type for some reason)
  • For 'Passthrough Mode', select 'DHCPS-Fixed'
  • Type in the MAC address for your router under 'Manual Entry', lowercase is fine.

On my NVG589 gateway the field for the Default Server Internal Address is "greyed out" and not editable. I tried various combinations with the Allocation Mode but nothing seemed to open the field. I could set all other fields.

 

I did continue with the instructions through the local router and, so far, it seems I do get internet through my ASUS RT-N66W. I suppose I'm trying to find out how critical setting the Default Server Internal Address is.

 

One other thing... I set the Device IPv4 Address as 192.168.2.254 not 192.169.2.254 as stated in the instructions.

 

Any suggestions? Thanks again for the help!

Re: How to put the Motorola NVG589 in 'bridge mode' (or as close as you can).

31 of 242 (75,189 Views)
0
(0)
  • Rate this reply
View profile
Feb 7, 2014 7:59:58 PM
0
(0)
Voyager

I'm in same boat. That box is greyed out. 

 

Suggesitons?

I'm in same boat. That box is greyed out. 

 

Suggesitons?

Re: How to put the Motorola NVG589 in 'bridge mode' (or as close as you can).

32 of 242 (75,125 Views)
0
(0)
  • Rate this reply
View profile
Feb 21, 2014 6:29:08 PM
0
(0)
Contributor

Great explanation and I believe I setup my system in this manner, but I can not get to certain ports from the outside.  If I go to canuseeme.org, it shows my IP as what I set my server to, great.

 

But, if I try the port my web server is on, it does not work.  This leads me to think that the RG router is blocking this.  I thought that the static IP would have full access to all ports and not be blocked, or rather, the port is in use due to the RG - which uses 80 and 443.

 

So the question is, if I get static IP's and do this setup, am I in the same position as port-forwarding from the base RG router, or how do I get to my ports and/or do I need to setup my own router on this public IP and then I am good to go ?

 

Thanks !

 

Great explanation and I believe I setup my system in this manner, but I can not get to certain ports from the outside.  If I go to canuseeme.org, it shows my IP as what I set my server to, great.

 

But, if I try the port my web server is on, it does not work.  This leads me to think that the RG router is blocking this.  I thought that the static IP would have full access to all ports and not be blocked, or rather, the port is in use due to the RG - which uses 80 and 443.

 

So the question is, if I get static IP's and do this setup, am I in the same position as port-forwarding from the base RG router, or how do I get to my ports and/or do I need to setup my own router on this public IP and then I am good to go ?

 

Thanks !

 

Re: How to put the Motorola NVG589 in 'bridge mode' (or as close as you can).

33 of 242 (74,949 Views)
0
(0)
  • Rate this reply
View profile
Feb 24, 2014 3:35:33 PM
0
(0)
Mentor
Edited by MoInSTL on Feb 24, 2014 at 3:52:17 PM

Mine is also grayed out. I "think'" it takes the settings from Home Network-->Subnets & DHCP-->Private LAN Subnet--->Device IPv4 Address

Are the numbers next to Device IPv4 Address the same as the grayed out box? Mine are the same which led me to think this. It just transfers the numbers over.

Mine is also grayed out. I "think'" it takes the settings from Home Network-->Subnets & DHCP-->Private LAN Subnet--->Device IPv4 Address

Are the numbers next to Device IPv4 Address the same as the grayed out box? Mine are the same which led me to think this. It just transfers the numbers over.

Re: How to put the Motorola NVG589 in 'bridge mode' (or as close as you can).

[ Edited ]
34 of 242 (74,904 Views)
0
(0)
  • Rate this reply
View profile
Mar 3, 2014 8:16:08 PM
0
(0)
Tutor

Hello, I have been researching this for a few weeks now and have read a few threads about it.

»forums.att.com/t5/Features-and-H···7BX-9KSN

»NVG589 & Netgear Router for DLNA

I think I have just enough info to get started. I do want to make sure that I have my ducks in a row.

I know that I want to use the NVG in IP passthrough mode. The router will handle the wifi in my house.

The modem will do all the heavy lifting, I have a Netgear Gigabit switch attached to it for added ports. I will not, as I see it now, need the router to do anything other than broadcast a strong signal.

I was lucky, rehabbing a house to hardwire 13 cat6 drops throughout. I have a patch panel set up in the basement. As I said before, the modem will still do all the heavy lifting, such as Uverse TV and my home server running FreeNAS, all of these will be hardwired via direct connection or patched in.

So, I want the router to handle DHCP allocation for my wireless network, but I want to make sure that anything connected to the wifi will have access to the modem attached network (i.e. the server attached to the modem and network printers and such). 

How does this affect my subnets when I allocate my IP addresses? Don't the modem and the router need to be on the same subnet to communicate?  I need to set it up so that the wireless router can access the hardwired parent network that supplies the wireless router with its signal.  Am I making sense?  I could set it up so that 192.168.1.1 is the IP address for both, which would make the RG UI only accessible via hardwired connection.

Thanks so much for this! Very excited to get this going! Cheers!  I welcome any thougts on this configuration.

Hello, I have been researching this for a few weeks now and have read a few threads about it.

»forums.att.com/t5/Features-and-H···7BX-9KSN

»NVG589 & Netgear Router for DLNA

I think I have just enough info to get started. I do want to make sure that I have my ducks in a row.

I know that I want to use the NVG in IP passthrough mode. The router will handle the wifi in my house.

The modem will do all the heavy lifting, I have a Netgear Gigabit switch attached to it for added ports. I will not, as I see it now, need the router to do anything other than broadcast a strong signal.

I was lucky, rehabbing a house to hardwire 13 cat6 drops throughout. I have a patch panel set up in the basement. As I said before, the modem will still do all the heavy lifting, such as Uverse TV and my home server running FreeNAS, all of these will be hardwired via direct connection or patched in.

So, I want the router to handle DHCP allocation for my wireless network, but I want to make sure that anything connected to the wifi will have access to the modem attached network (i.e. the server attached to the modem and network printers and such). 

How does this affect my subnets when I allocate my IP addresses? Don't the modem and the router need to be on the same subnet to communicate?  I need to set it up so that the wireless router can access the hardwired parent network that supplies the wireless router with its signal.  Am I making sense?  I could set it up so that 192.168.1.1 is the IP address for both, which would make the RG UI only accessible via hardwired connection.

Thanks so much for this! Very excited to get this going! Cheers!  I welcome any thougts on this configuration.

Re: How to put the Motorola NVG589 in 'bridge mode' (or as close as you can).

35 of 242 (74,798 Views)
0
(0)
  • Rate this reply
View profile
Mar 24, 2014 11:43:08 AM
0
(0)
Contributor

excellent and detailed documentation. Followed the same steps but still get the same invalid IP error. And also verified in my asus router that i am getting the public IP address 107.xxx.xxx.xx. any more pointers what is missing here ???

excellent and detailed documentation. Followed the same steps but still get the same invalid IP error. And also verified in my asus router that i am getting the public IP address 107.xxx.xxx.xx. any more pointers what is missing here ???

Re: How to put the Motorola NVG589 in 'bridge mode' (or as close as you can).

36 of 242 (74,580 Views)
0
(0)
  • Rate this reply
View profile
Mar 24, 2014 12:07:59 PM
0
(0)
Mentor
Edited by MoInSTL on Mar 24, 2014 at 12:12:37 PM

Is your router and RG on different IP addresses?  For example: 192.168.1.1, 192.168.2.1?

 

Have you double checked all of the settings in the RG, like wireless, off, firewall off, DHCPS-fixed?

 

If worse comes to worse, do a hard reset of the RG by pressing and holding the red reset button the back until all lights are solid red, It does take some time to come back up and make sure you have only one PC plugged into the back.

 

What device is giving you the error? The RG or your personal router?  Which Asus router do you have? I have the RT-N66U.

 

Have you rebooted the router?

Is your router and RG on different IP addresses?  For example: 192.168.1.1, 192.168.2.1?

 

Have you double checked all of the settings in the RG, like wireless, off, firewall off, DHCPS-fixed?

 

If worse comes to worse, do a hard reset of the RG by pressing and holding the red reset button the back until all lights are solid red, It does take some time to come back up and make sure you have only one PC plugged into the back.

 

What device is giving you the error? The RG or your personal router?  Which Asus router do you have? I have the RT-N66U.

 

Have you rebooted the router?

Re: How to put the Motorola NVG589 in 'bridge mode' (or as close as you can).

[ Edited ]
37 of 242 (74,574 Views)
0
(0)
  • Rate this reply
View profile
Apr 7, 2014 5:08:50 PM
0
(0)
Contributor

So, I just had my old 2Wire replaced with the new NVG589. I had purchased a D-Link DIR-826L and had purchased it for the Wireless N600 dual bands and the Gigabit ports. So, now that the NVG589 has Gigabit ports but only N300, should I just stick with the NVG589 handling everything or pass it all thru to my DIR-826 Router? I've got about 4 Wireless N cameras that of course I wanted to use N signal and the old 2Wire was a B/G, so that's one reason, but now the NVG589 has N. Then with running a DVR Camera System as well as the N Cameras I wanted fast Gigabit speed thruout my network. So, I'm looking for what would be better for me/us?

 

Realized we have tons of Wireless devices these days, so have an XBox, Wii, Cellphones, Streaming devices for Netflix and others, I didn't know if the NVG589 would bottleneck on me to handle about 20 Wirless devices connected to it. So, looking for some help/suggestions. Thanks everyone. 

So, I just had my old 2Wire replaced with the new NVG589. I had purchased a D-Link DIR-826L and had purchased it for the Wireless N600 dual bands and the Gigabit ports. So, now that the NVG589 has Gigabit ports but only N300, should I just stick with the NVG589 handling everything or pass it all thru to my DIR-826 Router? I've got about 4 Wireless N cameras that of course I wanted to use N signal and the old 2Wire was a B/G, so that's one reason, but now the NVG589 has N. Then with running a DVR Camera System as well as the N Cameras I wanted fast Gigabit speed thruout my network. So, I'm looking for what would be better for me/us?

 

Realized we have tons of Wireless devices these days, so have an XBox, Wii, Cellphones, Streaming devices for Netflix and others, I didn't know if the NVG589 would bottleneck on me to handle about 20 Wirless devices connected to it. So, looking for some help/suggestions. Thanks everyone. 

Re: How to put the Motorola NVG589 in 'bridge mode' (or as close as you can).

38 of 242 (74,376 Views)
0
(0)
  • Rate this reply
View profile
Apr 8, 2014 7:07:57 AM
0
(0)
Mentor

Excellent post...thanks.  Stupid question though...I bought an Asus 1750.  I am not sure how to best to physically configure the wires.  Should I plug the Asus into one of the LAN ports on the NVG 589? Or, can I plug the Uverse internet cable coming in from the ONT into the ASUS WAN port and then out from the ASUS LAN port to the WAN port on the NVG?

 

this is important because I really need all 4 ports on the NVG...one for printer, one for DVR, one for wired computer, and one for the wireless TV boxes...Thus, all 4 ports are used and I wouldnt have one available to plug the ASUS into.

Excellent post...thanks.  Stupid question though...I bought an Asus 1750.  I am not sure how to best to physically configure the wires.  Should I plug the Asus into one of the LAN ports on the NVG 589? Or, can I plug the Uverse internet cable coming in from the ONT into the ASUS WAN port and then out from the ASUS LAN port to the WAN port on the NVG?

 

this is important because I really need all 4 ports on the NVG...one for printer, one for DVR, one for wired computer, and one for the wireless TV boxes...Thus, all 4 ports are used and I wouldnt have one available to plug the ASUS into.

Re: How to put the Motorola NVG589 in 'bridge mode' (or as close as you can).

39 of 242 (74,361 Views)
0
(0)
  • Rate this reply
View profile
Apr 11, 2014 11:59:31 AM
0
(0)
Mentor

Forget my previsous question...

 

Anywho, I tried all of the bridging instructions and none of it worked.  The NVG would never let me changed the IP address to anything that any of the posters suggested.  I ended up having to factory reset the NVG to get everything back to normal since all of the settings got jacked up.

 

So, for anyone else, there is another option...I simply plugged the router into one of the LAN ports on the NVG and it works fine.  Admittedly, I am really only using this for wireless and for a couple of other hardwire connections to make printing easier so this may not be using the router to its fullest, but for me, it doesnt matter.

 

I am getting 220Mbps down on the AC ghz signal...not bad but I thought it would have pushed the full 300 since I have a solid signal.

Forget my previsous question...

 

Anywho, I tried all of the bridging instructions and none of it worked.  The NVG would never let me changed the IP address to anything that any of the posters suggested.  I ended up having to factory reset the NVG to get everything back to normal since all of the settings got jacked up.

 

So, for anyone else, there is another option...I simply plugged the router into one of the LAN ports on the NVG and it works fine.  Admittedly, I am really only using this for wireless and for a couple of other hardwire connections to make printing easier so this may not be using the router to its fullest, but for me, it doesnt matter.

 

I am getting 220Mbps down on the AC ghz signal...not bad but I thought it would have pushed the full 300 since I have a solid signal.

Re: How to put the Motorola NVG589 in 'bridge mode' (or as close as you can).

40 of 242 (74,295 Views)
0
(0)
  • Rate this reply
View profile
Apr 11, 2014 4:19:51 PM
0
(0)
Mentor
Edited by MoInSTL on Apr 11, 2014 at 4:22:07 PM

 Did you use Passthrough Mode, select DHCPS-Fixed?

 

I know it sounds obvious, but did you save your settings? Did you use your personal router MAC address in the NVG589?  Disable NVG wireless, turn off the firewall, etc? For the MAC address, I only had the PC connected and the NVG589 saw it.

 

You can leave the NVG IP adress the default if that's easier for you.  Just make sure the router is set to 192.168.2.1 for example.

 

I just turned 59 yesterday and am female. So if I can do it, you can too! Woman Very Happy

 

I took my time, printed out the instuctions and it worked the first time I thought. My personal router was not seeing my public WAN IP and was double routing (double NAT). If your personal router is showing 192.168.X.X it's probably doing double NAT.  Not a good thing. Since I also wanted to limit the number of DHCP addresses used I started over.  My router then had the public WAN IP set correctly. 104.0.8.2XX  As you can see, that address is different and is what is displayed on the Internet. The public WAN IP is assigned from Uverse and generally speaking cannot be changed.  Only a Uverse tech will cause it to change when moving your connection to another card for example.  

 

Sometimes is helps to see the steps short and sweet. http://www.dslreports.com/faq/17734

 Did you use Passthrough Mode, select DHCPS-Fixed?

 

I know it sounds obvious, but did you save your settings? Did you use your personal router MAC address in the NVG589?  Disable NVG wireless, turn off the firewall, etc? For the MAC address, I only had the PC connected and the NVG589 saw it.

 

You can leave the NVG IP adress the default if that's easier for you.  Just make sure the router is set to 192.168.2.1 for example.

 

I just turned 59 yesterday and am female. So if I can do it, you can too! Woman Very Happy

 

I took my time, printed out the instuctions and it worked the first time I thought. My personal router was not seeing my public WAN IP and was double routing (double NAT). If your personal router is showing 192.168.X.X it's probably doing double NAT.  Not a good thing. Since I also wanted to limit the number of DHCP addresses used I started over.  My router then had the public WAN IP set correctly. 104.0.8.2XX  As you can see, that address is different and is what is displayed on the Internet. The public WAN IP is assigned from Uverse and generally speaking cannot be changed.  Only a Uverse tech will cause it to change when moving your connection to another card for example.  

 

Sometimes is helps to see the steps short and sweet. http://www.dslreports.com/faq/17734

Re: How to put the Motorola NVG589 in 'bridge mode' (or as close as you can).

[ Edited ]
41 of 242 (74,283 Views)
0
(0)
  • Rate this reply
View profile
Jun 14, 2014 1:30:46 PM
0
(0)
Contributor

Hi guys,

 

I did all of the above but I have a slightly different setup.  My time capsule is not not directly plugged into the ATT modem.  But it is plugged into a Netgear 5 Port Switch with the Uverse box and then into the wall of my living room which routes back to the ATT modem.

 

So I was not able to connect the Time Capsule and ensure the 192.168.10.1 IP address.  So when I set the default internal server it is selecting 107.128.xxx.x which is my external IP address.  

 

This is okay and all works fine except every 24 hours or so the Time Capsule just loses it's network settings and I have to reboot it.  Then all is well for another 24 hours so I suspect a DHCP release problem and that I may need a fixed IP.  Any help appreciated.

 

Thanks

Antony

Hi guys,

 

I did all of the above but I have a slightly different setup.  My time capsule is not not directly plugged into the ATT modem.  But it is plugged into a Netgear 5 Port Switch with the Uverse box and then into the wall of my living room which routes back to the ATT modem.

 

So I was not able to connect the Time Capsule and ensure the 192.168.10.1 IP address.  So when I set the default internal server it is selecting 107.128.xxx.x which is my external IP address.  

 

This is okay and all works fine except every 24 hours or so the Time Capsule just loses it's network settings and I have to reboot it.  Then all is well for another 24 hours so I suspect a DHCP release problem and that I may need a fixed IP.  Any help appreciated.

 

Thanks

Antony

Re: How to put the Motorola NVG589 in 'bridge mode' (or as close as you can).

42 of 242 (73,321 Views)
0
(0)
  • Rate this reply
View profile
Jun 18, 2014 7:32:01 AM
0
(0)
Mentor

Probably stupid questions, but here goes:

 

1.  Does this process involve connecting a cable between the NVG589 and the personal router at all even when it's completed?

 

2.  When I'm done with the set-up, can I plug my LAN devices into the ASUS, the NVG589 or could I use both?  

 

3.  Should I reset the NVG589's subnet before even turning the ASUS on because isn't it possible they would conflict right off the bat?

 

4.   The Default Server Internal Address for the NVG589 is grayed out unless you switch to Default Mode for allocation.  I assume it's okay to temporarily do that, save, type in address and then switch back to Passthrough for allocation mode?

 

5.  Is the WAN address for the Asus its LAN MAC Address/Wireles 2.4GHz MAC address?

 

6.  Where do I change the Internet connection type to DHCP on the ASUS?  The LAN tab has a DHCP Server tab which reads "Enable the DHCP Server" which is "on" by default.

 

TIA.

Probably stupid questions, but here goes:

 

1.  Does this process involve connecting a cable between the NVG589 and the personal router at all even when it's completed?

 

2.  When I'm done with the set-up, can I plug my LAN devices into the ASUS, the NVG589 or could I use both?  

 

3.  Should I reset the NVG589's subnet before even turning the ASUS on because isn't it possible they would conflict right off the bat?

 

4.   The Default Server Internal Address for the NVG589 is grayed out unless you switch to Default Mode for allocation.  I assume it's okay to temporarily do that, save, type in address and then switch back to Passthrough for allocation mode?

 

5.  Is the WAN address for the Asus its LAN MAC Address/Wireles 2.4GHz MAC address?

 

6.  Where do I change the Internet connection type to DHCP on the ASUS?  The LAN tab has a DHCP Server tab which reads "Enable the DHCP Server" which is "on" by default.

 

TIA.

Re: How to put the Motorola NVG589 in 'bridge mode' (or as close as you can).

43 of 242 (73,226 Views)
0
(0)
  • Rate this reply
View profile
Jun 22, 2014 1:35:40 PM
0
(0)
Teacher
Edited by ddbear on Jun 22, 2014 at 1:37:56 PM

Important fix to frostcall's original post

 

This is a convoluted bridged mode workaround for the NVG589 and I hope AT&T fixes this with a firmware update.  I thought the "Power" tier was supposed to be an upgrade, but this NVG589 firmware is a major downgrade for users with 2nd routers, IP cameras, home automation systems, etc.

 

I couldn't reach the broadband public IP via dynamic DNS services for my security cameras until I made the following fix to the original instructions:

 


 

Personal router settings:

 

Instead of using Automatic IP (DHCP) for your personal router WAN type, give it a static private IP on the same subnet as the NVG589.  For example assign the following:

 

IP: 192.168.2.253

Subnet mask: 255.255.255.0

Default gateway: 192.168.2.254

Primary DNS server: 192.168.2.254

 

Settings on the NVG589:

 

Instead of DHCPS-fixed, select Default Server.

 

After selecting Default Server, you should see 192.168.2.253 filled in automatically in the Default Server Internal Address box.  This also sets the passthrough mode to DHCPS-fixed.  Restart the NVG589.

 



A huge problem remains, the lack of support for NAT loopback.

 

Has anyone figured out a workaround for this?  For example if your security cameras are using a dynamic DNS service to access the cameras from outside home, with port forwarding to route to the correct camera, this won't work while your viewing laptop is connected to the LAN.  In order to access the cameras, the address has to be changed back & forth from the friendly DNS name to the numeric IP address, depending whether you're on the public ISP or local home network.

 

Did AT&T even bother to test the NVG589 with people with 2nd routers and security cameras, home automation, etc. before such a widespread deployment? 

 

If AT&T is reading this, please fix the design flaws in the NVG589 firmware!

Important fix to frostcall's original post

 

This is a convoluted bridged mode workaround for the NVG589 and I hope AT&T fixes this with a firmware update.  I thought the "Power" tier was supposed to be an upgrade, but this NVG589 firmware is a major downgrade for users with 2nd routers, IP cameras, home automation systems, etc.

 

I couldn't reach the broadband public IP via dynamic DNS services for my security cameras until I made the following fix to the original instructions:

 


 

Personal router settings:

 

Instead of using Automatic IP (DHCP) for your personal router WAN type, give it a static private IP on the same subnet as the NVG589.  For example assign the following:

 

IP: 192.168.2.253

Subnet mask: 255.255.255.0

Default gateway: 192.168.2.254

Primary DNS server: 192.168.2.254

 

Settings on the NVG589:

 

Instead of DHCPS-fixed, select Default Server.

 

After selecting Default Server, you should see 192.168.2.253 filled in automatically in the Default Server Internal Address box.  This also sets the passthrough mode to DHCPS-fixed.  Restart the NVG589.

 



A huge problem remains, the lack of support for NAT loopback.

 

Has anyone figured out a workaround for this?  For example if your security cameras are using a dynamic DNS service to access the cameras from outside home, with port forwarding to route to the correct camera, this won't work while your viewing laptop is connected to the LAN.  In order to access the cameras, the address has to be changed back & forth from the friendly DNS name to the numeric IP address, depending whether you're on the public ISP or local home network.

 

Did AT&T even bother to test the NVG589 with people with 2nd routers and security cameras, home automation, etc. before such a widespread deployment? 

 

If AT&T is reading this, please fix the design flaws in the NVG589 firmware!

Re: How to put the Motorola NVG589 in 'bridge mode' (or as close as you can).

[ Edited ]
44 of 242 (73,113 Views)
0
(0)
  • Rate this reply
View profile
Jun 23, 2014 3:46:15 PM
0
(0)
Voyager

No matter what I try, I cannot change the subnet / netmask / DHCP range for the NVG589.

 

 

This is very frustrating....   Why can I at least not disable DHCP?     AT&T is crazy annoying with wanting to take over MY internal network settings so I can run on THEIR EXTERNAL network.

 

I've about had it with this and am extremely close to calling TWC up for an install...

 

The error I get on any network config I use is:

 

Address must be on network (192.169.2.0)

 

I get it no matter what I try...

 

I've tried the following:

 

device IPv4 address: 172.21.0.1
DHCPv4 start IP address: 172.21.0.7
DHCPv4 end IP address: 172.21.0.14
Subnet mask: 255.255.255.240

 

device IPv4 address: 10.0.0.1
DHCPv4 start IP address: 10.0.0.2
DHCPv4 end IP address: 10.0.0.5
Subnet mask: 255.255.255.240

 

device IPv4 address: 192.168.2.254
DHCPv4 start IP address: 192.168.2.1
DHCPv4 end IP address: 192.168.2.5
Subnet mask: 255.255.255.240

 

device IPv4 address: 192.169.2.254
DHCPv4 start IP address: 192.169.2.1
DHCPv4 end IP address:  192.169.2.5
Subnet mask: 255.255.255.0

 

(I've tried a subnet mask of 255.255.255.0 as well with all configs and increased the DHCP range.

 

Am I doing something wrong that I'm missing or did  AT&T disable this on my firmware?

 

Here's my sysinfo

 

System Information
ManufacturerMotorola
Model NumberNVG589
Serial Number66206465812288
Software Version9.1.0h12d19
MAC Addressxxxxxxxxx
First Use Date2014/03/31 20:00:26
Time Since Last Reboot02:04:51:36
Current Date/Time2014-06-23T17:45:31Z
Datapump VersionA2pv6F038k1.d24h
Legal Disclaimerxxxxx

No matter what I try, I cannot change the subnet / netmask / DHCP range for the NVG589.

 

 

This is very frustrating....   Why can I at least not disable DHCP?     AT&T is crazy annoying with wanting to take over MY internal network settings so I can run on THEIR EXTERNAL network.

 

I've about had it with this and am extremely close to calling TWC up for an install...

 

The error I get on any network config I use is:

 

Address must be on network (192.169.2.0)

 

I get it no matter what I try...

 

I've tried the following:

 

device IPv4 address: 172.21.0.1
DHCPv4 start IP address: 172.21.0.7
DHCPv4 end IP address: 172.21.0.14
Subnet mask: 255.255.255.240

 

device IPv4 address: 10.0.0.1
DHCPv4 start IP address: 10.0.0.2
DHCPv4 end IP address: 10.0.0.5
Subnet mask: 255.255.255.240

 

device IPv4 address: 192.168.2.254
DHCPv4 start IP address: 192.168.2.1
DHCPv4 end IP address: 192.168.2.5
Subnet mask: 255.255.255.240

 

device IPv4 address: 192.169.2.254
DHCPv4 start IP address: 192.169.2.1
DHCPv4 end IP address:  192.169.2.5
Subnet mask: 255.255.255.0

 

(I've tried a subnet mask of 255.255.255.0 as well with all configs and increased the DHCP range.

 

Am I doing something wrong that I'm missing or did  AT&T disable this on my firmware?

 

Here's my sysinfo

 

System Information
ManufacturerMotorola
Model NumberNVG589
Serial Number66206465812288
Software Version9.1.0h12d19
MAC Addressxxxxxxxxx
First Use Date2014/03/31 20:00:26
Time Since Last Reboot02:04:51:36
Current Date/Time2014-06-23T17:45:31Z
Datapump VersionA2pv6F038k1.d24h
Legal Disclaimerxxxxx

Re: How to put the Motorola NVG589 in 'bridge mode' (or as close as you can).

45 of 242 (73,065 Views)
0
(0)
  • Rate this reply
View profile
Jun 26, 2014 10:33:33 AM
0
(0)
Teacher

Since my previous post, I experimented with several different routers.  Some of them work with frostcall's settings (for example Linksys WRT1900AC), others will not work with those settings (for example D-Link DIR-868L) and require my settings instead to route traffic normally.

 

Therefore it appears that the peculiar pseudo-bridged mode on this NVG589 is implemented in some nonstandard way that behaves differently with different routers.  Try both, see which one works for yours.

Since my previous post, I experimented with several different routers.  Some of them work with frostcall's settings (for example Linksys WRT1900AC), others will not work with those settings (for example D-Link DIR-868L) and require my settings instead to route traffic normally.

 

Therefore it appears that the peculiar pseudo-bridged mode on this NVG589 is implemented in some nonstandard way that behaves differently with different routers.  Try both, see which one works for yours.

Re: How to put the Motorola NVG589 in 'bridge mode' (or as close as you can).

46 of 242 (72,994 Views)
0
(0)
  • Rate this reply
View profile
Jun 27, 2014 12:01:46 AM
0
(0)
Teacher
Edited by ddbear on Jun 27, 2014 at 12:02:28 AM

For the "standard" passthrough setting that works with the Linksys WRT1900AC, I noticed that the DNS is very slow (web pages slow to lookup initially).  When the Linksys fetches its DHCP setting, the primary DNS server is assigned to point to the NVG589 (192.168.2.254).

 

In order to assign my own direct DNS servers, I wrote down all the assigned WAN settings in my Linksys status screen, and then set the Linksys Internet connection to Static using these settings.  I entered my own preferred DNS servers, for example Google DNS 8.8.8.8 and 8.8.4.4.  I changed the firewall passthrough setting on the NVG589 to Manual

 

One step further, I used a free utility called namebench to find the fastest DNS servers, and it found the fastest AT&T DNS servers, so I used those.  Now my browsing tests on the Linksys WRT1900AC are much faster.

For the "standard" passthrough setting that works with the Linksys WRT1900AC, I noticed that the DNS is very slow (web pages slow to lookup initially).  When the Linksys fetches its DHCP setting, the primary DNS server is assigned to point to the NVG589 (192.168.2.254).

 

In order to assign my own direct DNS servers, I wrote down all the assigned WAN settings in my Linksys status screen, and then set the Linksys Internet connection to Static using these settings.  I entered my own preferred DNS servers, for example Google DNS 8.8.8.8 and 8.8.4.4.  I changed the firewall passthrough setting on the NVG589 to Manual

 

One step further, I used a free utility called namebench to find the fastest DNS servers, and it found the fastest AT&T DNS servers, so I used those.  Now my browsing tests on the Linksys WRT1900AC are much faster.

Re: How to put the Motorola NVG589 in 'bridge mode' (or as close as you can).

[ Edited ]
47 of 242 (72,964 Views)
Highlighted
4
(3)
  • Rate this reply
View profile
Solved
Jun 28, 2014 10:20:35 PM
4
(3)
Teacher

Also if anyone is experiencing very slow loading on some websites with the NVG589 and IP Passthrough, disable IPv6 on your personal router:

 

http://www.dslreports.com/forum/r29352935-New-AT-T-UVerse-Power-tier-slow-only-for-some-major-websit...

Also if anyone is experiencing very slow loading on some websites with the NVG589 and IP Passthrough, disable IPv6 on your personal router:

 

http://www.dslreports.com/forum/r29352935-New-AT-T-UVerse-Power-tier-slow-only-for-some-major-websites-

Re: How to put the Motorola NVG589 in 'bridge mode' (or as close as you can).

48 of 242 (72,908 Views)
Solution
0
(0)
  • Rate this reply
View profile
Jul 29, 2014 5:44:59 AM
0
(0)
Tutor

I was able to get things working, but like a few others, I'm unable to open any ports to the outside world.  My port forwarding rules are being defined by my router, which is behind the NVG589.  Everything is routed correctly inside my LAN, and I have internet access.

 

Ideally I'd like all ports to be open through the NGV589 to my router and use my router to forward and block.  'm thinking there's an issue with the two routers being on different subnets (192.168.1.* and 192.168.2.*).

 

Has anyone had any luck with this?

I was able to get things working, but like a few others, I'm unable to open any ports to the outside world.  My port forwarding rules are being defined by my router, which is behind the NVG589.  Everything is routed correctly inside my LAN, and I have internet access.

 

Ideally I'd like all ports to be open through the NGV589 to my router and use my router to forward and block.  'm thinking there's an issue with the two routers being on different subnets (192.168.1.* and 192.168.2.*).

 

Has anyone had any luck with this?

Re: How to put the Motorola NVG589 in 'bridge mode' (or as close as you can).

49 of 242 (72,221 Views)
0
(0)
  • Rate this reply
View profile
Jul 29, 2014 6:25:53 AM
0
(0)
ACE - Expert

If you're using your router as a router behind the RG, then you want it to have a different subnet on its LAN side from the RG's subnet.

If you're putting the NVG 589 in IP Passthrough mode, then all Internet traffic to your public address should flow through to your router, and you should set up your port mapping there.

What are you trying to do and how do you test it to know it's not working?

 

If you're using your router as a router behind the RG, then you want it to have a different subnet on its LAN side from the RG's subnet.

If you're putting the NVG 589 in IP Passthrough mode, then all Internet traffic to your public address should flow through to your router, and you should set up your port mapping there.

What are you trying to do and how do you test it to know it's not working?

 

*The views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.

Re: How to put the Motorola NVG589 in 'bridge mode' (or as close as you can).

50 of 242 (72,213 Views)
0
(0)
  • Rate this reply
View profile
Jul 29, 2014 8:57:32 AM
0
(0)
Tutor

Basically, I'm trying to use the NVG589 as a modem only, and handle all my routing with my Linksys router.  The only exception is that I understand my two TV boxes (one wireless) must be connected to the NVG589.

 

Currently I have the NVG589 set as 192.168.2.254 with DHCPv4 192.168.2.1-192.168.2.5 and subnet mask 255.255.255.0.  My Linksys router is set as 192.168.1.1 with subnet mask 255.255.255.0, gateway 0.0.0.0, local DNS 0.0.0.0.  (Note that I've also tried with gateway 192.168.2.254 with the same results)  All port forwarding rules are specified on my Linksys router, and I've disabled all packet filtering and advanced firewall rules on the NVG589.

 

TVs appear to be working fine, and the internet works.  Within the LAN, I can specify my external ip address and port number (i.e. ***.***.**.***:1234) and reach the service running on my server.  If I try to do the same from outside my LAN, I can't see the service.  I've also tested with canyouseeme.org, which also says my port appears closed.

 

Hopefully this makes sense, and thanks in advance for any help.

Basically, I'm trying to use the NVG589 as a modem only, and handle all my routing with my Linksys router.  The only exception is that I understand my two TV boxes (one wireless) must be connected to the NVG589.

 

Currently I have the NVG589 set as 192.168.2.254 with DHCPv4 192.168.2.1-192.168.2.5 and subnet mask 255.255.255.0.  My Linksys router is set as 192.168.1.1 with subnet mask 255.255.255.0, gateway 0.0.0.0, local DNS 0.0.0.0.  (Note that I've also tried with gateway 192.168.2.254 with the same results)  All port forwarding rules are specified on my Linksys router, and I've disabled all packet filtering and advanced firewall rules on the NVG589.

 

TVs appear to be working fine, and the internet works.  Within the LAN, I can specify my external ip address and port number (i.e. ***.***.**.***:1234) and reach the service running on my server.  If I try to do the same from outside my LAN, I can't see the service.  I've also tested with canyouseeme.org, which also says my port appears closed.

 

Hopefully this makes sense, and thanks in advance for any help.

Re: How to put the Motorola NVG589 in 'bridge mode' (or as close as you can).

51 of 242 (72,203 Views)
0
(0)
  • Rate this reply
View profile
Jul 29, 2014 9:07:36 AM
0
(0)
ACE - Expert

So... you have the WAN side IP address of your router statically set to 192.168.2.something, or you're allowing to to be acquired via DHCP?   If DHCP, are you getting a 192.168.2.something address or are you getting your public address?

 

I'm guessing you have all this correct because you seem to be saying that your router is bouncing your public IP address traffic back into your LAN (which some users have quite a fit getting to work correctly), but I want to be sure.

 

Also, would the port you're attempting to use be something that maybe the NVG 589 uses and won't pass.  Examples would be the default SSL port (443) [if you have a wireless TV receiver and WAP] and possibly the SIP ports.  Also, you should not have any port forwarding rules set up for these on the NVG 589, just on your router.

 

 

So... you have the WAN side IP address of your router statically set to 192.168.2.something, or you're allowing to to be acquired via DHCP?   If DHCP, are you getting a 192.168.2.something address or are you getting your public address?

 

I'm guessing you have all this correct because you seem to be saying that your router is bouncing your public IP address traffic back into your LAN (which some users have quite a fit getting to work correctly), but I want to be sure.

 

Also, would the port you're attempting to use be something that maybe the NVG 589 uses and won't pass.  Examples would be the default SSL port (443) [if you have a wireless TV receiver and WAP] and possibly the SIP ports.  Also, you should not have any port forwarding rules set up for these on the NVG 589, just on your router.

 

 

*The views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.

Re: How to put the Motorola NVG589 in 'bridge mode' (or as close as you can).

52 of 242 (72,199 Views)
0
(0)
  • Rate this reply
View profile
Jul 29, 2014 9:48:53 AM
0
(0)
Tutor

WAN is set to DHCP on my Linksys, and it's successfully obtaining the public ip.

 

The ports I'm testing are fairly arbitrary and not typically blocked by an ISP.  Strangely enough, I tried a few other ports just to double check, and I noticed that ports forwarded to another server running on the same subnet are visable.  It sounds like there might be an issue with my server itself.  I'll have to dig around since to my knowledge I haven't changed anything with regards to the Linksys router or any of my servers.  All I've done is swap out my old cable modem from Cox to my NVG589 from Uverse, and everything was working fine before the swap.

 

It's strange though because everything works fine from within the LAN, even when specifying the public ip.

 

Thanks

WAN is set to DHCP on my Linksys, and it's successfully obtaining the public ip.

 

The ports I'm testing are fairly arbitrary and not typically blocked by an ISP.  Strangely enough, I tried a few other ports just to double check, and I noticed that ports forwarded to another server running on the same subnet are visable.  It sounds like there might be an issue with my server itself.  I'll have to dig around since to my knowledge I haven't changed anything with regards to the Linksys router or any of my servers.  All I've done is swap out my old cable modem from Cox to my NVG589 from Uverse, and everything was working fine before the swap.

 

It's strange though because everything works fine from within the LAN, even when specifying the public ip.

 

Thanks

Re: How to put the Motorola NVG589 in 'bridge mode' (or as close as you can).

53 of 242 (72,193 Views)
5
(1)
  • Rate this reply
View profile
Jul 29, 2014 11:42:00 AM
5
(1)
Tutor

It ended up being an issue with my main server.  Corrected that and everything seems find.  Appreciate the feedback.

It ended up being an issue with my main server.  Corrected that and everything seems find.  Appreciate the feedback.

Re: How to put the Motorola NVG589 in 'bridge mode' (or as close as you can).

54 of 242 (72,185 Views)
0
(0)
  • Rate this reply
View profile
Jul 31, 2014 6:52:53 PM
0
(0)
Contributor
Edited by zmaynard67 on Jul 31, 2014 at 6:54:36 PM

I have done all above (except the IPTV part, im not sure where to do this).

 

The only issue I am having is that i would like my TV boxes to be plugged into my main router, not my RG. I have a Netgear Firehawk R7000. (I have a switch that is running my HTPC and my DVR. I need my HTPC to be on the same subnet as my unRaid server on a different floor of my home).

 

I can get them to work, but after 20seconds on any single channel it says they lose connection, however if you change the channel they will begin working again for another 20seconds.

 

Any ideas?

 

Device IPv4 Address: 192.168.2.254

Subnet Mask: 255.255.255.0

DHCPv4 Start: 192.168.1.2

DHCPv4 End: 192.168.1.5

 

R7000 IP: 10.10.10.1

Subnet : 255.255.255.0

 

Let me know if you need any more info.

I have done all above (except the IPTV part, im not sure where to do this).

 

The only issue I am having is that i would like my TV boxes to be plugged into my main router, not my RG. I have a Netgear Firehawk R7000. (I have a switch that is running my HTPC and my DVR. I need my HTPC to be on the same subnet as my unRaid server on a different floor of my home).

 

I can get them to work, but after 20seconds on any single channel it says they lose connection, however if you change the channel they will begin working again for another 20seconds.

 

Any ideas?

 

Device IPv4 Address: 192.168.2.254

Subnet Mask: 255.255.255.0

DHCPv4 Start: 192.168.1.2

DHCPv4 End: 192.168.1.5

 

R7000 IP: 10.10.10.1

Subnet : 255.255.255.0

 

Let me know if you need any more info.

Re: How to put the Motorola NVG589 in 'bridge mode' (or as close as you can).

[ Edited ]
55 of 242 (72,076 Views)
0
(0)
  • Rate this reply
View profile
Jul 31, 2014 7:26:42 PM
0
(0)
ACE - Expert
Edited by JefferMC on Jul 31, 2014 at 7:29:15 PM

The problem, @zmaynard67 , is that your router doesn't know how to handle multicast properly.  When you change channels on a U-verse Set Top Box (STB), it starts a unicast stream which you get to see immediately, while also starting a multicast stream by sending an IGMPv3 com up the line to request it.  Once the STB starts getting the multicast stream, it matches up the packet sequence with the unicast stream and switches over.  After 10-20 seconds, the unicast stream is stopped.

So... when your home consumer grade router gets the unicast request packet, it's a standard looking TCP/IP packet and it forwards it to the RG to be handled up the line, no problem. The unicast TV feed in return is also fairly standard UDP stream and the router passes it from the RG to the STB without issue. So you get to start watching your new program.  However, when the IGMPv3 multicast request comes up from the STB, your router takes one look at the smelly multicast addressing and strange protocol type and promptly drops that thing on your carpet (you need to clean that up, by the way). Smiley Wink  If the multicast downstream just magically started anyway, the router may (or may not) decide to route the multicast packets. If it's a wireless router, transmitting those multicast packets is not a good thing for your network, because it goes into a slow mode to try to reduce the chance of errored/dropped packets, since the multicast packets cannot be requested to be resent, which just gums up your whole Ethernet network, wired and wireless.  In any case, in 10-20 seconds the unicast flow stops and your STB doesn't have the multicast stream, so your program stops.

In short, do not attempt to pass IPTV traffic through your garden variety router.

You can have more success with passing it through gigabit switches, so long as you don't put a wireless access point/router on the same switch farm with the IPTV traffic (for the above mentioned reason).  If you're bound and determined to mix IPTV traffic with IP traffic to an remote STB and wireless router, then you'll have to spring for two managed routers that can do VLANs with tagging and handle it that way.

 

 

The problem, @zmaynard67 , is that your router doesn't know how to handle multicast properly.  When you change channels on a U-verse Set Top Box (STB), it starts a unicast stream which you get to see immediately, while also starting a multicast stream by sending an IGMPv3 com up the line to request it.  Once the STB starts getting the multicast stream, it matches up the packet sequence with the unicast stream and switches over.  After 10-20 seconds, the unicast stream is stopped.

So... when your home consumer grade router gets the unicast request packet, it's a standard looking TCP/IP packet and it forwards it to the RG to be handled up the line, no problem. The unicast TV feed in return is also fairly standard UDP stream and the router passes it from the RG to the STB without issue. So you get to start watching your new program.  However, when the IGMPv3 multicast request comes up from the STB, your router takes one look at the smelly multicast addressing and strange protocol type and promptly drops that thing on your carpet (you need to clean that up, by the way). Smiley Wink  If the multicast downstream just magically started anyway, the router may (or may not) decide to route the multicast packets. If it's a wireless router, transmitting those multicast packets is not a good thing for your network, because it goes into a slow mode to try to reduce the chance of errored/dropped packets, since the multicast packets cannot be requested to be resent, which just gums up your whole Ethernet network, wired and wireless.  In any case, in 10-20 seconds the unicast flow stops and your STB doesn't have the multicast stream, so your program stops.

In short, do not attempt to pass IPTV traffic through your garden variety router.

You can have more success with passing it through gigabit switches, so long as you don't put a wireless access point/router on the same switch farm with the IPTV traffic (for the above mentioned reason).  If you're bound and determined to mix IPTV traffic with IP traffic to an remote STB and wireless router, then you'll have to spring for two managed routers that can do VLANs with tagging and handle it that way.

 

 

*The views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.

Re: How to put the Motorola NVG589 in 'bridge mode' (or as close as you can).

[ Edited ]
56 of 242 (72,072 Views)
0
(0)
  • Rate this reply
View profile
Jul 31, 2014 7:30:32 PM
0
(0)
Contributor

It seems like unchecking the "disable IGMP Proxying" box has fixed the issue. I will watch for slowdown however, and adjust if need be.

 

Thanks for the help.

It seems like unchecking the "disable IGMP Proxying" box has fixed the issue. I will watch for slowdown however, and adjust if need be.

 

Thanks for the help.

Re: How to put the Motorola NVG589 in 'bridge mode' (or as close as you can).

57 of 242 (72,068 Views)
0
(0)
  • Rate this reply
View profile
Aug 21, 2014 2:18:50 PM
0
(0)
Tutor

Exact same problem here, and it's driving me nuts. Tried power cycling the NV, resetting everything to default, etc., and it still won't accept/hold any of the new IP settings. I can't get past the initial stage of trying to change the subnet / netmask / DHCP range as you note below. The only thing connected to the NV is my laptop, by cable.

 

(BTW, I've tried letting the lappy get its IP via DHCP and by fixing it myself. Same problem either way.)

 

Has anyone figured out a way to get around this for NV's that seem to be "stuck"?

 

 


amenic wrote:

No matter what I try, I cannot change the subnet / netmask / DHCP range for the NVG589.

 

 

This is very frustrating....   Why can I at least not disable DHCP?     AT&T is crazy annoying with wanting to take over MY internal network settings so I can run on THEIR EXTERNAL network.

 

I've about had it with this and am extremely close to calling TWC up for an install...

 

The error I get on any network config I use is:

 

Address must be on network (192.169.2.0)

 

I get it no matter what I try...

 

I've tried the following:

 

device IPv4 address: 172.21.0.1
DHCPv4 start IP address: 172.21.0.7
DHCPv4 end IP address: 172.21.0.14
Subnet mask: 255.255.255.240

 

device IPv4 address: 10.0.0.1
DHCPv4 start IP address: 10.0.0.2
DHCPv4 end IP address: 10.0.0.5
Subnet mask: 255.255.255.240

 

device IPv4 address: 192.168.2.254
DHCPv4 start IP address: 192.168.2.1
DHCPv4 end IP address: 192.168.2.5
Subnet mask: 255.255.255.240

 

device IPv4 address: 192.169.2.254
DHCPv4 start IP address: 192.169.2.1
DHCPv4 end IP address:  192.169.2.5
Subnet mask: 255.255.255.0

 

(I've tried a subnet mask of 255.255.255.0 as well with all configs and increased the DHCP range.

 

Am I doing something wrong that I'm missing or did  AT&T disable this on my firmware?

 

 

Exact same problem here, and it's driving me nuts. Tried power cycling the NV, resetting everything to default, etc., and it still won't accept/hold any of the new IP settings. I can't get past the initial stage of trying to change the subnet / netmask / DHCP range as you note below. The only thing connected to the NV is my laptop, by cable.

 

(BTW, I've tried letting the lappy get its IP via DHCP and by fixing it myself. Same problem either way.)

 

Has anyone figured out a way to get around this for NV's that seem to be "stuck"?

 

 


amenic wrote:

No matter what I try, I cannot change the subnet / netmask / DHCP range for the NVG589.

 

 

This is very frustrating....   Why can I at least not disable DHCP?     AT&T is crazy annoying with wanting to take over MY internal network settings so I can run on THEIR EXTERNAL network.

 

I've about had it with this and am extremely close to calling TWC up for an install...

 

The error I get on any network config I use is:

 

Address must be on network (192.169.2.0)

 

I get it no matter what I try...

 

I've tried the following:

 

device IPv4 address: 172.21.0.1
DHCPv4 start IP address: 172.21.0.7
DHCPv4 end IP address: 172.21.0.14
Subnet mask: 255.255.255.240

 

device IPv4 address: 10.0.0.1
DHCPv4 start IP address: 10.0.0.2
DHCPv4 end IP address: 10.0.0.5
Subnet mask: 255.255.255.240

 

device IPv4 address: 192.168.2.254
DHCPv4 start IP address: 192.168.2.1
DHCPv4 end IP address: 192.168.2.5
Subnet mask: 255.255.255.240

 

device IPv4 address: 192.169.2.254
DHCPv4 start IP address: 192.169.2.1
DHCPv4 end IP address:  192.169.2.5
Subnet mask: 255.255.255.0

 

(I've tried a subnet mask of 255.255.255.0 as well with all configs and increased the DHCP range.

 

Am I doing something wrong that I'm missing or did  AT&T disable this on my firmware?

 

 

Re: How to put the Motorola NVG589 in 'bridge mode' (or as close as you can).

58 of 242 (71,139 Views)
0
(0)
  • Rate this reply
View profile
Aug 26, 2014 6:39:35 AM
0
(0)
Tutor

so what is the best option for running the NVG589 with a Apple Extreme Router (tower version). my set up includes 3 STB with 2 hardwired & 1 wireless. iMac computer, but we consume most of our internet via our wifi devices.

 

bridge the NVG589 and use the AE as my router and wife?

 

when you bridge the NVG589 is it best to shut of its wireless radio. mine is in the basement which could help provide wifi down there while the AE is on the main level providing coverage there. not sure if the two conflict with each other.

 

right now i just have the AE in bridge mode providing additional ethernet ports and wifi on the main level.

 

much thanks.

 

 

so what is the best option for running the NVG589 with a Apple Extreme Router (tower version). my set up includes 3 STB with 2 hardwired & 1 wireless. iMac computer, but we consume most of our internet via our wifi devices.

 

bridge the NVG589 and use the AE as my router and wife?

 

when you bridge the NVG589 is it best to shut of its wireless radio. mine is in the basement which could help provide wifi down there while the AE is on the main level providing coverage there. not sure if the two conflict with each other.

 

right now i just have the AE in bridge mode providing additional ethernet ports and wifi on the main level.

 

much thanks.

 

 

Re: How to put the Motorola NVG589 in 'bridge mode' (or as close as you can).

59 of 242 (70,904 Views)
0
(0)
  • Rate this reply
View profile
Aug 26, 2014 12:09:58 PM
0
(0)
Tutor

I am having the same problem with the multicasting and 10-20sec drops. when i plug the vip2250 into the nvg589, i get no connection. How do i get it to connect?

I am having the same problem with the multicasting and 10-20sec drops. when i plug the vip2250 into the nvg589, i get no connection. How do i get it to connect?

Re: How to put the Motorola NVG589 in 'bridge mode' (or as close as you can).

60 of 242 (70,877 Views)
Advanced
You must be signed in to add attachments
Share this post
Share this post