Explore & discover

Helpful Links

Mercury USB - Software Won't Install and...

Mercury USB - Software Won't Install and...

I purchased the Mercury USB last evening (along with plan). When I plug it into my machine, my machine freezes entirely and the communication manager never installs. The ENTIRE computer freezes - the clock doesn't even advance.
I spent an hour and a half on the phone with 3 different levels of technical support. The last attempt involved me 'letting it go' for another hour and a half, whereupon the tech support called back to see how it went (she said that 'someone said' sometimes the install takes a long time with XP Pro SP3 - BS IMO, but I went along).
When she called back, I told her that not only was I frozen but NOTHING was happening (NO disk activity, no advance of clock - displayed the time that the device was plugged in).
I'm trying this on a desktop so I can SEE it works, before investing in a laptop. I gave the tech support rep the link to my hardware config (manufacturer's website) so she could verify between calls (she wanted to). She said there's no problem at all with my hardware config.
Has anyone else had this problem? If so, what was the resolution?
Next step is to install communication manager from USB flash - downloaded today. I'll try that when I get home from work and tech support is supposed to call me back to see if install works.
Thanks in advance for any feedback.
Message 1 of 5

Re: Mercury USB - Software Won't Install and...

Try downloading and installing ATT Comm Manager 6.8.104 from the ATT website. That may stop it from freezing.


I am an AT&T employee and the postings on this site are my own and don’t necessarily represent AT&T’s positions, strategies or opinions.
Message 2 of 5

Re: Mercury USB - Software Won't Install and...

Have you tried installing ACM while in selective startup to see if it may be a software conflict?

In Windows XP:

Start -> Run

Enter 'msconfig'.

This should bring up the System Configuration Utility. On the General tab, select 'Selective Startup'. On the Startup tab, select 'Disable All'. Click OK. Restart the computer.

When you log in, you should see a message informing you of the fact that you just used the System Configuration Utility to change the way Windows starts. Click OK. Cancel out of the System Configuration Utility if it opens.

Try installing ACM. If it does the same thing or when it finishes, remember to put yourself back in normal startup when you're done. It's a very similar process. Just change the selection to Normal Startup and make sure all the startup items got checked again and restart.


I am an AT&T employee and the postings on this site are my own and don’t necessarily represent AT&T’s positions, strategies or opinions.
Message 3 of 5
Accepted by topic author
Accepted by Ustonz2000
‎09-30-2015 1:39 AM

Re: Mercury USB - Software Won't Install and... IT WORKS

When I got home, I installed the ACM from Flash. That did the trick. When tech support called, I was able to pump her instead for info on proper settings so it actually performed acceptably -- I was accustomed to dial-up speeds (on an older, crappy computer) and initially it was about the same. Once settings adjusted, it works acceptably. No, it's not blazing fast -- but it is good enough for me. Unless... tonight's just a fluke.
No BSOD yet... so far, so good.
Have a good evening.
Message 4 of 5

Re: Mercury USB - Software Won't Install and...

I had that same issue.


1.     Open up Device Manager

(XP: start-right click on My computer-properties-hardware tab- Device Manager)

(Vista: Circle-control panel-device manager)

2.       Look for “Other Devices”

3.       In other devices locate any driver related to the air card that i.e. HSDPA Modem etc. 

** A hint, Other Devices usually have a big yellow ? then other devices. **

4.       Right Click and Uninstall any of these drivers

5.       Remove the card for a few seconds and reinsert it

6.       Check the device manager after the computer states “your devices are installed and ready to use”

·         Look for other devices, if it isn’t there, that’s great.

7.       Open up AT&T Communication manager, If it allows you to connect, connect and attempt to browse

8.       If it does not allow you to connect and all drivers are showing in the proper location uninstall these drivers and reconnect

9.       If still not working reboot and re-attempt


Message Edited by cs10399 on 09-26-2008 01:31:58 AM
Message 5 of 5
Share this topic
Share this topic
Additional Support