Explore & discover

Helpful Links

Only 480p on wireless genie mini

Highlighted
Teacher

Only 480p on wireless genie mini

I’ve read through previous posts, did the troubleshooting to no avail. Usually this always works, and I am aware of the issue causing the resolution to reset and default to 480. 

What I have tried so far, see below:

1. Press Info > Arrow to the right where it says: "Audio/Video"

2. Press Select on "Change Resolution & Format" until it says: 1080i + Original Format

 

If it doesn't cycle through anything other than 480p then follow this: 

 

1. Press Menu > Settings & Help > Settings > Display > TV Resolutions

2. Make sure there is a checkmark next to 720p and 1080i, If there isn't just highlight the box to the left of the resolution and press the select button. 

 

The 2nd part, actually works, once I select 1080, the resolution clearly changes, says it is supported, please select info to proceed. And then once I hit info it defaults back to 480. 

I have pulled the power plug, reset button, over and over again. I am very used to doing this on a daily basis unfortunately and it always works. Not this time. 

These wireless genies are a nightmare, I should have listened to my tech when he said not to get them. Not sure why they are even offered. 

For now, I’m back to watching the NBA in 480 likes it’s 1999 all over again!

1,284 Views
Message 1 of 3
Teacher
Solution
Accepted by topic author
Accepted by Jagonz2
‎12-25-2018 9:30 AM

Re: Only 480p on wireless genie mini

Ok I found a post I had not seen before and found a fix that seems to work every time. 

Hold down the EXIT button on your remote for 8-10 seconds, or until it says something like “your settings have returned to your original HD format” or something like that. 

Seened to fix everything very easily, and all my settings are corrected. 

Will make note of this. 

Tags (1)
Message 2 of 3
Contributor

Re: Only 480p on wireless genie mini

Have had the same issue. Tech was out today, said there was nothing they could do.  Then I saw the Exit button recommendation and it worked!  Thanks

Message 3 of 3
Share this topic
Share this topic
Additional Support