Blackberry Torch: Needs a MAJOR software update:

Guru

Blackberry Torch: Needs a MAJOR software update:

First off, let me say, I love the Torch for the most part.....and usually, I don't EVER buy the 1st batch when the phone comes out. Usually, I am patient, and this time I wasn't, and I wish I was. I need to know if I am the only one with this....the phone has  a delay after putting the password on the phone. Also, using the internet with the WIFI, it lags big time. On regular 3G, its fine. I've done everything such as resetting the phone, doing battery pulls. Help! PLEASE! Please advise?    

Message 1 of 9 (5,054 Views)
Contributor

Re: Blackberry Torch: Needs a MAJOR software update:

Try www.crackberry.com - their forums are full of helpful people willing to help.

Message 2 of 9 (5,008 Views)
Guru

waRe: Blackberry Torch: Needs a MAJOR software update:


XtrapOL8 wrote:

Try www.crackberry.com - their forums are full of helpful people willing to help.


I'm always on crackberry's website....and I did see a leaked software update, but I rather wait until at&t comes out with one. Patience is getting short and You can't risk it.....Thanks anyway!  

Message 3 of 9 (4,970 Views)

Re: waRe: Blackberry Torch: Needs a MAJOR software update:


ested23 wrote:

XtrapOL8 wrote:

Try www.crackberry.com - their forums are full of helpful people willing to help.


I'm always on crackberry's website....and I did see a leaked software update, but I rather wait until at&t comes out with one. Patience is getting short and You can't risk it.....Thanks anyway!  


 

I can tell you from YEARS of BB experience--AT&T will probably NEVER provide us with a "supported" OS update.  Now, I'm with you on the "never buy from the 1st batch"--although I did this time around.  However, since launch date, 2 "leak OS"s have been found online.  Both GREATLY improved the performance from the out-of-box OS 6.0.0.141 and are EXTREMELY easy to install w/ backup.  I encourage you to at least try one.  Remember--the OS CAN be reverted back to out-of-box specifications.  Updating an OS does NOT void the warranty, but is also NOT supported by the carrier UNLESS that carrier (i.e. AT&T) makes the update "official".  Hope this helps.

Message 4 of 9 (4,814 Views)
Highlighted
Professor
Solution
Accepted by topic author ested23
‎09-30-2015 1:39 AM

Re: waRe: Blackberry Torch: Needs a MAJOR software update:

 


bbjunkie1906 wrote:

ested23 wrote:

XtrapOL8 wrote:

Try www.crackberry.com - their forums are full of helpful people willing to help.


I'm always on crackberry's website....and I did see a leaked software update, but I rather wait until at&t comes out with one. Patience is getting short and You can't risk it.....Thanks anyway!  


 

I can tell you from YEARS of BB experience--AT&T will probably NEVER provide us with a "supported" OS update.  Now, I'm with you on the "never buy from the 1st batch"--although I did this time around.  However, since launch date, 2 "leak OS"s have been found online.  Both GREATLY improved the performance from the out-of-box OS 6.0.0.141 and are EXTREMELY easy to install w/ backup.  I encourage you to at least try one.  Remember--the OS CAN be reverted back to out-of-box specifications.  Updating an OS does NOT void the warranty, but is also NOT supported by the carrier UNLESS that carrier (i.e. AT&T) makes the update "official".  Hope this helps.


Do you think that RIM will release an offical OS upgrade in our life time?

 

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Zombie Hunter Mission Statement

Exterminate the living dead and keep our fellow citizens alive and safe. We will be connecting with our fellow businesses, the police department, funeral home, and weapon manufacturers to help map out, and exterminate the pesky living dead from our community.

~~~Seth Mendenhall
Message 5 of 9 (4,789 Views)
Mentor

Re: waRe: Blackberry Torch: Needs a MAJOR software update:

Remember one very important thing:  All AT&T cares about is if YOU pay your BILL ! Any other problem is not their fault so they will blame RIM. Even if RIM has an update that AT&T fails to roll out, they will still blame RIM for it.

 

However if enough people buy the Torch, and have the same issues with it, they will address it just to retain customers who PAY their BILLS. AT&T is quickly losing ground in customer satisfaction. They are just above Sprint in this area. However Sprint lost ground when they sold a ton of towersto pay for their 4G effort which only covers a few metro ares and will stay that way for a very long time. and if Sprint was to gain the cash they need to roll out 4G everywhere, they will probably be fighting Verizon for first place again.

Message 6 of 9 (4,763 Views)
Guru

Re: waRe: Blackberry Torch: Needs a MAJOR software update:


ghostryder wrote:

 


bbjunkie1906 wrote:

ested23 wrote:

XtrapOL8 wrote:

Try www.crackberry.com - their forums are full of helpful people willing to help.


I'm always on crackberry's website....and I did see a leaked software update, but I rather wait until at&t comes out with one. Patience is getting short and You can't risk it.....Thanks anyway!  


 

I can tell you from YEARS of BB experience--AT&T will probably NEVER provide us with a "supported" OS update.  Now, I'm with you on the "never buy from the 1st batch"--although I did this time around.  However, since launch date, 2 "leak OS"s have been found online.  Both GREATLY improved the performance from the out-of-box OS 6.0.0.141 and are EXTREMELY easy to install w/ backup.  I encourage you to at least try one.  Remember--the OS CAN be reverted back to out-of-box specifications.  Updating an OS does NOT void the warranty, but is also NOT supported by the carrier UNLESS that carrier (i.e. AT&T) makes the update "official".  Hope this helps.


Do you think that RIM will release an offical OS upgrade in our life time?

 


Thank You!!! Great Advice....I will consider trying the OS that I saw on crackberry.  

Message 7 of 9 (4,724 Views)
Guru

Re: waRe: Blackberry Torch: Needs a MAJOR software update:


Irondog wrote:

Remember one very important thing:  All AT&T cares about is if YOU pay your BILL ! Any other problem is not their fault so they will blame RIM. Even if RIM has an update that AT&T fails to roll out, they will still blame RIM for it.

 

However if enough people buy the Torch, and have the same issues with it, they will address it just to retain customers who PAY their BILLS. AT&T is quickly losing ground in customer satisfaction. They are just above Sprint in this area. However Sprint lost ground when they sold a ton of towersto pay for their 4G effort which only covers a few metro ares and will stay that way for a very long time. and if Sprint was to gain the cash they need to roll out 4G everywhere, they will probably be fighting Verizon for first place again.


Irondog.....YOU ARE SO CORRECT! LMAO!!! 100%

Message 8 of 9 (4,723 Views)

Re: waRe: Blackberry Torch: Needs a MAJOR software update:


ested23 wrote:

ghostryder wrote:

 


bbjunkie1906 wrote:

ested23 wrote:

XtrapOL8 wrote:

Try www.crackberry.com - their forums are full of helpful people willing to help.


I'm always on crackberry's website....and I did see a leaked software update, but I rather wait until at&t comes out with one. Patience is getting short and You can't risk it.....Thanks anyway!  


 

I can tell you from YEARS of BB experience--AT&T will probably NEVER provide us with a "supported" OS update.  Now, I'm with you on the "never buy from the 1st batch"--although I did this time around.  However, since launch date, 2 "leak OS"s have been found online.  Both GREATLY improved the performance from the out-of-box OS 6.0.0.141 and are EXTREMELY easy to install w/ backup.  I encourage you to at least try one.  Remember--the OS CAN be reverted back to out-of-box specifications.  Updating an OS does NOT void the warranty, but is also NOT supported by the carrier UNLESS that carrier (i.e. AT&T) makes the update "official".  Hope this helps.


Do you think that RIM will release an official OS upgrade in our life time?

 

Considering how long OS 5 has been available for the Bold 9000, coupled with the fact that AT&T is only supporting 4.7 for that device, the simple answer is NO!  But not to be totally pessimistic--I'd say highly unlikely, but still probable.  SN:  Just "tested" Torch leak .225--LOVE IT!  .161 and .214 provide GREAT improvements over .141, but .225 is nice!  It still needs some tweaking, but is worth the load.  If you load a leaked OS, you can go back to .141 just as easily as you put the leak on your device.  I HIGHLY recommend it, as ANYTHING is better than the "stock" OS.

 

 

Message 9 of 9 (4,498 Views)
Share this topic
Announcements

Welcome to the AT&T Community Forums!!! Stop by the Community How-To section for tips on how to get started.